View Issue Details

IDProjectCategoryView StatusLast Update
0005224CentOS-6ptlibpublic2011-11-03 19:20
Reporterojab 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version6.0 
Target VersionFixed in Version 
Summary0005224: Wrong --libs in ptlib.pc
Description$ pkg-config ptlib --libs
-L/usr/lib6464 -lpt -lrt -lsasl2 -lldap -llber -lldap_r -lssl -lcrypto -lz -lexpat -lSDL -lpthread -lresolv -ldl

But there isn't libsasl2 installed
Steps To Reproduce1. Install CentOS-6.0 x64_64 with cr repo
2. yum install ptlib
3. cat > conftest.cpp << "EOF"
#include <ptbuildopts.h>
#include <ptlib.h>
int main ()
{
  PString str("");
  return 0;
}

EOF
4. $ g++ `pkg-config ptlib --cflags` `pkg-config ptlib --libs` conftest.cpp
/usr/bin/ld: cannot find -lsasl2
collect2: ld returned 1 exit status
Additional InformationName : ptlib
Arch : x86_64
Version : 2.6.5
Release : 3.el6
TagsNo tags attached.

Activities

ojab

ojab

2011-11-03 18:38

reporter   ~0013700

Yay, there is cyrus-sasl installed, but there isn't .so lib:
$ ls /usr/lib64/libsasl2.so*
/usr/lib64/libsasl2.so.2 /usr/lib64/libsasl2.so.2.0.23

And unfortunately I don't see any way to change Issue Category or close it :/
ojab

ojab

2011-11-03 18:42

reporter   ~0013701

…and there is /usr/lib64/libsasl2.so in cyrus-sasl-devel.

So .so sould be moved from -devel to cyrus-sasl.
Should I create a new Issue for cyrus-sasl or Category of this issue can be changed?

Name : cyrus-sasl
Arch : x86_64
Version : 2.1.23
Release : 8.el6
ojab

ojab

2011-11-03 18:45

reporter   ~0013702

And the same with /usr/lib64/libldap.so in openldap[-devel].
ojab

ojab

2011-11-03 18:46

reporter   ~0013703

…and it looks like centos-cr is broken ATM.
ojab

ojab

2011-11-03 18:51

reporter   ~0013704

…and the same with centos-6.0 without cr repo, wtf

cyrus-sasl-devel-2.1.23-8.el6.x86_64 : Files needed for developing applications with Cyrus SASL
Repo : base
Matched from:
Filename : /usr/lib64/libsasl2.so

openldap-devel-2.4.19-15.el6.x86_64 : LDAP development libraries and header files
Repo : base
Matched from:
Filename : /usr/lib64/libldap.so
tru

tru

2011-11-03 19:19

administrator   ~0013705

you are obviously missing q few *-devel packages in order to compile:
cyrus-sasl-devel
openldap-devel
openssl-devel
expat-devel
SDL-devel..

[tru@c6 ~]$ pkg-config ptlib --libs
-L/usr/lib6464 -lpt -lrt -lsasl2 -lldap -llber -lldap_r -lssl -lcrypto -lz -lexpat -lSDL -lpthread -lresolv -ldl

-> would have told you

The only cosmetic issue is the -L/usr/lib6464 <-double 64 which is also find upstream

[root@domU-12-31-38-04-C2-01 ~]# rpm -qif /usr/lib64/pkgconfig/ptlib.pc
Name : ptlib-devel Relocations: (not relocatable)
Version : 2.6.5 Vendor: Red Hat, Inc.
Release : 3.el6 Build Date: Tue 22 Jun 2010 12:13:18 PM EDT
Install Date: Thu 03 Nov 2011 03:16:57 PM EDT Build Host: x86-008.build.bos.redhat.com
Group : Development/Libraries Source RPM: ptlib-2.6.5-3.el6.src.rpm
Size : 1687486 License: MPLv1.0
Signature : RSA/8, Mon 16 Aug 2010 03:28:10 PM EDT, Key ID 199e2f91fd431d51
Packager : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL : http://www.opalvoip.org/
Summary : Development package for ptlib
Description :
The ptlib-devel package includes the libraries and header files for ptlib.
[root@domU-12-31-38-04-C2-01 ~]# grep 6464 /usr/lib64/pkgconfig/ptlib.pc
Libs: -L${libdir} -lpt${suffix} -lpthread -lrt -lsasl2 -lldap -llber -lldap_r -L/usr/lib6464 -lssl -lcrypto -ldl -lz -lexpat -lSDL -lpthread -lresolv -ldl
tru

tru

2011-11-03 19:20

administrator   ~0013706

not a bug but operator error

Issue History

Date Modified Username Field Change
2011-11-03 18:32 ojab New Issue
2011-11-03 18:38 ojab Note Added: 0013700
2011-11-03 18:42 ojab Note Added: 0013701
2011-11-03 18:45 ojab Note Added: 0013702
2011-11-03 18:46 ojab Note Added: 0013703
2011-11-03 18:51 ojab Note Added: 0013704
2011-11-03 19:19 tru Note Added: 0013705
2011-11-03 19:20 tru Note Added: 0013706
2011-11-03 19:20 tru Status new => resolved
2011-11-03 19:20 tru Resolution open => no change required