View Issue Details

IDProjectCategoryView StatusLast Update
0005238CentOS-6phppublic2012-05-16 19:16
Reportereu 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformx86_64OSCentOSOS Version6.0
Product Version6.0 
Target VersionFixed in Version 
Summary0005238: [Wed Nov 09 11:04:34 2011] [notice] child pid 4251 exit signal Segmentation fault (11)
Descriptionphp-*5.3.3-3.el6.x86_64
php-eaccelerator-0.9.6.1-1.el6.x86_64

php packages from centos-release-cr repository are incompatible with php-eaccelerator from epel

older php-*5.3.2-6.el6_0.1.x86_64 packages work.
Steps To Reproduceaccess any php script that uses mysql => blank page in browser, segmentation fault in apache
Additional InformationName : php Relocations: (not relocatable)
Version : 5.3.3 Vendor: CentOS
Release : 3.el6 Build Date: Wed 20 Jul 2011 12:58:20 PM EEST
Install Date: Thu 20 Oct 2011 04:31:42 PM EEST Build Host: c6b6.bsys.dev.centos.org
Group : Development/Languages Source RPM: php-5.3.3-3.el6.src.rpm
Size : 3697933 License: PHP
Signature : RSA/SHA1, Mon 26 Sep 2011 07:23:26 AM EEST, Key ID 0946fca2c105b9de
Packager : CentOS BuildSystem <http://bugs.centos.org>

Name : php-eaccelerator Relocations: (not relocatable)
Version : 0.9.6.1 Vendor: Fedora Project
Release : 1.el6 Build Date: Sat 03 Jul 2010 04:45:03 PM EEST
Install Date: Thu 04 Aug 2011 08:08:57 PM EEST Build Host: x86-20.phx2.fedoraproject.org
Group : Development/Languages Source RPM: php-eaccelerator-0.9.6.1-1.el6.src.rpm
Size : 321118 License: GPLv2+ and Zend
Signature : RSA/8, Sat 03 Jul 2010 07:23:48 PM EEST, Key ID 3b49df2a0608b895
Packager : Fedora Project
TagsNo tags attached.

Activities

tru

tru

2011-11-09 09:38

administrator   ~0013740

not nice, if it is the case also for RHEL6, fill a bug upstream, unless the API changes (unlikely) is documented somewhere on the 6.1 release notes.
eu

eu

2011-11-09 09:55

reporter   ~0013742

i can't test on RHEL6 because i don't have one around. also, i can't find anything about php API changes in the release notes for RHEL 6.1, but maybe i don't know where to look.
neteffekt

neteffekt

2011-11-16 17:03

reporter   ~0013771

Hi Guys after hours of pain trying to provision a new server using out stock set of modules it looks like we are running into this scenario also. Removing the e Accelerator module halts the seg faults.

We don't have access to RHEL6 either to confirm the upstream issue.
iik

iik

2011-12-14 10:43

reporter   ~0013917

we can confirm the segfault for the above mentioned versions. eaccelerator (from epel-repo) ran fine on CentOS 6.0 with PHP 5.3.2, but not when we updated on CentOS 6.1 (without centos-release-cr) and PHP 5.3.3. Looks like e-accelerator has to be re-compiled against PHP 5.3.3 ...
(sorry, no RHEL6 here either)
tigalch

tigalch

2012-05-16 19:16

manager   ~0015094

Last edited: 2012-05-21 17:28

View 2 revisions

you might also try filling a bug report against EPEL. Since EPEL is an additional repo this is not necessarily a C6 bug.

Issue History

Date Modified Username Field Change
2011-11-09 09:28 eu New Issue
2011-11-09 09:38 tru Note Added: 0013740
2011-11-09 09:55 eu Note Added: 0013742
2011-11-16 17:03 neteffekt Note Added: 0013771
2011-12-14 10:43 iik Note Added: 0013917
2012-05-16 19:16 tigalch Note Added: 0015094
2012-05-21 17:28 tigalch Note Edited: 0015094 View Revisions