View Issue Details

IDProjectCategoryView StatusLast Update
0005478CentOS-6librsvg2public2012-02-25 11:48
Reporterjoe.julian 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSCentOSOS Version6.2
Product Version6.2 
Target VersionFixed in Version 
Summary0005478: librsvg2 does not register it's capability with gtk2
DescriptionIn librsvg2-2.26.0-5.el6_1.1.x86_64 both %postinstall and %postuninstall scriptlets call:
 /usr/bin/update-gdk-pixbuf-loaders x86_64-unknown-linux-gnu
instead of:
 /usr/bin/update-gdk-pixbuf-loaders x86_64-redhat-linux-gnu
TagsNo tags attached.

Relationships

related to 0005299 closedkbsingh@karan.org CentOS-6 POSTUN warning during update to 6.1 
related to 0005158 resolvedIssue Tracker CentOS-6 centos6 BASH_VERSINFO[5]/MACHTYPE 
related to 0003496 acknowledgedJohnnyHughes CentOS-5 rpm uninstall of librsvg2-2.16.1-1.el5.i386 on an x86 system doesn't work 
related to 0005543 acknowledged CentOS-6 SVG graphics doesn't render properly 

Activities

toracat

toracat

2012-01-31 01:59

manager   ~0014377

I can confirm this.

librsvg2-2.26.0-5.el6 was rebuilt for centos 6.1 to correct the issue (bug #5158). However, it seems as if the problem is back in librsvg2-2.26.0-5.el6_1.1 (centos 6.2).
toracat

toracat

2012-02-23 23:54

manager   ~0014540

The 32-bit version has:

/usr/bin/update-gdk-pixbuf-loaders i686-pc-linux-gnu

where it's supposed to be:

/usr/bin/update-gdk-pixbuf-loaders i386-redhat-linux-gnu
toracat

toracat

2012-02-24 05:33

manager   ~0014542

Reminder sent to: JohnnyHughes

Regression.
toracat

toracat

2012-02-24 16:26

manager   ~0014545

Despite the note in bug #5281, it looks as if librsvg2 has not been rebuilt.

$ sudo yum list --showduplicates librsvg2
Installed Packages
librsvg2.i686 2.26.0-5.el6_1.1 @cr
Available Packages
librsvg2.i686 2.26.0-5.el6_1.1 base

If that is the case, this is not a regression but rather omission / failure to fix. :-(
JohnnyHughes

JohnnyHughes

2012-02-25 11:48

administrator   ~0014554

This has been fixed in version:

http://vault.centos.org/6.2/updates/Source/SPackages/librsvg2-2.26.0-5.el6_1.1.0.1.centos.src.rpm

(now released)

Issue History

Date Modified Username Field Change
2012-01-31 01:12 joe.julian New Issue
2012-01-31 01:37 toracat Relationship added related to 0005299
2012-01-31 01:38 toracat Relationship added related to 0005158
2012-01-31 01:38 toracat Status new => acknowledged
2012-01-31 01:45 toracat Relationship added related to 0003496
2012-01-31 01:59 toracat Note Added: 0014377
2012-02-23 23:32 toracat Relationship added related to 0005543
2012-02-23 23:54 toracat Note Added: 0014540
2012-02-24 05:33 toracat Note Added: 0014542
2012-02-24 16:26 toracat Note Added: 0014545
2012-02-25 11:48 JohnnyHughes Note Added: 0014554
2012-02-25 11:48 JohnnyHughes Status acknowledged => resolved
2012-02-25 11:48 JohnnyHughes Resolution open => fixed