View Issue Details

IDProjectCategoryView StatusLast Update
0005572CentOS-5kernelpublic2013-02-04 19:59
Reporterarrfab 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformCentOS 5.8OSOS Version
Product Version5.8 
Target VersionFixed in Version5.8 
Summary0005572: 802.1q VLAN tagging doesn't work with the 5.8 kernel and tg3 default kernel module
DescriptionDuring 5.8, we discovered that an update to the 5.8 kernel (2.6.18-308.el5) will break the VLAN setup due to a bug in the updated tg3 kernel module
More informations can be read on the upstream bugzilla tool : https://bugzilla.redhat.com/show_bug.cgi?id=798939
Tags5.8, tg3

Activities

arrfab

arrfab

2012-03-06 11:35

administrator   ~0014619

Just to add that the current workaround (except staying with the pre-5.8 kernel of course) is to install the kmod-tg3-rhel5u7 from the CentOS updates repository.
Even if it's marked as 5u7, it will work on 5.8 and fixes the 802.1q issue introduced in the tg3 module from the 5.8 kernel
toracat

toracat

2012-03-17 08:35

manager  

centos-tg3.patch (1,188 bytes)

commit 5c1e688388f629e8d8e88183b5ebc21e209252aa
Author: Kasper Pedersen <kernel@kasperkp.dk>
Date:   Tue Sep 20 12:41:17 2011 +0000

    tg3: fix VLAN tagging regression
    
    commit 92cd3a17ce9c719abb4c28dee3438e0c641f8de4
        tg3: Simplify tx bd assignments
    
    broke VLAN tagging on outbound packets.
    It ifdef'ed BCM_KERNEL_SUPPORTS_8021Q, but this
    is not set anywhere. So vlan never gets set, and
    all packets are sent with vlan=0.
    
    v2: We can just remove the test. vlan_tx_tag_present
    is valid regardless of whether the 802.1q module
    is built.
    
    Tested on BCM5721 rev 11.
    
    Signed-off-by: Kasper Pedersen <kernel@kasperkp.dk>
    Signed-off-by: David S. Miller <davem@davemloft.net>

    Applied by: Akemi Yagi <toracat@centos.org>

--- a/drivers/net/tg3.c.dist	2012-03-17 01:18:24.198410806 -0700
+++ b/drivers/net/tg3.c.new	2012-03-17 01:19:24.553357938 -0700
@@ -5866,12 +5866,10 @@
 		}
 	}
 
-#ifdef BCM_KERNEL_SUPPORTS_8021Q
 	if (vlan_tx_tag_present(skb)) {
 		base_flags |= TXD_FLAG_VLAN;
 		vlan = vlan_tx_tag_get(skb);
 	}
-#endif
 
 	if (tg3_flag(tp, USE_JUMBO_BDFLAG) &&
 	    !mss && skb->len > VLAN_ETH_FRAME_LEN)
centos-tg3.patch (1,188 bytes)
toracat

toracat

2012-03-17 08:38

manager   ~0014693

According to bleve, the bug will be fixed in the upstream kernel. The patch comes from:

linus tree commit 5c1e688388f629e8d8e88183b5ebc21e209252aa

I have uploaded the centos patch to be included in the next release of centosplus kernel.
moc

moc

2012-03-18 02:50

reporter   ~0014696

@arrfab Thanks, that did the trick... Server is a Dell 2650 onboard nic use tg3.
briancamp

briancamp

2012-04-12 13:47

reporter   ~0014821

Does anyone know if this issue has been addressed upstream?

The RH Bugzilla link gives me "You are not authorized to access bug #798939.".
toracat

toracat

2012-04-12 15:35

manager   ~0014826

Upstream BZ 798939 was marked as a duplicate of BZ 797011 which is also inaccessible.
toracat

toracat

2012-04-18 00:41

manager   ~0014843

kernel-2.6.18-308.4.1.el5 was released upstream today. The patch noted in 14693 was not there. The centosplus kernel is being built with the patch.
toracat

toracat

2012-04-19 00:47

manager   ~0014853

kernel-2.6.18-308.4.1.el5.centos.plus released that has the patch applied.
jsosic

jsosic

2012-04-26 07:04

reporter   ~0014943

kernel-2.6.18-308.4.1.el5.centos.plus fixed this issue for me, although I still see tg3 dump in dmesg
toracat

toracat

2012-04-26 17:28

manager   ~0014950

Anyone wishing to try tg3 version 3.122 (latest from Broadcom) can do so by installing kmod-tg3 from ELRepo:

http://lists.elrepo.org/pipermail/elrepo/2012-April/001186.html
toracat

toracat

2012-05-05 07:42

manager   ~0015026

According to the upstream BZ, "the fix will be in 5.9 although there will be a z-stream fix for 5.8 too." and "it is fixed in 6.3."
toracat

toracat

2012-05-29 21:47

manager   ~0015183

The patch appeared in kernel 2.6.18-308.8.1.el5 released today.
tigalch

tigalch

2013-02-04 19:59

manager   ~0016427

as per last post this got fixed in 2.6.18-308.8.1.el5

Issue History

Date Modified Username Field Change
2012-03-05 11:56 arrfab New Issue
2012-03-05 11:58 arrfab Tag Attached: 5.8
2012-03-05 15:00 arrfab Product Version => 5.8
2012-03-06 11:35 arrfab Note Added: 0014619
2012-03-17 08:35 toracat File Added: centos-tg3.patch
2012-03-17 08:38 toracat Note Added: 0014693
2012-03-18 02:50 moc Note Added: 0014696
2012-04-12 13:47 briancamp Note Added: 0014821
2012-04-12 15:35 toracat Note Added: 0014826
2012-04-18 00:41 toracat Note Added: 0014843
2012-04-19 00:47 toracat Note Added: 0014853
2012-04-19 00:48 toracat Status new => assigned
2012-04-25 16:38 toracat Tag Attached: tg3
2012-04-26 07:04 jsosic Note Added: 0014943
2012-04-26 17:28 toracat Note Added: 0014950
2012-05-05 07:42 toracat Note Added: 0015026
2012-05-29 21:47 toracat Note Added: 0015183
2013-02-04 19:59 tigalch Note Added: 0016427
2013-02-04 19:59 tigalch Status assigned => resolved
2013-02-04 19:59 tigalch Fixed in Version => 5.8
2013-02-04 19:59 tigalch Resolution open => fixed