View Issue Details

IDProjectCategoryView StatusLast Update
0005582CentOS-5kvmpublic2012-03-28 13:58
ReporterJohnnyHughes 
PriorityhighSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version5.8 
Target VersionFixed in Version 
Summary0005582: KVM guests crash on CentOS 5.8 kvm host
DescriptionI have had Random KVM Guest crashes on a KVM Host that is running the kernel-2.6.18-308.el5.x86_64 kernel.

More that one guest has crashed (and more than one OS on the guest). All the guests are using the Virtio hard drive driver.

I have upgraded the kernel to kernel-2.6.18-308.el5.1.1.x86_64 on the host and several of the EL 5 guests and will report if this makes it more stable.


This is also an issue upstream as noted here:

http://www.redhat.com/archives/rhelv5-list/2012-February/msg00060.html
TagsNo tags attached.

Activities

mfalb

mfalb

2012-03-11 02:21

reporter   ~0014654

It hit me too.
2 guests on the the same host went unresponsive. The only thing I did not update was the kernel on the host which was still running kernel-2.6.18-274.18.1.el5

Next I will downgrade kvm and kmod kvm on the host and kernel on the guests.
JohnnyHughes

JohnnyHughes

2012-03-11 12:44

administrator   ~0014656

Last edited: 2012-03-11 12:45

View 2 revisions

This seems to be related to the virtio disk driver .. or at least it is more prevalent on machines with the virtio disk driver.

http://www.redhat.com/archives/rhelv5-list/2012-March/msg00017.html

JohnnyHughes

JohnnyHughes

2012-03-11 12:52

administrator   ~0014657

Created this upstream bugzilla entry for this item:

http://bugzilla.redhat.com/show_bug.cgi?id=802118
eradish

eradish

2012-03-14 09:10

reporter   ~0014671

Was the advise to update kmod-kvm using http://people.redhat.com/myamazak/.kvm-83-249.affinity_fix.el5_8/ usefull?
eradish

eradish

2012-03-14 10:32

reporter   ~0014672

I've updated one of the hosts whith http://people.redhat.com/myamazak/.kvm-83-249.affinity_fix.el5_8/ I'll report results.
mfalb

mfalb

2012-03-14 20:21

reporter   ~0014677

I have a test machine running with the new kvm but it is running since more than 3 days now without crash. I did not manage to reproduce the problem on this machine so it does not make sense to try the "fixed" kvm, hmm, sorry.
eradish

eradish

2012-03-14 21:29

reporter   ~0014678

mfalb, are You using disk with virtio drivers?
eradish

eradish

2012-03-15 10:23

reporter   ~0014679

Report:
1 host - CentOS 5.8 + http://people.redhat.com/myamazak/.kvm-83-249.affinity_fix.el5_8/ - stable - uptime 24 hours

3 host - Centos 5.8 - KVM guest freezes during 12 hours.


http://people.redhat.com/myamazak/.kvm-83-249.affinity_fix.el5_8/ - solve the problem for now.

If there be some problems on host http://people.redhat.com/myamazak/.kvm-83-249.affinity_fix.el5_8/ - i'll report.
JohnnyHughes

JohnnyHughes

2012-03-21 13:58

administrator   ~0014710

This is now fixed with this version:

http://lists.centos.org/pipermail/centos-announce/2012-March/018517.html

in version:
kvm-83-249.el5.centos.0.0.1.src.rpm

Please check and verify this version corrects the problem.
eradish

eradish

2012-03-26 09:43

reporter   ~0014731

I've updated 1 host (3 guest inside using virtio drivers) with kvm-83-249.el5.centos.0.0.1.src.rpm.
Uptime: 3 days, 12:21 - no problem detected.

The problem is solved for me.

I'm going to update another 4 hosts.
mfalb

mfalb

2012-03-26 09:48

reporter   ~0014732

For me it seems solved too.
The machine were I had this problem is running longer than 4 days now.

Issue History

Date Modified Username Field Change
2012-03-08 17:00 JohnnyHughes New Issue
2012-03-11 02:21 mfalb Note Added: 0014654
2012-03-11 12:44 JohnnyHughes Note Added: 0014656
2012-03-11 12:45 JohnnyHughes Note Edited: 0014656 View Revisions
2012-03-11 12:52 JohnnyHughes Note Added: 0014657
2012-03-14 09:10 eradish Note Added: 0014671
2012-03-14 10:32 eradish Note Added: 0014672
2012-03-14 20:21 mfalb Note Added: 0014677
2012-03-14 21:29 eradish Note Added: 0014678
2012-03-15 10:23 eradish Note Added: 0014679
2012-03-21 13:58 JohnnyHughes Note Added: 0014710
2012-03-21 13:58 JohnnyHughes Status new => feedback
2012-03-26 09:43 eradish Note Added: 0014731
2012-03-26 09:48 mfalb Note Added: 0014732
2012-03-28 13:58 JohnnyHughes Status feedback => resolved
2012-03-28 13:58 JohnnyHughes Resolution open => fixed