View Issue Details

IDProjectCategoryView StatusLast Update
0005619CentOS-6libvirtpublic2013-03-12 19:11
Reportercac2s 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.2 
Target VersionFixed in Version6.4 
Summary0005619: "virsh save" command will throw an error when used with qemu and attached USB device to the host passed through to the guest
Description# cat /etc/libvirt/qemu/buhserver.xml
<!--
WARNING: THIS IS AN AUTO-GENERATED FILE. CHANGES TO IT ARE LIKELY TO BE
OVERWRITTEN AND LOST. Changes to this xml configuration should be made using:
  virsh edit buhserver
or other application using the libvirt API.
-->

<domain type='kvm'>
  <name>buhserver</name>
  <uuid>335f35d4-59b8-eba3-4cd3-c96547534903</uuid>
  <memory>2097152</memory>
  <currentMemory>2097152</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='i686' machine='rhel6.0.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <cpu>
    <topology sockets='1' cores='2' threads='1'/>
  </cpu>
  <clock offset='localtime'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source dev='/dev/vg_data/lv_buhserver_c'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </disk>
    <disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source dev='/dev/vg_data/lv_buhserver_d'/>
      <target dev='vdb' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>
    <disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source dev='/dev/vg_data/lv_buhserver_e'/>
      <target dev='vdc' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>
    <interface type='bridge'>
      <mac address='52:54:0b:ab:d5:e3'/>
      <source bridge='br0'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target type='serial' port='0'/>
    </console>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5901' autoport='no' keymap='en-us'/>
    <video>
      <model type='cirrus' vram='65536' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <hostdev mode='subsystem' type='usb' managed='yes'>
      <source>
        <vendor id='0x0529'/>
        <product id='0x0001'/>
        <address bus='2' device='2'/>
      </source>
    </hostdev>
    <memballoon model='none'/>
  </devices>
</domain>
Steps To Reproduce1. add to xml-file:

    <hostdev mode='subsystem' type='usb' managed='yes'>
      <source>
        <vendor id='0x0529'/>
        <product id='0x0001'/>
        <address bus='2' device='2'/>
      </source>
    </hostdev>

2. virsh start buhserver
3. virsh save buhserver ./buhserver_ram
error: Failed to save domain buhserver to ./buhserver_ram
error: internal error unable to execute QEMU command 'migrate': An undefined error has ocurred
Additional Information# cat /etc/issue
CentOS release 6.2 (Final)

# uname -a
Linux vm-server1 2.6.32-220.7.1.el6.x86_64 #1 SMP Wed Mar 7 00:52:02 GMT 2012 x86_64 x86_64 x86_64 GNU/Linux

# /usr/libexec/qemu-kvm --version
QEMU PC emulator version 0.12.1 (qemu-kvm-0.12.1.2), Copyright (c) 2003-2008 Fabrice Bellard

# virsh --version
0.9.4
Tagslibvirt, qemu, usb, virsh

Activities

cac2s

cac2s

2012-03-27 08:09

reporter   ~0014746

am I alone?
cac2s

cac2s

2012-05-28 13:59

reporter   ~0015175

There is no opportunity to save guest’s memory (RAM) to local folder ONLY in case if usb device is passed through to the guest. But without passed through usb device command "virsh save" works all right.
rmorriso

rmorriso

2012-06-04 07:17

reporter   ~0015211

cac2s is not alone. Same os and software release - same problem.
cac2s

cac2s

2013-03-12 18:43

reporter   ~0016679

the issue is resolved in 6.4 release
tigalch

tigalch

2013-03-12 19:11

manager   ~0016680

resolving per reporters feedback

Issue History

Date Modified Username Field Change
2012-03-26 09:36 cac2s New Issue
2012-03-26 10:15 cac2s Tag Attached: libvirt
2012-03-26 10:15 cac2s Tag Attached: usb
2012-03-26 10:15 cac2s Tag Attached: qemu
2012-03-26 10:15 cac2s Tag Attached: virsh
2012-03-27 08:09 cac2s Note Added: 0014746
2012-03-27 08:09 cac2s Status new => feedback
2012-05-28 13:59 cac2s Note Added: 0015175
2012-05-28 13:59 cac2s Status feedback => assigned
2012-06-04 07:17 rmorriso Note Added: 0015211
2013-03-12 18:43 cac2s Note Added: 0016679
2013-03-12 19:11 tigalch Note Added: 0016680
2013-03-12 19:11 tigalch Status assigned => resolved
2013-03-12 19:11 tigalch Fixed in Version => 6.4
2013-03-12 19:11 tigalch Resolution open => fixed