View Issue Details

IDProjectCategoryView StatusLast Update
0005651CentOS-6environment-modulespublic2012-06-13 14:12
ReporterMarbolanGos 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Product Version6.2 
Target VersionFixed in Version 
Summary0005651: Double purge in modules warns about undefined variable
DescriptionWhen using the environment-modules given in the base repo I have a bug. This is very simple to explain:
$ su -c 'yum install environment-modules'
$ module load dot
$ module purge
$ module purge
ModuleCmd_Purge.c(114):ERROR:107: 'MODULEPATH' not set

I would say that even if it appears, it does not blocks the modules so it is non-blocking but disturbing for production centers.
Additional Information# rpm -q environment-modules
environment-modules-3.2.7b-6.el6.x86_64

I have updated this package to the 3.2.9c by building my own rpm and the error disappears.
TagsNo tags attached.

Activities

tru

tru

2012-06-08 09:01

administrator   ~0015226

could you report it upstream for a permanent fix? (adding the patch would accelerate the fix, imho).
MarbolanGos

MarbolanGos

2012-06-13 14:12

reporter   ~0015253

Do you mean contacting Red Hat directly? Because I believe that the fix is updating the package to the version 3.2.9c I do not know where the real fix is.

Issue History

Date Modified Username Field Change
2012-04-10 07:23 MarbolanGos New Issue
2012-06-08 09:01 tru Note Added: 0015226
2012-06-13 14:12 MarbolanGos Note Added: 0015253