View Issue Details

IDProjectCategoryView StatusLast Update
0005711CentOS-5yumpublic2012-05-19 14:18
Reportermaxman 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionno change required 
Product Version5.1 
Target VersionFixed in Version 
Summary0005711: Missing Dependency: php-common
DescriptionHi
I'm a newbie, each time I try to yum a new backege in my server I got "Missing Dependency: php-common" i don't how or why to resolv it
please any help

regard
Majdy
Steps To Reproduce[root@mail ~]# apt-get install php5-xmlrpc
-bash: apt-get: command not found
[root@mail ~]# yum install php-xmlrpc
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.isoc.org.il
 * epel: mirrors.ircam.fr
 * extras: mirror.isoc.org.il
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: mirror.isoc.org.il
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xmlrpc.i386 0:5.1.6-32.el5 set to be updated
--> Processing Dependency: php-common = 5.1.6-32.el5 for package: php-xmlrpc
--> Finished Dependency Resolution
php-xmlrpc-5.1.6-32.el5.i386 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-32.el5 is needed by package php-xmlrpc-5.1.6-32.el5.i386 (base)
Error: Missing Dependency: php-common = 5.1.6-32.el5 is needed by package php-xmlrpc-5.1.6-32.el5.i386 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
========================================================================================
[root@mail ~]# yum install php-soap
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.isoc.org.il
 * epel: mirrors.ircam.fr
 * extras: mirror.isoc.org.il
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: mirror.isoc.org.il
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-soap.i386 0:5.1.6-32.el5 set to be updated
--> Processing Dependency: php-common = 5.1.6-32.el5 for package: php-soap
--> Finished Dependency Resolution
php-soap-5.1.6-32.el5.i386 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-32.el5 is needed by package php-soap-5.1.6-32.el5.i386 (base)
Error: Missing Dependency: php-common = 5.1.6-32.el5 is needed by package php-soap-5.1.6-32.el5.i386 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@mail ~]#
TagsNo tags attached.

Activities

avij

avij

2012-05-08 15:02

updater   ~0015047

A new version of PHP has just been released, version 5.1.6-34. Perhaps the mirror didn't have all the files yet.

Try this:
yum clean all
yum install php-common

If those succeed, proceed with
yum install php-xmlrpc php-soap
maxman

maxman

2012-05-09 13:37

reporter   ~0015052

Hi avij
thank you for your resbond
I try your step and I got the same issue with no succes any help.
thanks again

[root@mail ~]# yum clean all
Loaded plugins: fastestmirror, priorities, protectbase
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@mail ~]# yum install php-common
Loaded plugins: fastestmirror, priorities, protectbase
Determining fastest mirrors
 * base: centos.syn.co.il
 * epel: mirror.ibcp.fr
 * extras: centos.syn.co.il
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: centos.syn.co.il
base | 1.1 kB 00:00
base/primary | 967 kB 00:00
base 2725/2725
epel | 3.4 kB 00:00
epel/primary_db | 3.1 MB 00:03
extras | 2.1 kB 00:00
extras/primary_db | 169 kB 00:00
rpmforge | 1.9 kB 00:00
rpmforge/primary_db | 7.2 MB 00:06
updates | 1.9 kB 00:00
updates/primary_db | 295 kB 00:00
0 packages excluded due to repository protections
Setting up Install Process
Package matching php-common-5.1.6-34.el5_8.i386 already installed. Checking for update.
Nothing to do
[root@mail ~]# yum install php-xmlrpc
Loaded plugins: fastestmirror, priorities, protectbase
Loading mirror speeds from cached hostfile
 * base: centos.syn.co.il
 * epel: mirror.ibcp.fr
 * extras: centos.syn.co.il
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: centos.syn.co.il
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xmlrpc.i386 0:5.1.6-34.el5_8 set to be updated
--> Processing Dependency: php-common = 5.1.6-34.el5_8 for package: php-xmlrpc
--> Finished Dependency Resolution
php-xmlrpc-5.1.6-34.el5_8.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-34.el5_8 is needed by package php-xmlrpc-5.1.6-34.el5_8.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-34.el5_8 is needed by package php-xmlrpc-5.1.6-34.el5_8.i386 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
avij

avij

2012-05-09 14:16

updater   ~0015053

OK, so, php-common has already been installed.. Running these commands might provide some additional clues about the problem:

rpm -qa 'php*'
grep php /etc/yum.conf /etc/yum.repos.d/*

There's a chance that your local RPM database is somehow corrupted. Running the package-cleanup programs as instructed in the output might also help.
maxman

maxman

2012-05-13 15:03

reporter   ~0015075

Hi Again
Unfortunately I do as your recommended with no results, here is the output.

[root@mail ~]# rpm -qa 'php*'
php-mcrypt-5.3.6-1.el5.remi
php-5.3.6-1.el5.remi
php-pdo-5.3.6-1.el5.remi
php-common-5.3.6-1.el5.remi
php-mysql-5.3.6-1.el5.remi
php-cli-5.3.6-1.el5.remi
php-xml-5.3.6-1.el5.remi
php-ldap-5.3.6-1.el5.remi
php-gd-5.3.6-1.el5.remi
php-mbstring-5.3.6-1.el5.remi
[root@mail ~]# grep php /etc/yum.conf /etc/yum.repos.d/*
[root@mail ~]# yum clean all
Loaded plugins: fastestmirror, priorities, protectbase
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@mail ~]# yum install php-xmlrpc
Loaded plugins: fastestmirror, priorities, protectbase
Determining fastest mirrors
 * base: centos.syn.co.il
 * epel: mirrors.ircam.fr
 * extras: centos.syn.co.il
 * rpmforge: mirror17.pcbsd.org
 * updates: centos.syn.co.il
base | 1.1 kB 00:00
base/primary | 967 kB 00:00
base 2725/2725
epel | 3.4 kB 00:00
epel/primary_db | 3.1 MB 00:03
extras | 2.1 kB 00:00
extras/primary_db | 169 kB 00:00
rpmforge | 1.9 kB 00:00
rpmforge/primary_db | 7.1 MB 00:06
updates | 1.9 kB 00:00
updates/primary_db | 311 kB 00:00
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xmlrpc.i386 0:5.1.6-34.el5_8 set to be updated
--> Processing Dependency: php-common = 5.1.6-34.el5_8 for package: php-xmlrpc
--> Finished Dependency Resolution
php-xmlrpc-5.1.6-34.el5_8.i386 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-34.el5_8 is needed by package php-xmlrpc-5.1.6-34.el5_8.i386 (updates)
Error: Missing Dependency: php-common = 5.1.6-34.el5_8 is needed by package php-xmlrpc-5.1.6-34.el5_8.i386 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

and thanks again
avij

avij

2012-05-13 20:19

updater   ~0015076

OK, your problem is that you're using PHP packages not provided by CentOS. That can be seen from the 'rpm -qa' output where it shows package names ending with remi. Those are not CentOS packages.

Uninstalling those and installing the versions provided by CentOS would likely let you install the CentOS-provided php-xmlrpc and php-soap packages. If you want to continue using the PHP packages provided by some third party, you'll need to ask them for assistance in your problem.

As it looks like there's no bug in CentOS, I'd be inclined to close this bug report. bugs.centos.org is only for bugs in the distribution, this is not a support venue.

Issue History

Date Modified Username Field Change
2012-05-07 20:15 maxman New Issue
2012-05-08 15:02 avij Note Added: 0015047
2012-05-09 13:37 maxman Note Added: 0015052
2012-05-09 14:16 avij Note Added: 0015053
2012-05-13 15:03 maxman Note Added: 0015075
2012-05-13 20:19 avij Note Added: 0015076
2012-05-19 14:18 avij Status new => closed
2012-05-19 14:18 avij Resolution open => no change required
2012-05-19 14:18 avij Steps to Reproduce Updated View Revisions