View Issue Details

IDProjectCategoryView StatusLast Update
0005730CentOS-6NetworkManagerpublic2012-05-25 23:35
Status resolvedResolutionno change required 
PlatformOSOS Versioni686
Product Version6.2 
Target VersionFixed in Version 
Summary0005730: Intel Corporation Centrino Advanced-N 6205 module loaded but not usable
DescriptionWifi connection not working: the module is loaded correctly but the device was not found

[root@zoppi ndiswrapper-1.57]# lsmod|grep iwlagn
iwlagn 170290 0
iwlcore 63753 1 iwlagn
mac80211 130488 2 iwlagn,iwlcore
cfg80211 117703 3 iwlagn,iwlcore,mac80211
TagsNo tags attached.




2012-05-16 13:01

administrator   ~0015088

I personally have a Dell Precision M4500 Mobile Workstation that has this:

[johnny@m4500n network-scripts]$ lspci | grep Centrino
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)

[johnny@m4500n network-scripts]$ uname -a
Linux m4500n 2.6.32-220.13.1.el6.x86_64 #1 SMP Tue Apr 17 23:56:34 BST 2012 x86_64 x86_64 x86_64 GNU/Linux

I am having no issues at all with this wireless nic.

Are you using Network Manager ... it is used by default and I would highly recommend it for wlan type connections.


2012-05-16 16:08

reporter   ~0015091

My Mobile is a DELL latitude E5520 that has this:

[zoppim@zoppi ~]$ lspci | grep Centrino
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)

[root@zoppi ~]# uname -a
Linux zoppi #1 SMP Wed May 16 04:10:42 BST 2012 i686 i686 i386 GNU/Linux
[root@zoppi ~]#

but none wireless connection is showed by NetworkManager


2012-05-17 13:05

reporter   ~0015098

May be is this a issue of 32 bit S.O. version ?
When i have used the 64 bit live cd, the wireless has been found


2012-05-24 14:01

reporter   ~0015141

Please execute:
# modinfo iwlagn
and paste all strings "firmware:"


2012-05-24 14:44

reporter   ~0015142

this is the response:

[]$ modinfo iwlagn|grep firmware
firmware: iwlwifi-4965-2.ucode
firmware: iwlwifi-5150-2.ucode
firmware: iwlwifi-5000-5.ucode
firmware: iwlwifi-6000g2b-5.ucode
firmware: iwlwifi-6000g2a-5.ucode
firmware: iwlwifi-6050-5.ucode
firmware: iwlwifi-6000-4.ucode
firmware: iwlwifi-100-5.ucode
firmware: iwlwifi-1000-3.ucode
parm: fw_restart50:restart firmware in case of error (deprecated) (int)
parm: fw_restart:restart firmware in case of error (int)

When I have tried all distro live CentOS (32&64bit) the wireless connection is available; this is strange


2012-05-24 14:46

reporter   ~0015143

filename: /lib/modules/
alias: iwl4965
license: GPL
author: Copyright(c) 2003-2010 Intel Corporation <>
version: in-tree:
description: Intel(R) Wireless WiFi Link AGN driver for Linux


2012-05-24 15:11

reporter   ~0015144

ifconfig -a
dmesg | grep iwlagn


2012-05-25 07:46

reporter   ~0015153

Problem solved:
I have added "alias wlan0 iwl4965" in /etc/modprobe.d/dist.conf and installed with yum the package "kmod-compat-wireless.i686"; Now i can use my wireless using NetworkManager.
Thank you at all


2012-05-25 17:51

manager   ~0015157

For future searchers, the "kmod-compat-wireless" package is from ELRepo:

See also:

Issue History

Date Modified Username Field Change
2012-05-16 12:22 ilmarkese New Issue
2012-05-16 13:01 JohnnyHughes Note Added: 0015088
2012-05-16 16:08 ilmarkese Note Added: 0015091
2012-05-17 13:05 ilmarkese Note Added: 0015098
2012-05-24 14:01 monr0e Note Added: 0015141
2012-05-24 14:44 ilmarkese Note Added: 0015142
2012-05-24 14:46 ilmarkese Note Added: 0015143
2012-05-24 15:11 monr0e Note Added: 0015144
2012-05-25 07:46 ilmarkese Note Added: 0015153
2012-05-25 17:51 toracat Note Added: 0015157
2012-05-25 23:35 toracat Status new => resolved
2012-05-25 23:35 toracat Resolution open => no change required