View Issue Details

IDProjectCategoryView StatusLast Update
0005738CentOS-6kernelpublic2012-05-23 00:27
Reporterrsandu 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version6.2 
Target VersionFixed in Version 
Summary0005738: Intel PRO/1000 GT Desktop Ethernet card is not supported
DescriptionHello,

The new Intel PRO/1000 GT Desktop Adapters (ID 8086:106c) are not supported by CentOS (does not show up as network controllers, does not show up and cannot be configured in NetworkManager).

Please see http://www.h-node.org/ethernetcards/view/en/634/Intel-Corporation-Device--rev-05-


TagsNo tags attached.

Activities

toracat

toracat

2012-05-21 21:16

manager   ~0015108

That hardware is so new that the driver for Linux is not available in the current RHEL (CentOS) kernels. It is also not available from ELRepo kmods, either. The vendor:device pair (8086:106c) suggests it is (will be) supported by the kmod-e1000 package.

However, the latest kernel seems to have the support for this device. You may want to try ELRepo's kernel-ml (3.3.6 is the latest at this moment).

If that works, then file a request to update (backport from kernel.org) the e1000 driver at http://bugzilla.redhat.com.
toracat

toracat

2012-05-21 21:44

manager   ~0015109

Maybe I spoke too soon. :-(

Just checked the e1000 code in the latest kernel 3.4. I do not see 106C on the list of devices.
repairmn

repairmn

2012-05-21 22:54

reporter   ~0015110

I have access to the Intel internal database that lists all the network adapter device IDs. 106C is not a valid device ID for any network device from Intel. The adapter might be a counterfeit or at least it is defective since the device ID is not valid.
toracat

toracat

2012-05-22 01:04

manager   ~0015111

... or a typo?

@rsandu, can you paste the whole line of output from:

lspci -nn | grep -i net
rsandu

rsandu

2012-05-22 06:53

reporter   ~0015113

Hello,

No, the device is a shining new Intel PRO/1000 GT Desktop Adapter, with authenticity holograms on it, purchased from the official distribution channel of Intel Romania. The manufacturing date, March 2012, is clearly labeled on it. It's a PCI card with "short bracket" (for mounting in 2U rackable cases).

IMHO, the chance to be a counterfeit or a defective one is almost zero.

I'll post the output of the above command ASAP.

Regards,
R?zvan
rsandu

rsandu

2012-05-22 13:47

reporter   ~0015116

Probably my fault, sorry - this card seems to be from the Twilight Zone.
Now it shows up correctly and IT WORKS (8086:107c). All I did it was to substitute it with another one (Intel PRO/1000 CT Adapter, PCIe), install the router (including the kmod-1000e module from ELREPO) and upgrade to the latest kernel. And, after that, switch the cards again.

However, I'm sure that *yesterday* was reported differently and *didn't* work (both in an un-updated CentOS 6.2 and in Trisquel 5.5). It was reported as:

Intel Corporation Device [8086:106c] (rev 05)

That's why I've opened the bug in the first place.

Sorry again - you may consider this closed...

Razvan
rsandu

rsandu

2012-05-22 13:54

reporter   ~0015117

Now, the output of "lspci -nn | grep -i net" is:

02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
04:00.0 Ethernet controller [0200]: Intel Corporation 82541PI Gigabit Ethernet Controller [8086:107c] (rev 05)
04:01.0 Ethernet controller [0200]: D-Link System Inc DGE-528T Gigabit Ethernet Adapter [1186:4300] (rev 10)

(the router contains multiple cards).
toracat

toracat

2012-05-22 14:42

manager   ~0015119

With that list, I see the following:

[1969:1083] supported by kmod-atl1 from ELRepo
[8086:107c] supported by in-kernel module e1000 or kmod-e1000 from ELRepo
[1186:4300] supported by in-kernel module r8169

(kernel version 2.6.32-220.17.1.el6)
rsandu

rsandu

2012-05-22 14:57

reporter   ~0015124

Yes, now everything is OK. All cards wok OK

I have no logical explanation for why yesterday I saw that card under a different ID and not recognized by the system. It was not a typo, since I've reported the parameters to h-node.org (name of the device, hardware ID) via Cut & Paste.
toracat

toracat

2012-05-22 15:03

manager   ~0015125

I will leave this report a little longer in case repairmn would like to make additional comment.
repairmn

repairmn

2012-05-22 16:25

reporter   ~0015127

I suspect that the issue was related to the PCI connector and cleared by removing the adapter and then putting the adapter back into the system. Other hardware issues are a possibility, but an issue with the connection is the most logical explanation considering the steps followed by rsandu.
toracat

toracat

2012-05-23 00:27

manager   ~0015132

Well said. With that, we will conclude this thread. :)

Issue History

Date Modified Username Field Change
2012-05-21 17:34 rsandu New Issue
2012-05-21 21:16 toracat Note Added: 0015108
2012-05-21 21:44 toracat Note Added: 0015109
2012-05-21 22:54 repairmn Note Added: 0015110
2012-05-22 01:04 toracat Note Added: 0015111
2012-05-22 06:53 rsandu Note Added: 0015113
2012-05-22 13:47 rsandu Note Added: 0015116
2012-05-22 13:54 rsandu Note Added: 0015117
2012-05-22 14:42 toracat Note Added: 0015119
2012-05-22 14:57 rsandu Note Added: 0015124
2012-05-22 15:03 toracat Note Added: 0015125
2012-05-22 15:03 toracat Status new => assigned
2012-05-22 16:25 repairmn Note Added: 0015127
2012-05-23 00:27 toracat Note Added: 0015132
2012-05-23 00:27 toracat Status assigned => resolved
2012-05-23 00:27 toracat Resolution open => no change required