View Issue Details

IDProjectCategoryView StatusLast Update
0005836CentOS-6-OTHERpublic2012-07-25 07:23
Reportertoracat 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version6.3 
Target Version6.3Fixed in Version 
Summary0005836: Some i686 packages missing in the x86_64 repo
DescriptionUsers reported missing i686 packages in the x86_64 repo [1,2].

hivex
hivex-devel
librdmacm
librdmacm-devel
sanlock-libs
sanlock-devel

[1] http://bugs.centos.org/view.php?id=5546#c15424
[2] http://lists.centos.org/pipermail/centos/2012-July/127461.html
TagsNo tags attached.

Activities

tigalch

tigalch

2012-07-14 03:57

manager   ~0015432

The current version of librdmacm (1.0.15-2) is present in /os of x86_64 but seems to be missing in /os of i386.
No version of hivex in the i386 tree.
No current version of hivex (2.3-1) in the i386 tree.
JohnnyHughes

JohnnyHughes

2012-07-14 13:54

administrator   ~0015438

This is in the SPEC file for the new version of sanlock:

Name: sanlock
Version: 2.3
Release: 1%{?dist}
Summary: A shared disk lock manager

Group: System Environment/Base
License: GPLv2 and GPLv2+ and LGPLv2+
URL: https://fedorahosted.org/sanlock/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExclusiveArch: x86_64
BuildRequires: libblkid-devel libaio-devel python python-devel
Requires: %{name}-lib = %{version}-%{release}
Source0: https://fedorahosted.org/releases/s/a/sanlock/%{name}-%{version}.tar.gz



As you can see, this package is x86_64 only (the ExclusiveArch) ... so there is no new sanlock i386.
JohnnyHughes

JohnnyHughes

2012-07-14 14:00

administrator   ~0015439

The following packages are added to the 6.3 x86_64 updates tree:

-rw-rw-r--. 1 kbsingh hughesjr 92552 Jul 14 14:05 hivex-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 28280 Jul 14 14:05 hivex-devel-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 14548 Jul 14 14:05 ocaml-hivex-devel-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 30072 Jul 14 14:03 librdmacm-1.0.15-2.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 65480 Jul 14 14:03 librdmacm-devel-1.0.15-2.el6.i686.rpm

============================================================

and the following have been added to the 6.3 i386 updates tree:

-rw-rw-r--. 1 kbsingh hughesjr 92552 Jul 14 14:05 hivex-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 28280 Jul 14 14:05 hivex-devel-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 14548 Jul 14 14:05 ocaml-hivex-devel-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 38516 Jul 14 14:05 perl-hivex-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 13464 Jul 14 14:05 python-hivex-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 15560 Jul 14 14:05 ocaml-hivex-1.3.3-4.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 904316 Jul 14 14:04 perl-libintl-1.20-1.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 37092 Jul 14 14:03 librdmacm-utils-1.0.15-2.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 30072 Jul 14 14:03 librdmacm-1.0.15-2.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 65480 Jul 14 14:03 librdmacm-devel-1.0.15-2.el6.i686.rpm
-rw-rw-r--. 1 kbsingh hughesjr 19164 Jul 14 14:03 librdmacm-static-1.0.15-2.el6.i686.rpm



This should solve all the issues for hivex and librdmacm ... leaving only outstanding the sanlock issue.
JohnnyHughes

JohnnyHughes

2012-07-14 18:00

administrator   ~0015444

WRT sanlock, CentOS matches upstream with the these packages in each repo:

64-bit system:
 
sanlock.x86_64 2.3-1.el6
sanlock-devel.i686 1.8-2.el6
sanlock-devel.x86_64 2.3-1.el6
sanlock-lib.i686 1.8-2.el6
sanlock-lib.x86_64 2.3-1.el6
sanlock-python.x86_64 2.3-1.el6
 
32-bit system:
 
sanlock.i686 1.8-2.el6
sanlock-devel.i686 1.8-2.el6
sanlock-lib.i686 1.8-2.el6
sanlock-python.i686 1.8-2.el6

So, even though I don't like different versions in different ARCHes ... we have what upstream has, so this is, by definition, correct.
JohnnyHughes

JohnnyHughes

2012-07-14 18:00

administrator   ~0015445

matches upstream
toracat

toracat

2012-07-24 20:04

manager   ~0015533

Reopening the ticket to add more missing packages.

The following i686 rpms should have been in the x86_64 tree on the 6.3 media:

ibus-gtk-1.3.4-6.el6.i686.rpm
ipset-6.11-1.el6.i686.rpm
libmnl-1.0.2-3.el6.i686.rpm
procps-3.2.8-23.el6.i686.rpm
gtk2-immodule-xim-2.18.9-10.el6.i686.rpm
JohnnyHughes

JohnnyHughes

2012-07-25 07:23

administrator   ~0015539

These all added to centos/6.3/updates/x86_64/Packages ... we be included on new media in the future:

ibus-gtk-1.3.4-6.el6.i686.rpm
ipset-6.11-1.el6.i686.rpm
libmnl-1.0.2-3.el6.i686.rpm
procps-3.2.8-23.el6.i686.rpm
gtk2-immodule-xim-2.18.9-10.el6.i686.rpm

Issue History

Date Modified Username Field Change
2012-07-13 21:12 toracat New Issue
2012-07-13 21:19 toracat Description Updated View Revisions
2012-07-14 03:57 tigalch Note Added: 0015432
2012-07-14 13:54 JohnnyHughes Note Added: 0015438
2012-07-14 14:00 JohnnyHughes Note Added: 0015439
2012-07-14 18:00 JohnnyHughes Note Added: 0015444
2012-07-14 18:00 JohnnyHughes Note Added: 0015445
2012-07-14 18:00 JohnnyHughes Status new => resolved
2012-07-14 18:00 JohnnyHughes Resolution open => fixed
2012-07-24 20:04 toracat Note Added: 0015533
2012-07-24 20:04 toracat Status resolved => feedback
2012-07-24 20:04 toracat Resolution fixed => reopened
2012-07-24 20:04 toracat Status feedback => assigned
2012-07-25 07:23 JohnnyHughes Note Added: 0015539
2012-07-25 07:23 JohnnyHughes Status assigned => resolved
2012-07-25 07:23 JohnnyHughes Resolution reopened => fixed