View Issue Details

IDProjectCategoryView StatusLast Update
0005860CentOS-6kernelpublic2015-06-19 07:35
Reporterjerry 
PriorityurgentSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformx86_64OSOS Version
Product Version6.3 
Target VersionFixed in Version 
Summary0005860: Virtual guests can no longer see multicast traffic from LAN
DescriptionAfter (via yum upgrade) update to 6.3, VM guests can no longer see multicast traffic from lan.

Guests are a mix of CentOS62, CentOS63 (updated to test to see if it still see's problem, yes), and Fedora17, none can see multicast from the LAN.

This breaks several things:
* OSPF runnning on a guest can establish neighbors with other guests but not hosts on the LAN.
* Bonjour chat can't see or send messages to bonjour users on the LAN.
* LAN hosts can't ping any IPv6 VM guests unless the VM guest pings the lan host first (thus establishing itself in the hosts ND cache).
Steps To ReproduceInstall CentOS62 from DVD.

Previously yum updated (before 6.3 came out) to keep updates current

Install guests with networking source device set to macvtap and source set to bridge

Test and all working

shutdown guests

yum update to 63
-this installed kernel 2.6.32-279.2.1.el6.x86_64
boot host

start guests

guests can no longer see multicast traffic that originates from LAN, they can see multicast from other guests

shutting guests down and booting host to kernel 2.6.32-220.23.1.el6.x86_64 and restarting guests fixes the problem
Tags6.3, libvirt

Activities

jerry

jerry

2012-08-17 01:35

reporter   ~0015672

Further testing, booting ANY/ALL 279 kernels break, ANY 220 kernel works.
jpereira

jpereira

2012-09-26 10:07

reporter   ~0015825

Also have this issue with a single host out of a group of 5 different servers hosting virtual machines.
On this host this issue happens with a 6.3 update form 6.2 and also in a fresh install.
tigalch

tigalch

2012-09-26 11:17

manager   ~0015828

kernel-2.6.32-279.9.1 is announced/released. Could you please retry?
jerry

jerry

2012-09-27 06:16

reporter   ~0015831

jpereira just to verify, you have hosts running a 2.6.32-279.* kernel that don't have this issue?

Can you verify which kernel booted (uname -a)?
Are you using the macvtap ethX as the source device?
Are all of your machines identical?
What NIC are you using?

Thanks for the info.
jpereira

jpereira

2012-09-27 08:33

reporter   ~0015835

Just to say that maybe i'm posting in the wrong bug, as in my case the problem is definitely related to 6.3 (2.6.32-279.*) as I get no traffic at all (not just multicast).

>Can you verify which kernel booted (uname -a)?
Anyway, current working install is:
Linux servername.local 2.6.32-220.el6.x86_64 #1 SMP Tue Dec 6 19:48:22 GMT 2011 x86_64 x86_64 x86_64 GNU/Linux

>Are you using the macvtap ethX as the source device?
My install with 6.3 did fail using macvtap ethX as the source device, I tried using a different type and number of NICs in the host.
 
>Are all of your machines identical?
No, but as I said beffore, not really checking for multicast traffic.
This issue (no traffic at all) is happening in a single server.

>What NIC are you using?
at this moment a Realtek Semiconductor Co., Ltd. RTL8111/8168B
but have also tried a number of other models, so I guess it is not a NIC related issue

>kernel-2.6.32-279.9.1 is announced/released. Could you please retry?
Not yet, I will post the result latter.
jpereira

jpereira

2012-09-27 08:37

reporter   ~0015836

Let me rephrase my first sentence in the last note:
Just to say that maybe i'm posting in the wrong bug tracker as my problem is that I get no traffic at all (not just multicast) between the host and the guests.
jpereira

jpereira

2012-09-27 08:50

reporter   ~0015837

>kernel-2.6.32-279.9.1 is announced/released. Could you please retry?
Linux servername.local 2.6.32-279.9.1.el6.x86_64 #1 SMP Tue Sep 25 21:43:11 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

No network traffic again.

So its back to 6.2 for me.
jerry

jerry

2012-09-27 11:44

reporter   ~0015838

jpereira is just ipv6 traffic breaking by any chance, or ipv4 as well?
jerry

jerry

2012-09-27 11:45

reporter   ~0015839

Still broke with 279.9.1 kernel. Multicast traffic from the lan is not being seen by virtual guests.
jpereira

jpereira

2012-09-27 14:04

reporter   ~0015845

>jpereira is just ipv6 traffic breaking by any chance, or ipv4 as well?
I haven't tried ipv6 at all, just ipv4.
Still don't know how to get around this problem, so i'll run 6.2 for a while more.
jerry

jerry

2012-09-30 05:09

reporter   ~0015859

A review of all the notes regarding 2.6.32-279.9.1.el6.x86_64 doesn't give me any reason to believe that this issue has been fixed. Testing confirms the bug is still present.
slaggi

slaggi

2013-01-19 13:37

reporter   ~0016300

I got the same problem as described, no traffic to guests using direct bridged connection with IP v4.

But, if I run a tcpdump on the hostinterface e.g. eth0 (if guest is bridged to eth0) then traffic is forwarded to the guest ! If I stop the tcpdump, traffic stops as well. Guest traffic is very very slow.

this is with 2.6.32-279.19.1.el6.x86_64
jerry

jerry

2013-01-21 03:20

reporter   ~0016309

slaggi thats not the same issue. Did you even read the bug report? Why do people keep adding to this ticket when its not even close to the same issue.
mjakmarcin

mjakmarcin

2013-02-01 07:55

reporter   ~0016380

I can confirm. After update from 6.2 to 6.3 (2.6.32-279.14.1.el6.x86_64) i lost multicast traffic on print servers set up as NLB clusters on WIN2008R2. After changing it to Unicast the traffic was visible again. Not sure if this hit this bug but i was not able to see this traffic even from domain controller hosted on the same virtualization host.

Here are affected kernel versions with patches :
2.6.32-279.14.1.el6.x86_64
2.6.32-279.2.1.el6.x86_64
jerry

jerry

2013-05-11 07:36

reporter   ~0017404

6.4 still broken, booting a 220 kernel continues to work.
toracat

toracat

2013-05-12 07:06

manager   ~0017405

@jerry

Does the problem look similar to the one reported in this BZ?

https://bugzilla.redhat.com/show_bug.cgi?id=880035
jerry

jerry

2013-05-12 08:04

reporter   ~0017406

It might be related, but definitely not the same.

His issues seem to be intermittent, mine are 100%, good on 220 kernels on the host, bad on anything newer. And yes, I've let it run for several hours on the newer kernels and it doesn't clear up or change.

He appears to be bridging the vm's, I'm using macvtap (so there is no host/vm communication, my host is dedicated to running vm's so there is no need for host/vm communication).

In either case (new or old kernel) multicast between vm's is fine.

With new kernel, multicast between vm's and lan is broken.

In my case, host only has a single nic and all vm's are doing macvtap, so as to appear directly on the lan.

It does break for both ipv4 AND ipv6.

With no changes on the vm's, booting the host into a 220 kernel, everything works as expected, booting into *any* newer kernel breaks multicast between vm and lan.

Everything on the host is stock CentOS, no 3rd party packages, everything that is on it (pretty base install) was installed via yum, no custom packages, nothing compiled by hand, yum repolist only shows CentOS repo's. Its basically a stock box thats up to date (except for the kernel) with a basic install and libvirtd stuff.

I'm not sure I've actually found anyone else encountering this bug, but its easily pointed to the kernel version by simply rebooting the host to the older or current kernel and it working or breaking with that being the only change.
jerry

jerry

2013-05-12 08:14

reporter   ~0017407

Reading through all the notes on this ticket, it does look like its possible that mjakmarcin is seeing the same bug.

Outside of that I'm not sure I've seen anyone else report it here or at Redhat.

I've also asked in multiple IRC channels, but it just seems like once you say multicast everyone goes clueless.

It also seems I'm one of the few people using macvtap, as most people can't deal with the limitation of host/vm communications.
jerry

jerry

2015-06-19 07:35

reporter   ~0023443

This issue is still present in Centos7

Issue History

Date Modified Username Field Change
2012-07-25 19:51 jerry New Issue
2012-07-25 20:32 jerry Tag Attached: 6.3
2012-07-25 20:32 jerry Tag Attached: libvirt
2012-08-17 01:35 jerry Note Added: 0015672
2012-09-26 10:07 jpereira Note Added: 0015825
2012-09-26 11:17 tigalch Note Added: 0015828
2012-09-27 06:16 jerry Note Added: 0015831
2012-09-27 08:33 jpereira Note Added: 0015835
2012-09-27 08:37 jpereira Note Added: 0015836
2012-09-27 08:50 jpereira Note Added: 0015837
2012-09-27 11:44 jerry Note Added: 0015838
2012-09-27 11:45 jerry Note Added: 0015839
2012-09-27 14:04 jpereira Note Added: 0015845
2012-09-30 05:09 jerry Note Added: 0015859
2013-01-19 13:37 slaggi Note Added: 0016300
2013-01-21 03:20 jerry Note Added: 0016309
2013-02-01 07:55 mjakmarcin Note Added: 0016380
2013-05-11 07:36 jerry Note Added: 0017404
2013-05-12 07:06 toracat Note Added: 0017405
2013-05-12 08:04 jerry Note Added: 0017406
2013-05-12 08:14 jerry Note Added: 0017407
2015-06-19 07:35 jerry Note Added: 0023443