View Issue Details

IDProjectCategoryView StatusLast Update
0005927CentOS-6-OTHERpublic2013-01-17 23:11
Reporteravij 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.3 
Target Version6.4Fixed in Version 
Summary0005927: Increase torrent piece size
DescriptionTorrents are divided into pieces, which are then shuffled around by Bittorrent clients. The more pieces, the more overhead there is for controlling which client has which piece. On the other hand, if the piece size is too big, it may take the clients a bit longer to get their first full piece, which they could then send to other clients in exchange for new pieces.

The opinion is divided on the correct piece size, but in any case I suppose the piece size could be made somewhat bigger than what it is now. This would also make the torrent files smaller, although this is likely less of a concern to anyone nowadays.

Here's a summary of the CentOS torrents I have:

[anssi@norsu centos]$ for i in *.torrent; do transmission-show $i | egrep -e " (Piece Size|Name):"; done | awk '{if (NR%2) {prev=$0} else {print prev,$0}}' | sort
  Name: CentOS-4.8-i386-bin1to4 Piece Size: 256.0 KiB
  Name: CentOS-4.8-i386-binDVD Piece Size: 256.0 KiB
  Name: CentOS-4.8-x86_64-bin1to5 Piece Size: 256.0 KiB
  Name: CentOS-4.8-x86_64-binDVD Piece Size: 256.0 KiB
  Name: CentOS-5.6-i386-bin-1to7 Piece Size: 256.0 KiB
  Name: CentOS-5.6-i386-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-5.6-i386-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-5.6-x86_64-bin-1to8 Piece Size: 256.0 KiB
  Name: CentOS-5.6-x86_64-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-5.6-x86_64-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-5.7-i386-bin-1to8 Piece Size: 256.0 KiB
  Name: CentOS-5.7-i386-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-5.7-x86_64-bin-1to8 Piece Size: 256.0 KiB
  Name: CentOS-5.7-x86_64-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-5.8-i386-bin-1to7 Piece Size: 256.0 KiB
  Name: CentOS-5.8-i386-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-5.8-x86_64-bin-1to8 Piece Size: 256.0 KiB
  Name: CentOS-5.8-x86_64-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-6.0-i386-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-6.0-i386-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-6.0-i386-LiveDVD Piece Size: 256.0 KiB
  Name: CentOS-6.0-x86_64-bin-DVD Piece Size: 256.0 KiB
  Name: CentOS-6.0-x86_64-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-6.0-x86_64-LiveDVD Piece Size: 256.0 KiB
  Name: CentOS-6.1-i386-bin-DVD1to2 Piece Size: 256.0 KiB
  Name: CentOS-6.1-i386-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-6.1-i386-LiveDVD Piece Size: 256.0 KiB
  Name: CentOS-6.1-x86_64-bin-DVD1to2 Piece Size: 256.0 KiB
  Name: CentOS-6.1-x86_64-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-6.1-x86_64-LiveDVD Piece Size: 256.0 KiB
  Name: CentOS-6.2-i386-bin-DVD1to2 Piece Size: 256.0 KiB
  Name: CentOS-6.2-i386-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-6.2-i386-LiveDVD Piece Size: 256.0 KiB
  Name: CentOS-6.2-x86_64-bin-DVD1to2 Piece Size: 256.0 KiB
  Name: CentOS-6.2-x86_64-LiveCD Piece Size: 256.0 KiB
  Name: CentOS-6.2-x86_64-LiveDVD Piece Size: 256.0 KiB
  Name: CentOS-6.3-i386-bin-DVD1to2 Piece Size: 512.0 KiB
  Name: CentOS-6.3-i386-LiveCD Piece Size: 64.00 KiB
  Name: CentOS-6.3-i386-LiveDVD Piece Size: 128.0 KiB
  Name: CentOS-6.3-x86_64-bin-DVD1to2 Piece Size: 512.0 KiB
  Name: CentOS-6.3-x86_64-LiveCD Piece Size: 64.00 KiB
  Name: CentOS-6.3-x86_64-LiveDVD Piece Size: 128.0 KiB

It looks like some other method was used for creating the C6.3 torrents than before. Bug 5926 also suggests that some other method was used for the 6.3 torrents. I don't know if that was a one-time occurrence or if all the future torrents will be made using the same method as the C6.3 torrents.

I would suggest using a 1MB piece size for DVD images (and complete 1-8 CD sets for C5.x) and a 512KB piece size for smaller files. If for some reason only one piece size can be used for all torrents, 512KB would be fine.
Steps To Reproducetransmission-show centos.torrent
Additional Informationmktorrent -l 19 will create a torrent with 512KB pieces
mktorrent -l 20 will create a torrent with 1MB pieces
TagsNo tags attached.

Activities

avij

avij

2012-08-31 21:59

updater   ~0015727

Changing the piece size now would change the info hashes, thus splitting the torrent swarm. This may be undesirable, so it's better to stick with the torrents we have now. Please consider changing the piece size at C5.9 or C6.4 release time.
avij

avij

2013-01-17 23:11

updater   ~0016295

Piece size has been increased to 512k with 5.9 torrents.

Issue History

Date Modified Username Field Change
2012-08-31 21:29 avij New Issue
2012-08-31 21:59 avij Note Added: 0015727
2012-08-31 22:00 avij Severity minor => feature
2013-01-17 23:11 avij Note Added: 0016295
2013-01-17 23:11 avij Status new => resolved
2013-01-17 23:11 avij Resolution open => fixed