View Issue Details

IDProjectCategoryView StatusLast Update
0005991CentOS-6rsyslogpublic2013-03-13 19:47
Status newResolutionopen 
PlatformXenServer 6.0OSCentOSOS Version6
Product Version6.2 
Target VersionFixed in Version 
Summary0005991: System fails to boot after installation of latest rsync
DescriptionWhen trying to upgrade rsync to fix the rsyslog security (CESA-2012-0796), which brings rsync up to 5.8.10-2.el6.x86_64, the system will not reboot after the update. I have reproduced this several times, always with the same result. After doing a reboot command, the system gives the message that the system is being rebooted, but it never completes. Using XenCenter to force a reboot allows the system to start to boot, but the boot never completes. The system comes up far enough that it is responding to its IP address, but an SSH attempt to login only gets to the prompt for the password, & the login never completes.
Modules updated for the bugfix include: rsyslog, rsyslog-debuginfo, rsyslog-gnutls, rsyslog-gssapi, rsyslog-mysql, rsyslog-pgsql, rsyslog-relp, and rsyslog-snmp.
Steps To Reproduceyum install rsyslog (and the other modules listed above)
issue reboot command (reboot never gets started, and IP address is still responding)
issue XenCenter force reboot and the system starts the reboot, but stalls before the system is fully up.
TagsNo tags attached.




2013-03-13 19:47

reporter   ~0016701

I have exactly the same issue

rsyslog daemon is not able to start - just waiting 5min and then dies.
So it affects system boot, init.d restart, yum cleanup too. Boot continues after that 5mins, but without syslogging of course.

/sbin/rsyslogd -i /var/run/ -c 5 -d
....some usual debug output.....
7775.447762377:7f124a8b5700: deque option i, optarg '/var/run/'
7775.447771451:7f124a8b5700: Checking pidfile.
(it creates pidfile normally!!)
and hangs for 5 minutes. Then dies without any output.

happen me after update from cos 6.3 to 6.4

uname -r
(but it doesn't care, I tried older kernel too)

My step to reproduce:
update rsyslog to 5.8.10-6.el6.x86_64

Problem goes away when I downgrade rsyslog back to 5.8.10-2.el6.x86_64

Issue History

Date Modified Username Field Change
2012-10-04 17:12 harveywmiller New Issue
2013-03-13 19:47 petr11 Note Added: 0016701