View Issue Details

IDProjectCategoryView StatusLast Update
0006038CentOS-6lvm2public2013-01-04 22:45
ReporterCrowdness 
PriorityurgentSeveritycrashReproducibilityalways
Status newResolutionopen 
Product Version6.3 
Target VersionFixed in Version 
Summary0006038: Creating VM's using LVM's crashes on boot
DescriptionThe superblock could not be read or does not describe a correrct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem is the message on boot.

The LVM's were created as ext4. The LVM was then used for creating a VM. Soon as the VM(s) are created and the machine is rebooted, the above error appears and the system is no longer bootable.
Steps To ReproduceThe LVM's can be created during the installation of 6.3 or they can be created after the installation. The system will boot fine.

1) Create a bridge
2) Use a script to create the VM using virt-install or create the VM using the gui tool (virt-install --connect qemu:///system -n mail1 -r 1024 --vcpus=1 --disk path=/dev/vg_ms/lv_mail1 -c /share/CentOS-63.x86_64-bin-DVD1.iso --vnc --noautoconsole --os-type linux --accelerate --network=bridge:br1 --hvm **note** the lv_mail1 is 20G. Even tried it with 100G.
3) Make sure the VM works
4) Shut down the VM
5) Reboot the host
Additional InformationSo far I have not tried creating VM's that are not associate with an LVM. I don't know what the difference would be.

The drives are 2TB SATA.

uname -a
Linux <server> 2.6.32-279.11.1.el6.x86_64 #1 SMP Tue Oct 16 15:57:10 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

fdisk -l shows the following:

Device Boot Start End Blocks Id System
/dev/sda1 * 1 64 512000 83 Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2 64 243302 1953001472 8e Linux LVM

Goes on to list more that are clean, then gets to the newly create VM and it is as follows:

/dev/mapper/vg_userStuff2-lv_mail1 * 1 64 512000 83 Linux
Partition 1 does not end on cylinder boundary.

So it appears that even though the LVM is specified, it's trying to create the same size on the boot partition and corrupting it.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2012-10-28 02:41 Crowdness New Issue