View Issue Details

IDProjectCategoryView StatusLast Update
0006112CentOS-6dracutpublic2012-12-03 18:20
Status newResolutionopen 
PlatformX86_64OS6OS Version6.3
Product Version6.3 
Target VersionFixed in Version 
Summary0006112: NFS or LiveNet Functionality Not Working Correctly with Dracut
DescriptionI am trying to create a new initrd to support booting diskless machines over the network. The DHCP/TFTP configuration is working as intended. The client gets and IP address and is able to download the initrd file and vmlinuz.

The problem appears when attempting to mount the root filesystem on the client. I have tried to use both the livenet module and nfs, but an error appears saying:

"don't know how to handle root=nfs (or root=live)"

I even tried downloading the newest version of dracut (024) and still experience this issue.
Steps To Reproduce1. Setup DHCP/TFTP server to lease addresses.
2. Installed appropriate dracut RPMs (dracut, dracut-network) using Yum.
3. Ran the following command to make the initrd

dracut -v --force -a "livenet nfs" initrd.img

4. Configured /var/lib/tftpboot/linux-install/pxelinux.cfg/default to contain the following
default rhel6

label rhel6
  kernel vmlinuz
  append initrd=initrd.img root=nfs:<serverip>:/exports/root rw

I also tried the folowing for the livenet module

append initrd=initrd.img console=tty0 rd.debug root=live:http://<serverip>/squashfs.img rw

5. Created the /exports/root filesystem to include the base packages for CentOS

yum --releasever=6 groupinstall Base --installroot=/exports/root

6. Exported this via /exports/root via NFS

7. Squashed it to try with the livenet module

mksquashfs /exports/root /var/www/html/squashfs.img -e /var/www/html

Additional InformationI even tried uninstalling the version of dracut that is installed with CentOS and installing dracut 024 (including the network modules), but this did not make a difference.

At this point, I'm trying anyway to create a diskless system to boot over the network. If there is another way (besides dracut), let me know.
TagsNo tags attached.


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2012-12-03 18:20 kecalli New Issue