View Issue Details

IDProjectCategoryView StatusLast Update
0006233CentOS-6reportpublic2013-02-02 16:59
ReporterChris Schanzle 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.3 
Target VersionFixed in Version6.3 
Summary0006233: unable to install abrt update; Requires: libreport >= 2.0.9-5.el6_3.2
Descriptionyum transaction error updating abrt
Looks like naming issue with release tag.
Not sure if this is a bad Requires in abrt or libreport versioning issue; there's no libreport category, presuming 'report'.
Steps To Reproduce# yum update
Loaded plugins: aliases, changelog, downloadonly, kabi, priorities, protectbase, refresh-
              : packagekit, security, tmprepo, verify, versionlock
Loading support for CentOS kernel ABI
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package abrt.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt.x86_64 0:2.0.8-6.el6.centos.2 will be an update
--> Processing Dependency: libreport >= 2.0.9-5.el6_3.2 for package: abrt-2.0.8-6.el6.centos.2.x86_64
---> Package abrt-addon-ccpp.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-addon-ccpp.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-addon-kerneloops.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-addon-kerneloops.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-addon-python.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-addon-python.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-cli.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-cli.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-desktop.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-desktop.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-gui.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-gui.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-libs.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-libs.x86_64 0:2.0.8-6.el6.centos.2 will be an update
---> Package abrt-tui.x86_64 0:2.0.8-6.el6.centos will be updated
---> Package abrt-tui.x86_64 0:2.0.8-6.el6.centos.2 will be an update
--> Finished Dependency Resolution
Error: Package: abrt-2.0.8-6.el6.centos.2.x86_64 (updates)
           Requires: libreport >= 2.0.9-5.el6_3.2
           Installed: libreport-2.0.9-5.el6.centos.2.x86_64 (@updates)
               libreport = 2.0.9-5.el6.centos.2
           Available: libreport-2.0.9-5.el6.centos.i686 (base)
               libreport = 2.0.9-5.el6.centos
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Additional Informationrecent updates:
$ ls -ltr libreport*.rpm
-rw-r--r-- 2 schanzle 771div 41256 Jan 31 17:19 libreport-gtk-2.0.9-5.el6.centos.2.i686.rpm
-rw-r--r-- 2 schanzle 771div 234372 Jan 31 17:19 libreport-2.0.9-5.el6.centos.2.i686.rpm
-rw-r--r-- 2 schanzle 771div 10540 Jan 31 17:19 libreport-gtk-devel-2.0.9-5.el6.centos.2.i686.rpm
-rw-r--r-- 2 schanzle 771div 24132 Jan 31 17:19 libreport-devel-2.0.9-5.el6.centos.2.i686.rpm
-rw-r--r-- 1 schanzle 771div 25956 Jan 31 17:19 libreport-plugin-rhtsupport-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 19392 Jan 31 17:19 libreport-plugin-mailx-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 30404 Jan 31 17:19 libreport-plugin-bugzilla-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 31972 Jan 31 17:19 libreport-python-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 16124 Jan 31 17:19 libreport-plugin-kerneloops-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 41804 Jan 31 17:19 libreport-gtk-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 24132 Jan 31 17:19 libreport-devel-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 233672 Jan 31 17:19 libreport-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 20032 Jan 31 17:19 libreport-plugin-reportuploader-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 18296 Jan 31 17:19 libreport-plugin-logger-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 15224 Jan 31 17:19 libreport-newt-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 10516 Jan 31 17:19 libreport-gtk-devel-2.0.9-5.el6.centos.2.x86_64.rpm
-rw-r--r-- 1 schanzle 771div 20628 Jan 31 17:19 libreport-cli-2.0.9-5.el6.centos.2.x86_64.rpm
TagsNo tags attached.

Relationships

has duplicate 0006236 resolvedIssue Tracker abrt requiring version of libreport not available 

Activities

toracat

toracat

2013-02-01 07:40

manager   ~0016379

abrt requires libreport >= 2.0.9-5.el6_3.2. However, version '2.0.9-5.el6.centos.2' is older than version '2.0.9-5.el6_3.2', so yum cannot find the version of libreport that satisfies the requirement.
paszczak000

paszczak000

2013-02-01 11:25

reporter   ~0016381

The same error: CentOS release 6.3 (Final)

Error: Package: abrt-2.0.8-6.el6.centos.2.x86_64 (updates)
           Requires: libreport >= 2.0.9-5.el6_3.2
           Removing: libreport-2.0.9-5.el6.centos.x86_64 (@base)
               libreport = 2.0.9-5.el6.centos
           Updated By: libreport-2.0.9-5.el6.centos.2.x86_64 (updates)
               libreport = 2.0.9-5.el6.centos.2
RemcoCentos

RemcoCentos

2013-02-01 14:36

reporter   ~0016383

Same error here after fresh install of CentOS release 6.3 (Final).

After fresh install run yum update, and this error appears:

--> Finished Dependency Resolution
Error: Package: abrt-2.0.8-6.el6.centos.2.x86_64 (updates)
           Requires: libreport >= 2.0.9-5.el6_3.2
           Removing: libreport-2.0.9-5.el6.centos.x86_64 (@anaconda-CentOS-201207061011.x86_64/6.3)
               libreport = 2.0.9-5.el6.centos
           Updated By: libreport-2.0.9-5.el6.centos.2.x86_64 (updates)
               libreport = 2.0.9-5.el6.centos.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Newbornus

Newbornus

2013-02-01 15:06

reporter   ~0016389

Same there. Fixed by using -skip-broken but this is not the resolution of the problem.
jleafey

jleafey

2013-02-01 15:09

reporter   ~0016391

I was able to get the update to succeed on my system by using --skip-broken and --exclude='abrt*'. It doesn't fix it, but it does let me get the rest of the updates.

Thinking about it, the --skip-broken was probably not required.
sswuste

sswuste

2013-02-01 15:27

reporter   ~0016392

I had the same issue but solved it by removing the epel.repo
RemcoCentos

RemcoCentos

2013-02-01 15:30

reporter   ~0016393

I ran the updates with the --exclude='abrt*' switch.
Chris Schanzle

Chris Schanzle

2013-02-01 15:48

reporter   ~0016394

sswuste - are you sure about epel having any effect? This still fails, which is *only* using the updates repo.

yum --disablerepo=\* --enablerepo=updates update

excluding abrt\* seems the likely best temporary workaround.
sswuste

sswuste

2013-02-01 16:02

reporter   ~0016395

@chris Schanzle yes it worked on my System:
Linux 2.6.32-279.5.2.el6.x86_64

I did a lot to fix the problem but nothing worked until:
  667 cd /etc/yum.repos.d/
  668 ls -al
  669 rm epel.repo
  670 yum clean all

After that my yum upgrade did not come back with the bug mentioned.
janlugt

janlugt

2013-02-01 16:06

reporter   ~0016396

I think the 'yum clean all' fixed it. I did not have the epel in my repositories, but a simple 'yum clean all' fixed my problems.
sswuste

sswuste

2013-02-01 16:07

reporter   ~0016397

@janlugt i tried the yum clean all also before removing the epel but for me it did not work at that moment
paszczak000

paszczak000

2013-02-01 16:11

reporter   ~0016398

yum clean all is not working.
Chris Schanzle

Chris Schanzle

2013-02-01 16:11

reporter   ~0016399

New abrt packages were just respun. Not an epel issue, just a timing issue.
abrt* (and all updates) are installing fine.
Thanks toracat!
toracat

toracat

2013-02-01 16:15

manager   ~0016400

A revised version of abrt has been released. It now Requires: libreport >= 2.0.9-5.el6.centos.2 thus solves the issue.
tigalch

tigalch

2013-02-02 16:59

manager   ~0016407

With the new packages the dependency issue is solved.

Issue History

Date Modified Username Field Change
2013-02-01 06:42 Chris Schanzle New Issue
2013-02-01 07:40 toracat Note Added: 0016379
2013-02-01 07:41 toracat Priority high => urgent
2013-02-01 07:41 toracat Status new => confirmed
2013-02-01 11:25 paszczak000 Note Added: 0016381
2013-02-01 14:36 RemcoCentos Note Added: 0016383
2013-02-01 15:06 Newbornus Note Added: 0016389
2013-02-01 15:09 jleafey Note Added: 0016391
2013-02-01 15:27 sswuste Note Added: 0016392
2013-02-01 15:30 RemcoCentos Note Added: 0016393
2013-02-01 15:48 Chris Schanzle Note Added: 0016394
2013-02-01 16:02 sswuste Note Added: 0016395
2013-02-01 16:06 janlugt Note Added: 0016396
2013-02-01 16:07 sswuste Note Added: 0016397
2013-02-01 16:11 paszczak000 Note Added: 0016398
2013-02-01 16:11 Chris Schanzle Note Added: 0016399
2013-02-01 16:15 toracat Note Added: 0016400
2013-02-01 16:29 toracat Relationship added has duplicate 0006236
2013-02-02 16:59 tigalch Note Added: 0016407
2013-02-02 16:59 tigalch Status confirmed => resolved
2013-02-02 16:59 tigalch Fixed in Version => 6.3
2013-02-02 16:59 tigalch Resolution open => fixed