View Issue Details

IDProjectCategoryView StatusLast Update
0006306CentOS-6kernelpublic2013-03-15 19:48
ReporterJrSysAdmin 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformCentOSOS6.4OS Version6.4
Product Version6.3 
Target VersionFixed in Version 
Summary0006306: VirtualBox VM doesn't boot after upgrade to 6.4
DescriptionI have a CentOS Virtual Machine that I upgraded to CentOS 6.4 from 6.3 via yum update. Upon restart the machine does not boot anymore.

If you press escape at the boot screen before it freezes you can see it stops at "Starting atd [ OK ]"
Steps To ReproduceUpdate CentOS 6.3 VirtualBox VM to CentOS 6.4
TagsNo tags attached.

Activities

JrSysAdmin

JrSysAdmin

2013-03-11 21:05

reporter   ~0016658

0006301

Fixed by removing /etc/X11/xorg.conf as advised in that ticket
JrSysAdmin

JrSysAdmin

2013-03-11 21:24

reporter   ~0016659

Trying to upgrade VboxLinuxAdditions


Verifying archive integrity... All good.
Uncompressing VirtualBox 4.2.8 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 4.2.4 of VirtualBox Guest Additions...

Hangs at removing old installed version, related?
toracat

toracat

2013-03-12 15:00

manager   ~0016670

You may want to check this out:

https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=41693&forum=55

It's about a patch to create the VirtualBox guestadditions.
uromahn

uromahn

2013-03-14 19:02

reporter   ~0016714

The suggested fix (removing, or better renaming xorg.conf) fixed it for me.

Here is the process that worked for me:
1. completely uninstall VirtualBox Guest Additions (using /opt/VBoxGuestAdditions-4.2.8/uninstall.sh) *before* removing/renaming xorg.conf
2. reboot and then login as root to remove/rename xorg.conf (IMPORTANT: you should establish access to your VM via ssh before that since the console screen will "hang" during boot time)
3. reboot and re-install VirtualBox Guest Additions (NOTE: unless you have patched them, there will be one failure regarding the openGL module which can be ignored.

You should be up-and-running again :)
toracat

toracat

2013-03-14 19:22

manager   ~0016716

@uromahn

Thanks for your note.

@JrSysAdmin

Were you able to fix the issue?
JrSysAdmin

JrSysAdmin

2013-03-14 19:28

reporter   ~0016717

I was about to reply to the comment about the patch and as I was doing do the install suddenly completed.

I thought it hung or something, but eventually it went.

Would the fact that it took so long to complete still be a bug though?
toracat

toracat

2013-03-14 19:39

manager   ~0016718

As far as it completes successfully, I wouldn't call 'taking a long time' a bug. I'm going to close this report as 'resolved'. Feel free to reopen if you think there still is a bug.
alicealice

alicealice

2013-03-15 02:39

reporter   ~0016720

My host machine is Windows 7. The solution says to uninstall Guest Addition and remove/rename the conf file. But how am I supposed to do these while I am not able to even boot the VM?
I am really new to this. I am assuming there is some way to skip the boot and log in directly? Could someone please let me know how to do that?

Thank you!
JrSysAdmin

JrSysAdmin

2013-03-15 18:36

reporter   ~0016726

@alicealice

Boot in runlevel1 (S, Single User mode) or boot the Live CD and remove it from there.

Push E when the OS is selected in Grub, go to the second line and push A. Add a 1 after all the text there, and boot, not sure of the exact keys to press from here, I think just pushing enter at this screen will boot, if it takes you back to the menu push B to boot.
toracat

toracat

2013-03-15 19:48

manager   ~0016728

The original issue resolved. For further help, please use one of the support venues.

Issue History

Date Modified Username Field Change
2013-03-11 20:55 JrSysAdmin New Issue
2013-03-11 21:05 JrSysAdmin Note Added: 0016658
2013-03-11 21:24 JrSysAdmin Note Added: 0016659
2013-03-12 15:00 toracat Note Added: 0016670
2013-03-14 19:02 uromahn Note Added: 0016714
2013-03-14 19:22 toracat Note Added: 0016716
2013-03-14 19:22 toracat Status new => feedback
2013-03-14 19:28 JrSysAdmin Note Added: 0016717
2013-03-14 19:28 JrSysAdmin Status feedback => assigned
2013-03-14 19:39 toracat Note Added: 0016718
2013-03-15 02:39 alicealice Note Added: 0016720
2013-03-15 18:36 JrSysAdmin Note Added: 0016726
2013-03-15 19:48 toracat Note Added: 0016728
2013-03-15 19:48 toracat Status assigned => resolved
2013-03-15 19:48 toracat Resolution open => fixed