CentOS Bug Tracker
CentOS Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006321CentOS-6centos-releasepublic2013-03-14 17:472016-05-23 10:50
ReporterLarry Newitt 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformDell R720OSCentOSOS Version6.4
Product Version6.4 
Target VersionFixed in Version6.5 
Summary0006321: Minimal CD will not install in UEFI mode
DescriptionI attempted to use minimal install CD to install on a system which uses UEFI to boot. I get an error "Error 15: File not found" and the system will not boot.
Steps To ReproduceBoot system and install from the minimal CD.
Additional InformationThe problem is that the pxeboot directory is missing from the Images directory.
The /EFI/BOOT/BOOTX64.conf file points to this directory for the vmlinuz and initrd images.

I copied the pxeboot directory from the normal 6.4 CD and rebuilt the minimal CD.
I was then able to boot and install from my new CD.
TagsQA-6.5
Attached Files

- Relationships

-  Notes
(0017016)
ct16k (reporter)
2013-03-27 11:21

I've encountered the same problem with the minimal install CD, but instead of rebuilding it, I just edited the grub menu item at boot, to load the kernel from /isolinux instead of /images/pxeboot.
(0017649)
DCB (reporter)
2013-07-12 02:30

Thanks to both. Edited during boot, solved.
(0017655)
tigalch (developer)
2013-07-12 18:42

If I remember correct the minimal ISO is not intended to boot from EFI. The full DVD1 does however boot from EFI.
(0018184)
C3PJim (reporter)
2013-10-16 15:06

Hi,

Forgive me if I'm posting this in the wrong section, I don't normally write in forums.

I'm new to CentOS and Linux in general, and I was wondering if someone could detail the Edit during boot so that I can follow the instructions.
(0018186)
tigalch (developer)
2013-10-16 16:41
edited on: 2013-10-17 15:48

@C3PJim: Asking in the CentOS-forums is the appropriate place for this. You can find them at https://www.centos.org/modules/newbb/index.php?cat=9. [^]

(0018416)
toracat (developer)
2013-11-26 17:50

Is there a plan to make the minimal ISO to be bootable from EFI in 6.5?
(0018428)
tigalch (developer)
2013-11-29 16:11

With the release of 6.5 the minimal ISO has been tested to run in the EFI flavours of vBox and ESXi (5.1). Hopefully this covers enough EFI flavours (but we can't test on every hardware).
(0018436)
arrfab (administrator)
2013-11-29 18:00

Minimal.iso (for x86_64) works now in EFI mode (Fixed and tested during 6.5 QA tests)
(0026657)
JohnnyHughes (administrator)
2016-05-23 10:50

NOTE: As of CentOS-6.8, here is the status:

No Version of CentOS-6 uses Secureboot. Secureboot must be disabled to install ANY CentOS-6.

No Version of i386 ISO for CentOS-6.8 uses UEFI. You must use legacy boot mode for any 32 bit CentOS-6.

All x86_64 ISOs for CentOS-6.8 will boot and install on UEFI machines as long as Secure Boot is disabled.

- Issue History
Date Modified Username Field Change
2013-03-14 17:47 Larry Newitt New Issue
2013-03-27 11:21 ct16k Note Added: 0017016
2013-07-12 02:30 DCB Note Added: 0017649
2013-07-12 18:42 tigalch Note Added: 0017655
2013-07-12 18:42 tigalch Status new => feedback
2013-10-16 15:06 C3PJim Note Added: 0018184
2013-10-16 16:41 tigalch Note Added: 0018186
2013-10-17 15:48 tigalch Note Edited: 0018186 View Revisions
2013-10-18 03:36 toracat Tag Attached: QA-6.5
2013-11-26 17:50 toracat Note Added: 0018416
2013-11-29 16:11 tigalch Note Added: 0018428
2013-11-29 18:00 arrfab Note Added: 0018436
2013-11-29 18:00 arrfab Status feedback => resolved
2013-11-29 18:00 arrfab Fixed in Version => 6.5
2013-11-29 18:00 arrfab Resolution open => fixed
2016-05-23 10:50 JohnnyHughes Note Added: 0026657


Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker