View Issue Details

IDProjectCategoryView StatusLast Update
0006346CentOS-6kernelpublic2013-11-22 20:35
Reporterpgreco 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.4 
Target VersionFixed in Version6.5 
Summary0006346: Bios Warns about thermal shutdown
DescriptionI've just installed CentOS 6.4 on my HP4295us Laptop and every time I reboot bios warns about a Thermal Shutdown (090d) even though it's not the case.
I've bisected and I'm pretty sure this patch solves this problem https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=9bcb8118965ab4631a65ee0726e6518f75cda6c5 .
I'm building 2.6.32-358.2.1 with the patch applied and will report back when it's done.
I think this should be reported to RH instead of here, but I don't know which is the proper procedure.

Trying to find the problem, I found many HP laptops with the same problem.
TagsNo tags attached.

Activities

tigalch

tigalch

2013-03-29 07:12

manager   ~0017036

Yes, if the issue is in the kernel reporting it upstream is indeed the way to procede. Please do so at https://bugzilla.redhat.com.
If the patch works it could be considered for inclusion in the CentOS-Plus-Kernel (until it is solved upstream).
pgreco

pgreco

2013-03-29 10:37

developer   ~0017037

I've just confirmed that this works!!!, I'll try to report it upstream, thanks.
toracat

toracat

2013-03-29 12:55

manager   ~0017039

Thank you for reporting a bug with a positive result of the patch. I will try to add the patch to the next update to the centosplus kernel.
pgreco

pgreco

2013-03-30 12:53

developer   ~0017047

Reported upstream as https://bugzilla.redhat.com/show_bug.cgi?id=929293 .
toracat

toracat

2013-03-30 12:59

manager   ~0017048

It is not publicly accessible. Could you please add my registered email address toracat <at> elrepo.org to the CC list?
toracat

toracat

2013-03-30 17:10

manager  

centos-linux-2.6-fix-thermal-shutdown-warns-bug6346.patch (1,695 bytes)
centos-linux-2.6-fix-thermal-shutdown-warns-bug6346.patch
http://bugs.centos.org/view.php?id=6346

commit 9bcb8118965ab4631a65ee0726e6518f75cda6c5
Author: Matthew Garrett <mjg@redhat.com>
Date:   Wed Feb 1 10:26:54 2012 -0500

    ACPI: Evaluate thermal trip points before reading temperature

    An HP laptop (Pavilion G4-1016tx) has the following code in _TMP:

           Store (\_SB.PCI0.LPCB.EC0.RTMP, Local0)
           If (LGreaterEqual (Local0, S4TP))
           {
               Store (One, HTS4)
           }

    S4TP is initialised at 0 and not programmed further until either _HOT or
    _CRT is called. If we evaluate _TMP before the trip points then HTS4 will
    always be set, causing the firmware to generate a message on boot
    complaining that the system shut down because of overheating. The simplest
    solution is just to reverse the checking of trip points and _TMP in thermal
    init.

    Signed-off-by: Matthew Garrett <mjg@redhat.com>
    Signed-off-by: Len Brown <len.brown@intel.com>

    Applied by: Akemi Yagi <toracat@centos.org>

--- a/drivers/acpi/thermal.c	2009-12-02 19:51:21.000000000 -0800
+++ b/drivers/acpi/thermal.c	2013-03-30 10:02:51.000000000 -0700
@@ -1315,13 +1315,13 @@
 	if (!tz)
 		return -EINVAL;
 
-	/* Get temperature [_TMP] (required) */
-	result = acpi_thermal_get_temperature(tz);
+	/* Get trip points [_CRT, _PSV, etc.] (required) */
+	result = acpi_thermal_get_trip_points(tz);
 	if (result)
 		return result;
 
-	/* Get trip points [_CRT, _PSV, etc.] (required) */
-	result = acpi_thermal_get_trip_points(tz);
+	/* Get temperature [_TMP] (required) */
+	result = acpi_thermal_get_temperature(tz);
 	if (result)
 		return result;
 
toracat

toracat

2013-03-30 17:11

manager   ~0017049

centos patch uploaded:

http://bugs.centos.org/file_download.php?file_id=1466&type=bug
toracat

toracat

2013-03-30 23:52

manager   ~0017053

Cplus test kernel with the patch applied is now available from :

http://people.centos.org/toracat/kernel/6/plus/bug6346/

( kernel-2.6.32-358.2.1.bug6316bug6346.el6.centos.plus )

Please note that the packages are not signed. They are provided for testing purposes only.
toracat

toracat

2013-04-23 22:34

manager   ~0017275

The patch is now in the official centosplus kernel 2.6.32-358.6.1.el6.
toracat

toracat

2013-11-22 20:32

manager   ~0018387

This bug was fixed in EL6.5GA.

Issue History

Date Modified Username Field Change
2013-03-29 04:02 pgreco New Issue
2013-03-29 07:12 tigalch Note Added: 0017036
2013-03-29 10:37 pgreco Note Added: 0017037
2013-03-29 12:55 toracat Note Added: 0017039
2013-03-29 12:55 toracat Status new => assigned
2013-03-30 12:53 pgreco Note Added: 0017047
2013-03-30 12:59 toracat Note Added: 0017048
2013-03-30 17:10 toracat File Added: centos-linux-2.6-fix-thermal-shutdown-warns-bug6346.patch
2013-03-30 17:11 toracat Note Added: 0017049
2013-03-30 23:52 toracat Note Added: 0017053
2013-04-23 22:34 toracat Note Added: 0017275
2013-11-22 20:32 toracat Note Added: 0018387
2013-11-22 20:32 toracat Resolution open => fixed
2013-11-22 20:32 toracat Product Version 6.4 => 6.5
2013-11-22 20:35 toracat Status assigned => resolved
2013-11-22 20:35 toracat Product Version 6.5 => 6.4
2013-11-22 20:35 toracat Fixed in Version => 6.5