View Issue Details

IDProjectCategoryView StatusLast Update
0006665CentOS-6qemu-kvmpublic2013-10-25 11:21
Reporterpanda84 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformIntel PCOSCentOSOS Version6.4
Product Version6.4 
Target VersionFixed in Version 
Summary0006665: Guests can ping each other but not ssh when using MACVTAP + virtio device
DescriptionCentOS host updated @ 13 sep 2013
# uname -a
Linux boltzmann 2.6.32-358.6.2.el6.x86_64 #1 SMP Thu May 16 20:59:36 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.355.0.1.el6.centos.7.x86_64

The problem is similar to this one:
https://groups.google.com/forum/#!msg/mailing.freebsd.bugs/gw42Il1AX0o/3zj-gnRKgHIJ

Two guests (tried both Fedora 19 and Ubuntu 12.04, without change) both with:
- MACVTAP to eth0
- device model: virtio
- source mode: bridge

The guests can ping each other, but cannot ssh or access to any service each other.
Steps To Reproduce- CentOS 6 host
- 2 F19 guests
- MACVTAP to eth0
- device model: virtio
- source mode: bridge
- test ping: OK
- test ssh: fail
Additional InformationImportant observations:
- changing ONLY the device model in both guests to "Hypervisor default" which is "rtl8139" or other device models solves the problem: they can ssh each other;
- having only one guest with "virtio" makes it impossibile to ssh the guest with "rtl8139" (although as usual they can ping each other);
- (not 100% sure to remember correctly, but quite likely) using a Fedora 17 host presents the same problem (I think qemu-kvm-1.0.1-6.fc17.x86_64)
- (100% sure) using a Fedora 19 host fixes the issue: virtio guests can ssh each other (qemu-kvm-1.4.2-7.fc19.x86_64).

Let me know if you need any other test or information.
TagsNo tags attached.

Activities

tigalch

tigalch

2013-09-13 12:46

manager   ~0017996

I see the kernel is still at -358.6.2. Any specific reason you are not running -358.18.1? (most current kernel)
panda84

panda84

2013-09-13 12:50

reporter   ~0017997

Yes, the host keeps up several guests so I don't reboot often. If there's any indication kernel-2.6.32-358.18.1.el6.x86_64 might fix this I'd be glad to try.
tigalch

tigalch

2013-09-27 18:51

manager   ~0018093

I didn't check the change log, but it is available here https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/6.4_Technical_Notes/kernel.html
panda84

panda84

2013-09-30 13:05

reporter   ~0018109

Tried the latest kernel, but the problem is still present immutated:
# uname -r
2.6.32-358.18.1.el6.x86_64
All the updates have been applied.

It's easy to reproduce: install two guests using MACVTAP and use virtio on one of the two.
panda84

panda84

2013-10-25 11:21

reporter   ~0018255

Same problem on a recent kernel, so it's probably not a kernel problem:
# uname -r
3.11.4-1.el6.elrepo.x86_64

Issue History

Date Modified Username Field Change
2013-09-13 09:33 panda84 New Issue
2013-09-13 12:46 tigalch Note Added: 0017996
2013-09-13 12:50 panda84 Note Added: 0017997
2013-09-27 18:51 tigalch Note Added: 0018093
2013-09-30 13:05 panda84 Note Added: 0018109
2013-10-25 11:21 panda84 Note Added: 0018255