View Issue Details

IDProjectCategoryView StatusLast Update
0006682CentOS-6kernelpublic2013-09-27 19:55
Reportergoldyfruit 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version6.4 
Target VersionFixed in Version 
Summary0006682: kernel and kernel debuginfo are not the same
DescriptionHi,

After a crash server i tried to analyze the crashdump generated by Kdump.
To do that i used crash utility but it seem that kernel-debuginfo are not the same that the kernel.

# crash -s /usr/lib/debug/lib/modules/2.6.32-358.18.1.el6.centos.plus.x86_64/vmlinux /var/crash/127.0.0.1-2013-09-26-18\:52\:13/vmcore

Result :

WARNING: kernels compiled by different gcc versions:
  /usr/lib/debug/lib/modules/2.6.32-358.18.1.el6.centos.plus.x86_64/vmlinux: 4.4.6
  /var/crash/127.0.0.1-2013-09-26-18:52:13/vmcore kernel: 4.4.7

WARNING: kernel version inconsistency between vmlinux and dumpfile

crash: page excluded: kernel virtual address: ffffffff81c1bbc0 type: "current_task (per_cpu)"
crash: page excluded: kernel virtual address: ffffffff81c1bbc0 type: "current_task (per_cpu)"
crash: page excluded: kernel virtual address: ffffffff81c1bbc0 type: "current_task (per_cpu)"
crash: page excluded: kernel virtual address: ffffffff81c1bbc0 type: "current_task (per_cpu)"
crash: page excluded: kernel virtual address: ffffffff81c232a4 type: "tss_struct ist array"

Do you have any fix to solve this issue ?

Thanks guys !

Gaëtan
Additional InformationPackages version :

crash-6.1.0-1.el6.x86_64
kernel-debuginfo-common-x86_64-2.6.32-358.18.1.el6.centos.plus.x86_64
kernel-2.6.32-358.18.1.el6.x86_64
kernel-debuginfo-2.6.32-358.18.1.el6.centos.plus.x86_64
TagsNo tags attached.

Activities

toracat

toracat

2013-09-27 15:22

manager   ~0018080

You are mixing the distro kernel and centosplus kernel. Please try again with the matching debuginfo package.
goldyfruit

goldyfruit

2013-09-27 15:41

reporter   ~0018082

I used this repository :

[debug]
name=CentOS-6 - Debuginfo
baseurl=http://debuginfo.centos.org/6/$basearch/
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-6
enabled=1
toracat

toracat

2013-09-27 16:09

manager   ~0018084

Because your kernel is 2.6.32-358.18.1.el6, you'd need to pick up the ones without the "centos.plus" tag. Did yum find the wrong debuginfo packages ?
goldyfruit

goldyfruit

2013-09-27 16:32

reporter   ~0018086

Hum,

I should use this command to be sure that the good kernel-debuginfo parckage will be installed :

# yum install kernel-debuginfo-`uname -r`

Very strange, why by default yum wants to install the centosplus package ?

Thanks, i'll try with this debuginfo.
toracat

toracat

2013-09-27 16:52

manager   ~0018087

> why by default yum wants to install the centosplus package ?

Version 2.6.32-358.18.1.el6.centos.plus is "newer" than 2.6.32-358.18.1.el6 as far as yum is concerned. So, as you just did, it is necessary to specify the right one.
goldyfruit

goldyfruit

2013-09-27 19:36

reporter   ~0018097

Ok it works with the good kernerl-debuginfo package.
Thanks toracat !

Gaëtan
toracat

toracat

2013-09-27 19:54

manager   ~0018098

Good to know things are working now. Will close this as 'resolved'.

Issue History

Date Modified Username Field Change
2013-09-27 13:40 goldyfruit New Issue
2013-09-27 15:22 toracat Note Added: 0018080
2013-09-27 15:41 goldyfruit Note Added: 0018082
2013-09-27 16:09 toracat Note Added: 0018084
2013-09-27 16:32 goldyfruit Note Added: 0018086
2013-09-27 16:52 toracat Note Added: 0018087
2013-09-27 19:36 goldyfruit Note Added: 0018097
2013-09-27 19:54 toracat Note Added: 0018098
2013-09-27 19:55 toracat Status new => resolved
2013-09-27 19:55 toracat Resolution open => no change required