View Issue Details

IDProjectCategoryView StatusLast Update
0006697CentOS-6NetworkManagerpublic2013-10-23 07:07
Reporterjantho 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformDell E6420XFROSCentOSOS Version6.4
Product Version6.4 
Target VersionFixed in Version 
Summary0006697: Segmentation fault when connecting
DescriptionAfter applying the following updates:

NetworkManager.x86_64 1:0.8.1-61.el6_4
NetworkManager-glib.x86_64 1:0.8.1-61.el6_4
NetworkManager-gnome.x86_64 1:0.8.1-61.el6_4

I can no longer connect to any network (wireless or cable). nm-applet exits with a segmentation fault.
Steps To ReproduceAlways happens when connecting to a network.
Additional InformationI tried removing all network configurations and restarted nm-applet and the computer many times. I finally got it back to work by downgrading to NetworkManager-0.8.1-43.el6.x86_64.
TagsNo tags attached.

Activities

jantho

jantho

2013-10-09 09:09

reporter   ~0018170

Tried same update on other machine, no problem. The problematic machine is using VirtualBox-4.2-4.2.18_88780_el6-1.x86_64, the other machine not. Maybe a problem with VirtualBox network settings?
Rob230

Rob230

2013-10-18 15:01

reporter   ~0018194

I've had the same problem. I'm running CentOS 6.4 in VirtualBox-4.2.18 (on Windows 7 host).

I updated NetworkManager, NetworkManager-glib and NetworkManager-gnome. After a restart I had no Internet and the icon had gone and I got a segmentation fault every time I tried to start NetworkManager, which was configured to automatically connect.

At first I thought I was in a bit of a catch-22 situation since I couldn't downgrade NetworkManager without access to the Internet, but eventually I realised I could disable the NetworkManager service and set up the connection myself using ifconfig. Then I was able to downgrade NetworkManager, which fixed the problem.
tigalch

tigalch

2013-10-18 19:46

manager   ~0018195

I might be having a different setup here, but I just changed eth0 to NM-controlled and installed NetworkManager. Prior to that I stoped the network service, and afterwards I started NetworkManager. Pinging 8.8.8.8 didn't work prior to starting NetworkManager, and worked again afterwards. I could also start/open the NetworkManager GUI.
jantho

jantho

2013-10-18 20:08

reporter   ~0018196

Well in my case it was exactly the other way around. I have a CentOS 6.4 host and the problem occurs without even starting a virtual machine.
I just thought about VitualBox because I have 3 other machines that don't show this problem and have a very similar setup. Only difference is that they don't have VirtualBox installed.
OlivierL

OlivierL

2013-10-20 07:25

reporter   ~0018201

I've the same issue on a Lenovo R61i with the wireless.
When I run "nm-applet" with my user id, I get an error "Segmentation Fault".
I've run "nm-applet" as root user, no error, it's working.

The difference between user id and root wireless setting is:
  User id:
    - IPv4 Settings Method = Manual
  Root:
    - IPv4 Settings Method = Automatic (DHCP)


CentOS: 6.4
kernel release: 2.6.32-358.23.2.el6.x86_64
Installed Packages
NetworkManager.x86_64 1:0.8.1-61.el6_4 @updates
NetworkManager-glib.x86_64 1:0.8.1-61.el6_4 @updates
NetworkManager-gnome.x86_64 1:0.8.1-61.el6_4 @updates
NetworkManager-vpnc.x86_64 1:0.8.0-1.git20100411.el6 @epel
tigalch

tigalch

2013-10-21 11:29

manager   ~0018203

I just retried again as non-root user, killed nm-applet and restarted it (ip is set to manual). At least in a VM i don't experience those issues.
roentgen

roentgen

2013-10-23 07:03

reporter   ~0018218

Confirm the bug on my Thinkpad T61.
NetworkManager successfully connects to WiFi, but upon connecting the Ethernet cable nm-applet segfaults:

$ nm-applet
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
Segmentation fault (core dumped)
$ ps auxw|grep Net
root 4603 0.5 0.0 98156 5868 ? Ssl 12:47 0:00 NetworkManager --pid-file=/var/run/NetworkManager/NetworkManager.pid

Downgrade resolves the problem:
Removed:
  NetworkManager.x86_64 1:0.8.1-61.el6_4
  NetworkManager-glib.x86_64 1:0.8.1-61.el6_4
  NetworkManager-gnome.x86_64 1:0.8.1-61.el6_4

Installed:
  NetworkManager.x86_64 1:0.8.1-43.el6
  NetworkManager-glib.x86_64 1:0.8.1-43.el6
  NetworkManager-gnome.x86_64 1:0.8.1-43.el6

$ cat /etc/redhat-release
CentOS release 6.4 (Final)
$ uname -a
Linux ibm2 2.6.32-358.23.2.el6.x86_64 #1 SMP Wed Oct 16 18:37:12 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
tigalch

tigalch

2013-10-23 07:07

manager   ~0018219

Please be so kind a report this upstream at https://bugzilla.redhat.com. Once it gets fixed there, CentOS will inherit the fix.

Issue History

Date Modified Username Field Change
2013-10-09 07:33 jantho New Issue
2013-10-09 09:09 jantho Note Added: 0018170
2013-10-18 15:01 Rob230 Note Added: 0018194
2013-10-18 19:46 tigalch Note Added: 0018195
2013-10-18 20:08 jantho Note Added: 0018196
2013-10-20 07:25 OlivierL Note Added: 0018201
2013-10-21 11:29 tigalch Note Added: 0018203
2013-10-23 07:03 roentgen Note Added: 0018218
2013-10-23 07:07 tigalch Note Added: 0018219