View Issue Details

IDProjectCategoryView StatusLast Update
0006726CentOS-6kshpublic2013-11-06 21:54
ReporterKalmanReti 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformx86_64OSCentosOS Version6.4
Product Version6.4 
Target VersionFixed in Version 
Summary0006726: ksh fails to unset a variable sometimes
DescriptionThe innermost dotted in script sets a unique variable at the beginning
(after checking that it is not already set) and unsets it at the end.
If you invoke the upper-level script twice in a row, the second invocation
erroneously finds the variable set.
Steps To ReproduceUntar the attached tar file (which results in 4 small files). Invoke t4.ksh.
If there is no output, the file worked. If it complains about ccc, you've seen
the bug.
Additional InformationOlder versions of ksh (e.g. the one in Centos 5.7) are correct. All the ones
in Centos 6.x that I've tried fail.
TagsNo tags attached.

Activities

KalmanReti

KalmanReti

2013-11-06 21:54

reporter  

t4.tar (10,240 bytes)

Issue History

Date Modified Username Field Change
2013-11-06 21:54 KalmanReti New Issue
2013-11-06 21:54 KalmanReti File Added: t4.tar