View Issue Details

IDProjectCategoryView StatusLast Update
0006899CentOS-6-OTHERpublic2014-01-14 20:09
Reportermdieterich Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformx86_64OSCentosOS Version6.5
Summary0006899: kickstart based network install of CentOS 6.5 fails with e1000 driver
DescriptionWhen trying to kickstart an NFS based install with ethernet hardware requiring the e1000 driver, the installation fails part way through. The machine boots off the network, pulls down the kernel and initrd image, proceeds to format the disks and then comes up with a Window asking you to select select a network interface. After selecting an interface, the dialog goes away for a while stating that it's waiting for Network Manager to activate the device, which fails with a message stating:

An error occurred trying to bring up the eth0 network interface

My DHCP server sees no traffic from this machine as it is trying to do this. The network card is obviously working at some level, since it pulled the boot images, the kickstart configuration, etc. off the network. It then goes down and can't be brought back up again.

This is the second time Network Manager tries to bring the interface up during the install process. The first time, just prior to performing a disk partitioning, it works just fine.

Actually, as I was writing this, I kicked over another install to track down the various failure points and this time it got to the point of downloading packages for install. The network interface went down after download 7 of 239 packages and the install just hung.

I rolled back to a CentOS 6.4 based installation and it seems to be going through just fine. I suspect there is some sort of issue with the e1000 driver included with the CentOS 6.5 distribution.
TagsNo tags attached.

Relationships

duplicate of 0006810 closedtoracat LAN Driver Crash after update and reboot 

Activities

toracat

toracat

2014-01-13 22:20

manager   ~0019041

Possibly related to bug #6810. What is your hardware?
mdieterich

mdieterich

2014-01-14 19:28

reporter   ~0019052

Confirmed, this is due to the same issue as ~<0006810>. When I tossed pcie_aspm=off, the install could complete as expected. Feel free to close this out as a duplicate.

Thanks!

Mark
mdieterich

mdieterich

2014-01-14 19:32

reporter   ~0019053

Er... that should have referenced #0006810.
toracat

toracat

2014-01-14 20:09

manager   ~0019054

Closing as a dupe of #6810.

Issue History

Date Modified Username Field Change
2014-01-13 21:54 mdieterich New Issue
2014-01-13 22:20 toracat Note Added: 0019041
2014-01-14 19:28 mdieterich Note Added: 0019052
2014-01-14 19:32 mdieterich Note Added: 0019053
2014-01-14 20:08 toracat Relationship added duplicate of 0006810
2014-01-14 20:09 toracat Note Added: 0019054
2014-01-14 20:09 toracat Status new => closed
2014-01-14 20:09 toracat Resolution open => duplicate