2017-08-16 15:08 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0007126CentOS-6-OTHERpublic2014-07-01 20:48
Reporterpantinor 
PriorityhighSeverityminorReproducibilityalways
StatusassignedResolutionopen 
PlatformDocker Centos official ImageOScentos:latestOS Version
Product Version 
Target VersionFixed in Version 
Summary0007126: Update libselinux on Docker official image
DescriptionSee description started on Fedora bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=1098120


Using Centos Docker image on a system with selinux enabled fails
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0019775

toracat (manager)

Message posted by Dan Walsh:

http://lists.centos.org/pipermail/centos-devel/2014-May/010345.html

~0019829

ekohl (reporter)

Since this landed I have problems with multilib and enabling centosplus works around it. Yum output:

centos-6.example.com 15:23:25$ yum install -y puppet
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.widexs.nl
 * extras: mirror.oxilion.nl
 * updates: centos.mirror.triple-it.nl
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:3.6.1-1.el6 will be installed
--> Processing Dependency: ruby-rgen >= 0.6.5 for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: ruby >= 1.8 for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: ruby >= 1.8.7 for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: facter >= 1:1.7.0 for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: rubygem-json for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.6.1-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.6.1-1.el6.noarch
--> Running transaction check
---> Package facter.x86_64 1:2.0.1-1.el6 will be installed
--> Processing Dependency: pciutils for package: 1:facter-2.0.1-1.el6.x86_64
--> Processing Dependency: virt-what for package: 1:facter-2.0.1-1.el6.x86_64
--> Processing Dependency: dmidecode for package: 1:facter-2.0.1-1.el6.x86_64
---> Package hiera.noarch 0:1.3.3-1.el6 will be installed
---> Package libselinux-ruby.x86_64 0:2.0.94-5.3.el6_4.1 will be installed
--> Processing Dependency: libselinux = 2.0.94-5.3.el6_4.1 for package: libselinux-ruby-2.0.94-5.3.el6_4.1.x86_64
---> Package ruby.x86_64 0:1.8.7.352-13.el6 will be installed
--> Processing Dependency: ruby-libs = 1.8.7.352-13.el6 for package: ruby-1.8.7.352-13.el6.x86_64
--> Processing Dependency: libruby.so.1.8()(64bit) for package: ruby-1.8.7.352-13.el6.x86_64
---> Package ruby-augeas.x86_64 0:0.4.1-3.el6 will be installed
--> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
---> Package ruby-rgen.noarch 0:0.6.5-2.el6 will be installed
---> Package ruby-shadow.x86_64 1:2.2.0-2.el6 will be installed
---> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-json-1.5.5-1.el6.x86_64
--> Running transaction check
---> Package augeas-libs.x86_64 0:1.0.0-5.el6_5.1 will be installed
---> Package dmidecode.x86_64 1:2.12-5.el6_5 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: libdl.so.2 for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: ld-linux.so.2 for package: libselinux-2.0.94-5.3.el6_4.1.i686
---> Package pciutils.x86_64 0:3.1.10-2.el6 will be installed
--> Processing Dependency: pciutils-libs = 3.1.10-2.el6 for package: pciutils-3.1.10-2.el6.x86_64
--> Processing Dependency: libpci.so.3(LIBPCI_3.1)(64bit) for package: pciutils-3.1.10-2.el6.x86_64
--> Processing Dependency: libpci.so.3(LIBPCI_3.0)(64bit) for package: pciutils-3.1.10-2.el6.x86_64
--> Processing Dependency: libpci.so.3()(64bit) for package: pciutils-3.1.10-2.el6.x86_64
---> Package ruby-libs.x86_64 0:1.8.7.352-13.el6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.352-13.el6.x86_64
---> Package rubygems.noarch 0:1.3.7-5.el6 will be installed
--> Processing Dependency: ruby-rdoc for package: rubygems-1.3.7-5.el6.noarch
---> Package virt-what.x86_64 0:1.11-1.2.el6 will be installed
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package glibc.i686 0:2.12-1.132.el6_5.2 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6_5.2.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6_5.2.i686
---> Package pciutils-libs.x86_64 0:3.1.10-2.el6 will be installed
---> Package ruby-rdoc.x86_64 0:1.8.7.352-13.el6 will be installed
--> Processing Dependency: ruby-irb = 1.8.7.352-13.el6 for package: ruby-rdoc-1.8.7.352-13.el6.x86_64
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-10.el6_5 will be installed
---> Package ruby-irb.x86_64 0:1.8.7.352-13.el6 will be installed
--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libselinux which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libselinux of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libselinux.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libselinux installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libselinux installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libselinux-2.0.94-5.3.el6_4.1.i686 != libselinux-2.0.94-5.3.0.1.el6.centos.plus.x86_64
 You could try using --skip-broken to work around the problem

~0019831

Evolution (administrator)

Thanks for the update with the work-around. You're correct in that you will have to pull in the multilib pieces of libselinux from centosplus until this patch makes its way into the core distribution. We've been told to expect it around the 6.6 timeframe (no idea when that is)

~0020056

clev2k (reporter)

Hi, neither of the workarounds are working for me. I'm trying to download npm, [yum install -y npm].

When I use any of the options mentioned to skip it, it states that it skips it because it's available from epel:

[Packages skipped because of dependency problems:
...
npm-1.3.6-5.el6.noarch from epel]

Does anyone have any suggestions on how to get around this?

Cheers,
Carl.

~0020057

Evolution (administrator)

Carl,
What you've pasted doesn't say it's skipped because it's from epel. It's skipped because there are dependency issues. We'd need to see more of the paste to know exactly why. It could be this issue, or it could be something else.

~0020133

Freman (reporter)

Hi, I thought I'd add my two cents and error paste.

It's still an issue in the centos build I pulled from docker today

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.aarnet.edu.au
 * extras: mirror.aarnet.edu.au
 * updates: mirror.aarnet.edu.au
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:3.6.2-1.el6 will be installed
--> Processing Dependency: facter >= 1:1.7.0 for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: ruby >= 1.8.7 for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: ruby >= 1.8 for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: ruby-rgen >= 0.6.5 for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: rubygem-json for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: initscripts for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-3.6.2-1.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-3.6.2-1.el6.noarch
--> Running transaction check
---> Package facter.x86_64 1:2.1.0-1.el6 will be installed
--> Processing Dependency: dmidecode for package: 1:facter-2.1.0-1.el6.x86_64
--> Processing Dependency: pciutils for package: 1:facter-2.1.0-1.el6.x86_64
--> Processing Dependency: virt-what for package: 1:facter-2.1.0-1.el6.x86_64
--> Processing Dependency: which for package: 1:facter-2.1.0-1.el6.x86_64
---> Package hiera.noarch 0:1.3.4-1.el6 will be installed
---> Package initscripts.x86_64 0:9.03.40-2.el6.centos.1 will be installed
--> Processing Dependency: upstart >= 0.6.0 for package: initscripts-9.03.40-2.el6.centos.1.x86_64
--> Processing Dependency: ethtool >= 1.8-2 for package: initscripts-9.03.40-2.el6.centos.1.x86_64
--> Processing Dependency: /sbin/ip for package: initscripts-9.03.40-2.el6.centos.1.x86_64
--> Processing Dependency: /sbin/arping for package: initscripts-9.03.40-2.el6.centos.1.x86_64
---> Package libselinux-ruby.x86_64 0:2.0.94-5.3.el6_4.1 will be installed
--> Processing Dependency: libselinux = 2.0.94-5.3.el6_4.1 for package: libselinux-ruby-2.0.94-5.3.el6_4.1.x86_64
---> Package ruby.x86_64 0:1.8.7.352-13.el6 will be installed
--> Processing Dependency: ruby-libs = 1.8.7.352-13.el6 for package: ruby-1.8.7.352-13.el6.x86_64
--> Processing Dependency: libruby.so.1.8()(64bit) for package: ruby-1.8.7.352-13.el6.x86_64
---> Package ruby-augeas.x86_64 0:0.4.1-3.el6 will be installed
--> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
---> Package ruby-rgen.noarch 0:0.6.5-2.el6 will be installed
---> Package ruby-shadow.x86_64 1:2.2.0-2.el6 will be installed
---> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-json-1.5.5-1.el6.x86_64
--> Running transaction check
---> Package augeas-libs.x86_64 0:1.0.0-5.el6_5.1 will be installed
---> Package dmidecode.x86_64 1:2.12-5.el6_5 will be installed
---> Package ethtool.x86_64 2:3.5-1.4.el6_5 will be installed
---> Package iproute.x86_64 0:2.6.32-32.el6_5 will be installed
--> Processing Dependency: iptables >= 1.4.5 for package: iproute-2.6.32-32.el6_5.x86_64
--> Processing Dependency: libxtables.so.4()(64bit) for package: iproute-2.6.32-32.el6_5.x86_64
---> Package iputils.x86_64 0:20071127-17.el6_4.2 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: libdl.so.2 for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: libselinux-2.0.94-5.3.el6_4.1.i686
--> Processing Dependency: ld-linux.so.2 for package: libselinux-2.0.94-5.3.el6_4.1.i686
---> Package pciutils.x86_64 0:3.1.10-2.el6 will be installed
--> Processing Dependency: pciutils-libs = 3.1.10-2.el6 for package: pciutils-3.1.10-2.el6.x86_64
--> Processing Dependency: libpci.so.3(LIBPCI_3.1)(64bit) for package: pciutils-3.1.10-2.el6.x86_64
--> Processing Dependency: libpci.so.3(LIBPCI_3.0)(64bit) for package: pciutils-3.1.10-2.el6.x86_64
--> Processing Dependency: libpci.so.3()(64bit) for package: pciutils-3.1.10-2.el6.x86_64
---> Package ruby-libs.x86_64 0:1.8.7.352-13.el6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.352-13.el6.x86_64
---> Package rubygems.noarch 0:1.3.7-5.el6 will be installed
--> Processing Dependency: ruby-rdoc for package: rubygems-1.3.7-5.el6.noarch
---> Package upstart.x86_64 0:0.6.5-13.el6_5.3 will be installed
---> Package virt-what.x86_64 0:1.11-1.2.el6 will be installed
---> Package which.x86_64 0:2.19-6.el6 will be installed
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package glibc.i686 0:2.12-1.132.el6_5.2 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6_5.2.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6_5.2.i686
---> Package iptables.x86_64 0:1.4.7-11.el6 will be installed
--> Processing Dependency: policycoreutils for package: iptables-1.4.7-11.el6.x86_64
---> Package pciutils-libs.x86_64 0:3.1.10-2.el6 will be installed
---> Package ruby-rdoc.x86_64 0:1.8.7.352-13.el6 will be installed
--> Processing Dependency: ruby-irb = 1.8.7.352-13.el6 for package: ruby-rdoc-1.8.7.352-13.el6.x86_64
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-10.el6_5 will be installed
---> Package policycoreutils.x86_64 0:2.0.83-19.39.el6 will be installed
---> Package ruby-irb.x86_64 0:1.8.7.352-13.el6 will be installed
--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libselinux which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libselinux of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libselinux.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libselinux installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libselinux installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libselinux-2.0.94-5.3.el6_4.1.i686 != libselinux-2.0.94-5.3.0.1.el6.centos.plus.x86_64
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
udev-147-2.51.el6.x86_64 has missing requires of /sbin/service
udev-147-2.51.el6.x86_64 has missing requires of MAKEDEV >= ('0', '3.11', None)

~0020134

Evolution (administrator)

Freman,

In order go with multilib like this, you'll need to enable the centosplus repository explicitly for libselinux. This should ONLY be required until 6.6 comes out.

yum --enablerepo centosplus your-command-here
+Notes

-Issue History
Date Modified Username Field Change
2014-05-21 14:02 pantinor New Issue
2014-05-21 17:47 toracat Note Added: 0019775
2014-06-11 07:14 ekohl Note Added: 0019829
2014-06-11 12:34 Evolution Note Added: 0019831
2014-06-26 14:50 clev2k Note Added: 0020056
2014-06-26 15:08 Evolution Note Added: 0020057
2014-06-30 23:50 Freman Note Added: 0020133
2014-07-01 00:50 Evolution Note Added: 0020134
2014-07-01 20:48 toracat Status new => assigned
+Issue History