View Issue Details

IDProjectCategoryView StatusLast Update
0007165CentOS-7anacondapublic2014-06-18 22:42
Reporterbstinson Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0007165: Installation notifies user about the upstream EULA
DescriptionAfter completing an install, anaconda presents (at the bottom of the screen) a message saying "Use of this product is subject to the license agreement found at /usr/share/redhat-release/EULA"
TagsNo tags attached.
abrt_hash
URL

Activities

kbsingh@karan.org

kbsingh@karan.org

2014-06-17 17:45

reporter   ~0019907

I think that should be OK, we have a very basic EULA. Please check after todays release tress to make sure the EULA displayed is indeed sane and the CentOS one.

build 20140617+ should have this fixed
bstinson

bstinson

2014-06-18 02:59

administrator   ~0019911

The installer still contains the text '/usr/share/redhat-release/EULA' (see screenshot) but that file contains the correct CentOS EULA in 20140617. I'm not sure this is worth patching anaconda since it's functional, but the constant 'eulaLocation' lives in (anaconda-sourcedir)/pynaconda/constants.py if we need to generate a patch.
bstinson

bstinson

2014-06-18 03:00

administrator  

EULA_Screenshot.png (92,484 bytes)   
EULA_Screenshot.png (92,484 bytes)   
kbsingh@karan.org

kbsingh@karan.org

2014-06-18 22:42

reporter   ~0019935

Patched to reflect right place ( the redhat-release is a symlink anyway )

Issue History

Date Modified Username Field Change
2014-06-14 22:34 bstinson New Issue
2014-06-17 17:45 kbsingh@karan.org Note Added: 0019907
2014-06-17 17:45 kbsingh@karan.org Status new => feedback
2014-06-18 02:59 bstinson Note Added: 0019911
2014-06-18 02:59 bstinson Status feedback => assigned
2014-06-18 03:00 bstinson File Added: EULA_Screenshot.png
2014-06-18 22:42 kbsingh@karan.org Note Added: 0019935
2014-06-18 22:42 kbsingh@karan.org Status assigned => resolved
2014-06-18 22:42 kbsingh@karan.org Resolution open => fixed