View Issue Details

IDProjectCategoryView StatusLast Update
0007177CentOS-7firstbootpublic2018-01-26 17:25
Status assignedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0007177: Initial setup of CentOS Linux Server 7 requires license acceptance
DescriptionFirst boot of the installed CentOS 7QA 20140614-Broken comes up with a prompt to accept a license agreement. No license agreement is displayed and I do not think this prompt should be issued at all.
Steps To ReproduceInstall using the attached kickstart file. Boot the system and see the prompt.
TagsNo tags attached.




2014-06-16 00:22


seven.ks (1,424 bytes)


2014-06-16 00:26


firstboot7.jpg (51,047 bytes)
firstboot7.jpg (51,047 bytes)


2014-06-16 07:12

manager   ~0019855

Is the license displayed if you enter "1" ?


2014-06-16 08:46

developer   ~0019857

So a new kickstart option "eula --agreed" in a kickstart is meant to prevent this though my first install was a non-kickstart and I still saw this on reboot. If there was a EULA agreement in previous versions, wasn't it part of the install screens so you agreed to it during the install and the subsequent reboot didn't stop and wait?


2014-06-16 11:00

manager   ~0019860

C6 also had something you had to agree to in a GUI installation. That screen appeared after the first reboot after the installation completed


2014-09-05 11:43

reporter   ~0020833

press 1, the screen changes slightly:

    1) Read the License Agreement
[ ] 2) I accept the License Agreement

press 2, this will select the checkbox

[X] 2) I accept the License Agreement

press c, a confirmation will be displayed, stating that you accepted the license
press c again and you'll find the login prompt

2015-02-17 09:12

administrator   ~0022367

is this resolved now ?


2015-04-07 18:48

reporter   ~0022698

This is not resolved as of 7.1.1503

while the instructions do get you passed the agreement there is another problem

If you install minimal system, and then install the gui desktop with yum, when you try and start the desktop it just hangs. Presumably waiting for the license acceptance.

Not until you reboot or hard reset, does the agreement message show up.

Also I tried the eula --agreed in the ks.cfg but this didn't work

I added it right after the firstboot statement, not sure if it makes a difference where it should go.


2015-04-09 14:26

reporter   ~0022736

correction, the eula --agreed, is working to a sort.

upon boot the message has the X already in the box agreeing to the license, but you still have to type C to continue.

What program is actually doing this prompt ?, I'd like to know if I could run it manually at the command line and agree before starting the gui. Then I wouldn't have to reboot after the yum install.


2015-05-06 22:00

reporter   ~0023008

I am concerned that my installed-with-GUI-now-headless-7.0-and-then-yum-updated box will prompt (i.e. fail to fully boot) at the next reboot. Does anyone know if I need to drive to my colo or not? I only have one of these boxes so far, elsewise I'd test it...

Thanks in advance.


2015-05-15 04:01

reporter   ~0023075

I had the same mysterious troubles (blank screen after a reboot; forced power off and back on eventually got me the prompt (I tried init=/bin/bash, but that gave no clue); I figured out to select 1 then 2 then c) - and now that I'm no longer panicked about getting my system back, I'd kind of like to know what I agreed to.

So: where's the license file kept?


2015-08-15 20:50

reporter   ~0023907

Hi I don't know if this issue needs to be fixed or not but the prompt is due to the "initial-setup utility" which is separate from anaconda (centos installer).

If you guys want I can try to patch it as I am working with anaconda but I don't know if this change will be added to the official initial-setup package for CentOS.


2015-08-21 13:15

administrator   ~0023985

@StephenPSchaefer, You agreed to the EULA here:


2016-02-05 15:24

reporter   ~0025635

This bug completely brokes automated install with gui, not resolved in 7.2.1511.
That can be triggered if you run: python -m initial_setup
Something like this in kickstart-file removes the license prompt:

sed -i 's/__all__ = \["EULAspoke"\]/__all__ = \["LicenseScreen"\]/' /usr/lib/python2.7/site-packages/initial_setup/tui/spokes/


2016-02-15 20:35

reporter   ~0025732

I just got bitten by this one in a weird, somewhat big way.

I set my new server up in late December, and have rebooted it probably 5 times since, almost all in the first couple of days. Then, I moved it to a data center where I hooked up the IPMI controller. Not once during the initial reboots did I see this message, so it must have arrived in a subsequent update.

Last night, there was a problem at the DC, essentially cutting power to the server for less than a minute. As luck would have it, I was also out of contact (first time in several years, Murphy's Law).

Hours later, when I got all of the alerts, I logged into the baseboard controller, and the licensing thing was up. At first I thought someone in the DC had gained physical access to the machine and had tried to re-install the OS. I was extremely confused and, of course, the server had been offline for hours.

I didn't know what would happen if I accepted the license agreement ... would it scrub the OS and re-install ... what was going on?

Finally, on a whim, I just completed the process and got the server back. After 8 hours of downtime for a EULA prompt, one that I had never seen during previous reboots.

Anyway, it sounds like you're aware of the issue, I just figured I'd toss a real-world experience in there for you. I'd personally call it a rather serious issue, as anything that causes downtime in a server environment would probably be deemed the same.

I'm also not sure why I missed the EULA screen until what was, essentially, the ~6th reboot, but I swear to you, this is the case.

Thanks fellas.


2016-02-15 23:29

reporter   ~0025734

@SeattleRex, this might have been due to someone enabling "InitialSetup

" systemd service. You can do a systemctl enable initial-setup-text and this prompt will come on next reboot.


2018-01-25 21:15

reporter   ~0031045

I am encountering this issue as well. I am using Packer to setup a CentOS 7.4 template VM in VMware vSphere, minimal installation. After setup, I clone the VM, and then run Ansible on the clone. During the Ansible run, I install GNOME and switch the runlevel to use the GUI. Upon reboot via Ansible, the process fails because an Initial Setup screen is displayed requiring that the license be accepted. This bug completely halts Ansible and perhaps any configuration management tool in it's tracks when installing the GUI. I tried the workaround SED command provided by akelio, but it didn't do the trick for me. The only option I have is to log into the system by hand and accept the EULA. Thankfully, it's only one VM, but that number will likely grow as we'll need more and more VMs with GUIs to perform automated UI tests on via Jenkins. Please fix this ASAP!!!



2018-01-25 21:54

developer   ~0031048

systemctl disable initial-setup
systemctl disable initial-setup-text


2018-01-25 22:59

reporter   ~0031049

Hi TrevorH, thank you for the help, but that didn't work unfortunately. I can stop and disable both services, but upon reboot, the EULA prompt is back again (see screenshot). Anything I can do differently?



2018-01-26 02:02

developer   ~0031051

Do you have a $HOME/.config/gnome-initial-setup-done file containing just the word "yes" (no quotes).


2018-01-26 08:22

administrator   ~0031055

I have this in my ks.cfg file:

# missing systemctl disable initial-setup.service
systemctl disable initial-setup-graphical.service




2018-01-26 17:25

reporter   ~0031062

Thanks @tru. That worked like a charm. I just run that service disable from Ansible after installing GNOME. Upon reboot, there's no EULA prompt.

Issue History

Date Modified Username Field Change
2014-06-16 00:22 TrevorH New Issue
2014-06-16 00:22 TrevorH File Added: seven.ks
2014-06-16 00:26 TrevorH File Added: firstboot7.jpg
2014-06-16 07:12 avij Note Added: 0019855
2014-06-16 08:46 TrevorH Note Added: 0019857
2014-06-16 11:00 tigalch Note Added: 0019860
2014-09-05 11:43 mniedero Note Added: 0020833
2015-02-17 09:12 Note Added: 0022367
2015-02-17 09:12 Status new => feedback
2015-04-07 18:48 rwe Note Added: 0022698
2015-04-09 14:26 rwe Note Added: 0022736
2015-05-06 22:00 lindahl Note Added: 0023008
2015-05-15 04:01 StephenPSchaefer Note Added: 0023075
2015-08-15 20:50 asad Note Added: 0023907
2015-08-21 13:15 JohnnyHughes Note Added: 0023985
2016-02-05 15:24 akelio Note Added: 0025635
2016-02-15 20:35 SeattleRex Note Added: 0025732
2016-02-15 23:29 asad Note Added: 0025734
2018-01-25 21:15 bugreporter0202 File Added: 2018-01-25 14_12_15-PTAPacker - VMware Workstation.png
2018-01-25 21:15 bugreporter0202 Note Added: 0031045
2018-01-25 21:54 TrevorH Note Added: 0031048
2018-01-25 21:54 TrevorH Status feedback => assigned
2018-01-25 22:59 bugreporter0202 File Added: 2018-01-25 15_54_07-mRemoteNG - mRemote_confCons.xml - Test01.png
2018-01-25 22:59 bugreporter0202 Note Added: 0031049
2018-01-26 02:02 TrevorH Note Added: 0031051
2018-01-26 08:22 tru Note Added: 0031055
2018-01-26 17:25 bugreporter0202 Note Added: 0031062