View Issue Details

IDProjectCategoryView StatusLast Update
0007182CentOS-7pampublic2014-06-18 11:40
ReporterGabyB Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx84_64OSCentOSOS Version7
Summary0007182: pam-1.1.8-9.el7.i686 and pam-1.1.8-9.el7.x86_64 can't be installed parallel
DescriptionI want to install a meta package which requires 32Bit libraries, especially pam.i686. This is aborted due to conflicts in manual pages:
 
Transaction check error:
  file /usr/share/man/man8/faillock.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pam_env.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pam_faillock.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pam_unix.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pwhistory_helper.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64

Steps To ReproduceTry to install attached rpm:
yum install bruker-topspin-environ-1.0-3.el7.noarch.rpm
TagsNo tags attached.
abrt_hash
URL

Activities

GabyB

GabyB

2014-06-16 09:40

reporter  

tigalch

tigalch

2014-06-16 11:06

manager   ~0019862

From where is bruker-topspin-environ from? I can't seem to find that in the package list of C7.
GabyB

GabyB

2014-06-16 12:00

reporter   ~0019864

That is own development for easy installation 32Bit libraries. As described its a meta package, which installs all required libraries, header files and binaries
for our TopSpin program

$ rpm -qlp bruker-topspin-environ-1.0-3.el7.noarch.rpm
/usr/share/doc/bruker-topspin-environ-1.0
/usr/share/doc/bruker-topspin-environ-1.0/COPYING
/usr/share/doc/bruker-topspin-environ-1.0/README

$ rpm -qip bruker-topspin-environ-1.0-3.el7.noarch.rpm
Name : bruker-topspin-environ Relocations: (not relocatable)
Version : 1.0 Vendor: Bruker BioSpin GmbH
Release : 3.el7 Build Date: Fri 13 Dec 2013 09:14:25 AM CET
Install Date: (not installed) Build Host: localhost
Group : Virtual groups/ TopSpin Libraries Source RPM: bruker-topspin-environ-1.0-3.el7.src.rpm
Size : 18199 License: GPL
Signature : (none)
Packager : Bruker AddOn Build <nmr-support@bruker.de>
Summary : Meta Packages to Install Groups of Packages with 32-Bit Libraries for TopSpin
Description :
A virtual package to install 32-Bit libraries used by TopSpin,
and the C++ environment to compile AU-programs.
This is implemented as required package list of this one.


$ rpm -qp --requires bruker-topspin-environ-1.0-3.el7.noarch.rpm
/bin/sh
audit-libs(x86-32)
expat(x86-32)
fontconfig(x86-32)
freetype(x86-32)
gcc
gcc-c++
glibc(x86-32)
glibc-devel
glibc-devel(x86-32)
glibc-headers
kernel-headers
libICE(x86-32)
libSM(x86-32)
libX11(x86-32)
libXau(x86-32)
libXdmcp(x86-32)
libXext(x86-32)
libXft(x86-32)
libXmu(x86-32)
libXpm(x86-32)
libXrender(x86-32)
libXt(x86-32)
libXtst(x86-32)
libgcc(x86-32)
libgnome(x86-32)
libstdc++(x86-32)
pam(x86-32)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
xorg-x11-fonts-75dpi
xorg-x11-fonts-ISO8859-1-75dpi
zlib(x86-32)
rpmlib(PayloadIsXz) <= 5.2-1
avij

avij

2014-06-16 12:27

updater   ~0019865

This problem can also be reproduced with 'yum install pam.i686' without using the attached rpm.
tru

tru

2014-06-16 12:41

administrator   ~0019866

so a possible multiarch issue? ie pam.x86_64 installed in base but installing pam.i686 after, yields a conflicts on the duplicated man pages.

Since that works on plain C6, looks like a regression or misconfiguration somewhere.

On my CentOS-6.x86_64 box:
[tru@c001 ~]$ rpm -q pam
pam-1.1.1-17.el6.x86_64
[tru@c001 ~]$ sudo yum install pam.i686
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package pam.i686 0:1.1.1-17.el6 will be installed
...
Dependencies Resolved

================================================================================
 Package Arch Version Repository Size
================================================================================
Installing:
 pam i686 1.1.1-17.el6 base 659 k
Installing for dependencies:
 audit-libs i686 2.2-4.el6_5 updates 61 k
 cracklib i686 2.8.16-4.el6 base 70 k
 db4 i686 4.7.25-18.el6_4 base 580 k
 glibc i686 2.12-1.132.el6_5.2 updates 4.3 M
 libselinux i686 2.0.94-5.3.el6_4.1 base 108 k
 nss-softokn-freebl i686 3.14.3-10.el6_5 updates 147 k
Updating for dependencies:
 audit-libs x86_64 2.2-4.el6_5 updates 60 k
 glibc x86_64 2.12-1.132.el6_5.2 updates 3.8 M
 glibc-common x86_64 2.12-1.132.el6_5.2 updates 14 M

Transaction Summary
================================================================================
Install 7 Package(s)
Upgrade 3 Package(s)

Total download size: 24 M
Is this ok [y/N]: y
Downloading Packages:
(1/10): audit-libs-2.2-4.el6_5.i686.rpm | 61 kB 00:00
(2/10): audit-libs-2.2-4.el6_5.x86_64.rpm | 60 kB 00:00
(3/10): cracklib-2.8.16-4.el6.i686.rpm | 70 kB 00:00
(4/10): db4-4.7.25-18.el6_4.i686.rpm | 580 kB 00:00
(5/10): glibc-2.12-1.132.el6_5.2.i686.rpm | 4.3 MB 00:00
(6/10): glibc-2.12-1.132.el6_5.2.x86_64.rpm | 3.8 MB 00:00
(7/10): glibc-common-2.12-1.132.el6_5.2.x86_64.rpm | 14 MB 00:00
(8/10): libselinux-2.0.94-5.3.el6_4.1.i686.rpm | 108 kB 00:00
(9/10): nss-softokn-freebl-3.14.3-10.el6_5.i686.rpm | 147 kB 00:00
(10/10): pam-1.1.1-17.el6.i686.rpm | 659 kB 00:00
--------------------------------------------------------------------------------
...
Installed:
  pam.i686 0:1.1.1-17.el6

Dependency Installed:
  audit-libs.i686 0:2.2-4.el6_5
  cracklib.i686 0:2.8.16-4.el6
  db4.i686 0:4.7.25-18.el6_4
  glibc.i686 0:2.12-1.132.el6_5.2
  libselinux.i686 0:2.0.94-5.3.el6_4.1
  nss-softokn-freebl.i686 0:3.14.3-10.el6_5

Dependency Updated:
  audit-libs.x86_64 0:2.2-4.el6_5 glibc.x86_64 0:2.12-1.132.el6_5.2
  glibc-common.x86_64 0:2.12-1.132.el6_5.2

Complete!
avij

avij

2014-06-16 13:17

updater   ~0019867

Comparing the i686 and x86_64 rpms:

# diff -ru i686/ x86_64/
Binary files i686/usr/share/man/man8/faillock.8.gz and x86_64/usr/share/man/man8/faillock.8.gz differ
Binary files i686/usr/share/man/man8/pam_env.8.gz and x86_64/usr/share/man/man8/pam_env.8.gz differ
Binary files i686/usr/share/man/man8/pam_faillock.8.gz and x86_64/usr/share/man/man8/pam_faillock.8.gz differ
Binary files i686/usr/share/man/man8/pam_unix.8.gz and x86_64/usr/share/man/man8/pam_unix.8.gz differ
Binary files i686/usr/share/man/man8/pwhistory_helper.8.gz and x86_64/usr/share/man/man8/pwhistory_helper.8.gz differ

These files would need to be the same on both i686 and x86_64, but now there are differences. Looks like the difference is the timestamp embedded in the man pages. To fix this, the i686 and x86_64 rpms would need to be built on the same day.
avij

avij

2014-06-16 13:33

updater   ~0019868

You should be able to work around this problem by installing pam.i686 manually with "yum install pam.i686 --setopt tsflags=nodocs", then "yum install bruker-topspin-environ-1.0-3.el7.noarch.rpm". This bug will hopefully be fixed for C7 GA, thanks for the report.
GabyB

GabyB

2014-06-16 13:48

reporter   ~0019869

Thank you, the last note worked.
 (if I got 0007099 fixed, our program may start ;-)
avij

avij

2014-06-18 00:03

updater   ~0019910

These pam packages have now been rebuilt and are available at http://buildlogs.centos.org/centos/7/os/x86_64-20140617/Packages/

Preliminary testing suggests that these newly rebuilt packages should be installable in parallel. If this is not the case, let us know.
GabyB

GabyB

2014-06-18 09:32

reporter   ~0019913

Last edited: 2014-06-18 10:39

Still the same problem:

[root@centos7-vm ~]# yum install pam.i686
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package pam.i686 0:1.1.8-9.el7 will be installed
--> Processing Dependency: libutil.so.1(GLIBC_2.0) for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libutil.so.1 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libselinux.so.1 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libnsl.so.1(GLIBC_2.0) for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libnsl.so.1 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libdl.so.2 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libcrypt.so.1(GLIBC_2.0) for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libcrypt.so.1 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.9) for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libaudit.so.1 for package: pam-1.1.8-9.el7.i686
--> Running transaction check
---> Package audit-libs.i686 0:2.3.3-4.el7 will be installed
---> Package cracklib.i686 0:2.9.0-11.el7 will be installed
--> Processing Dependency: libz.so.1 for package: cracklib-2.9.0-11.el7.i686
---> Package glibc.i686 0:2.17-55.el7 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-55.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-55.el7.i686
---> Package libdb.i686 0:5.3.21-17.el7 will be installed
---> Package libselinux.i686 0:2.2.2-6.el7 will be installed
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.2.2-6.el7.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: libselinux-2.2.2-6.el7.i686
--> Processing Dependency: liblzma.so.5 for package: libselinux-2.2.2-6.el7.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.15.4-2.el7 will be installed
---> Package pcre.i686 0:8.32-12.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-12.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-12.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-12.el7.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-12.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: pcre-8.32-12.el7.i686
--> Processing Dependency: libgcc_s.so.1 for package: pcre-8.32-12.el7.i686
---> Package xz-libs.i686 0:5.1.2-8alpha.el7 will be installed
---> Package zlib.i686 0:1.2.7-13.el7 will be installed
--> Running transaction check
---> Package libgcc.i686 0:4.8.2-16.el7 will be installed
---> Package libstdc++.i686 0:4.8.2-16.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

 Package Arch Version Repository Size

Installing:
 pam i686 1.1.8-9.el7 centos-qa-03 709 k
Installing for dependencies:
 audit-libs i686 2.3.3-4.el7 centos-qa-03 76 k
 cracklib i686 2.9.0-11.el7 centos-qa-03 78 k
 glibc i686 2.17-55.el7 centos-qa-03 4.2 M
 libdb i686 5.3.21-17.el7 centos-qa-03 728 k
 libgcc i686 4.8.2-16.el7 centos-qa-03 93 k
 libselinux i686 2.2.2-6.el7 centos-qa-03 143 k
 libstdc++ i686 4.8.2-16.el7 centos-qa-03 300 k
 nss-softokn-freebl i686 3.15.4-2.el7 centos-qa-03 179 k
 pcre i686 8.32-12.el7 centos-qa-03 413 k
 xz-libs i686 5.1.2-8alpha.el7 centos-qa-03 106 k
 zlib i686 1.2.7-13.el7 centos-qa-03 89 k

Transaction Summary

Install 1 Package (+11 Dependent packages)

Total size: 7.0 M
Installed size: 22 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/man/man8/faillock.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pam_env.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pam_faillock.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pam_unix.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64
  file /usr/share/man/man8/pwhistory_helper.8.gz from install of pam-1.1.8-9.el7.i686 conflicts with file from package pam-1.1.8-9.el7.x86_64

Error Summary
-------------

I'm using the proposed repofile:

[root@centos7-vm ~]# cat /etc/yum.repos.d/centos-buildlogs.repo
[centos-qa-04]
name=CentOS Open QA - c7.00.04
baseurl=http://buildlogs.centos.org/c7.00.04/
enabled=1
gpgcheck=0

[centos-qa-03]
name=CentOS Open QA - c7.00.03
baseurl=http://buildlogs.centos.org/c7.00.03/
enabled=1
gpgcheck=0

avij

avij

2014-06-18 10:58

updater   ~0019914

Try this as the repofile, and remove the centos-qa-0[34] entries:

[centos-qa-latest]
name=CentOS
baseurl=http://buildlogs.centos.org/centos/7/os/x86_64-latest/
enabled=1
gpgcheck=0

Then run "yum clean all" and "yum reinstall pam.x86_64", or do a fresh install. Installing pam.i686 should work after these steps.
GabyB

GabyB

2014-06-18 11:38

reporter   ~0019915

With the modified repo file the pam.i686 could successfully installed
tigalch

tigalch

2014-06-18 11:39

manager   ~0019916

Marking this issue as SOLVED per feedback from reporter.

Issue History

Date Modified Username Field Change
2014-06-16 09:40 GabyB New Issue
2014-06-16 09:40 GabyB File Added: bruker-topspin-environ-1.0-3.el7.noarch.rpm
2014-06-16 11:06 tigalch Note Added: 0019862
2014-06-16 12:00 GabyB Note Added: 0019864
2014-06-16 12:27 avij Note Added: 0019865
2014-06-16 12:41 tru Note Added: 0019866
2014-06-16 13:17 avij Note Added: 0019867
2014-06-16 13:33 avij Note Added: 0019868
2014-06-16 13:48 GabyB Note Added: 0019869
2014-06-18 00:03 avij Note Added: 0019910
2014-06-18 00:03 avij Status new => feedback
2014-06-18 09:32 GabyB Note Added: 0019913
2014-06-18 09:32 GabyB Status feedback => assigned
2014-06-18 10:39 avij Note Edited: 0019913
2014-06-18 10:58 avij Note Added: 0019914
2014-06-18 10:58 avij Status assigned => feedback
2014-06-18 11:38 GabyB Note Added: 0019915
2014-06-18 11:38 GabyB Status feedback => assigned
2014-06-18 11:39 tigalch Note Added: 0019916
2014-06-18 11:39 tigalch Status assigned => resolved
2014-06-18 11:39 tigalch Resolution open => fixed