View Issue Details

IDProjectCategoryView StatusLast Update
0007187CentOS-7[All Projects] generalpublic2014-06-29 18:45
Reportersman 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformVMWARE Workstation 9.0.3OSCentosOS Version7
Product Version 
Target VersionFixed in Version 
Summary0007187: boot.iso does not detect network interface
DescriptionBoot from boot.iso it does not detect VMware interface. I tried with it set to bridged and NAT in VMware container settings. I also tried manually adding bond interface as ethernet with a static IP.
Steps To ReproduceCreate new VMWare container. Select CentOS or CentOS 64 as OS type. Boot from boot.iso image.
TagsNo tags attached.
abrt_hash
URL

Activities

spital

spital

2014-06-17 08:15

reporter   ~0019885

the same with me.
possibly driver issue ? Fedora 20 live works fine with vmplayer and says :

02:01.0 Ethernet controller: Advanced Micro Devices, Inc. [AMD] 79c970 [PCnet32 LANCE] (rev 10)
    Subsystem: Advanced Micro Devices, Inc. [AMD] PCnet - Fast 79C971
    Kernel driver in use: pcnet32

it should be here:
/usr/lib/...../kernel/drivers/net/ethernet/amd/pcnet32.ko
or
..../kernel/drivers/net/pcnet32.ko

but it is not in case of centos 7 live.
Please include
tigalch

tigalch

2014-06-17 09:22

manager   ~0019887

Have you tried a different network card typ? Also - without refering to Fedora - RHEL7 is not listed as supproted guest on Workstation9.
spital

spital

2014-06-17 11:49

reporter   ~0019888

thanks for quick reply.

* I have no idea, how to change network card type in VMware vmplayer. My physical net interface is gigabit Intel 82577LM. Any help is welcome

* "support" on vmwareXXX means "automatic login and serial code input etc" - many linuxes are not supported - and yet they work well

I kindly ask for including pcnet32 kernel module in the build. Although (not only) I can test rhel7 with qemu, it seems to be 3 times slower than with free linux vmplayer.
tigalch

tigalch

2014-06-17 12:06

manager   ~0019889

Probably bad news:
That one is not supported, at least not in EL7 beta, so probably also not in GA. Also 'confirmed' by RedHat:
>>
Yes, the pcnet32 driver has been removed. Use the emulated Intel e1000 device, or preferably the paravirtualized VMWare vmxnet3 device.
>>
Taken from here https://access.redhat.com/site/discussions/644133
sman

sman

2014-06-17 17:16

reporter   ~0019900

As per that discussion link above this will at least get it working.

>>
In order for me to get this working I had to add the following line to the vmdk file for the VM.

ethernet0.virtualDev = "e1000"

Afterward you remove the VM and re-add it. Following the directions provided by Remmele and then this last step got it all sorted out for me.
<<
sman

sman

2014-06-17 17:22

reporter   ~0019901

Actually this is the discussion where it's mentioned. At the bottom.

https://access.redhat.com/site/discussions/722093
tigalch

tigalch

2014-06-17 17:32

manager   ~0019903

@spital: That is also the guide on how to change the virtual NIC :)
tigalch

tigalch

2014-06-17 17:40

manager   ~0019904

Last edited: 2014-06-18 12:13

View 2 revisions

I'm inclined to close this one, as it 'works as designed'. Any objections?

arrfab

arrfab

2014-06-18 13:18

administrator   ~0019920

Closing, it as it was confirmed to be the default behaviour for upstream iso/kernel.

Issue History

Date Modified Username Field Change
2014-06-16 21:49 sman New Issue
2014-06-17 08:15 spital Note Added: 0019885
2014-06-17 09:22 tigalch Note Added: 0019887
2014-06-17 11:49 spital Note Added: 0019888
2014-06-17 12:06 tigalch Note Added: 0019889
2014-06-17 12:06 tigalch Status new => feedback
2014-06-17 17:16 sman Note Added: 0019900
2014-06-17 17:16 sman Status feedback => assigned
2014-06-17 17:22 sman Note Added: 0019901
2014-06-17 17:32 tigalch Note Added: 0019903
2014-06-17 17:40 tigalch Note Added: 0019904
2014-06-17 17:40 tigalch Status assigned => feedback
2014-06-18 12:13 tigalch Note Edited: 0019904 View Revisions
2014-06-18 13:18 arrfab Note Added: 0019920
2014-06-18 13:18 arrfab Status feedback => closed
2014-06-18 13:18 arrfab Resolution open => fixed