View Issue Details

IDProjectCategoryView StatusLast Update
0007192CentOS-7abrtpublic2014-06-23 20:15
Reporterdavidlmansfield Assigned To 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Summary0007192: branding issue with abrt-tui-2.1.11-12.el7.x86_64
DescriptionAfter a crash, if I run "abrt-cli list" I get the text:

Run 'abrt-cli report /var/tmp/abrt/ccpp-2014-06-17-10:22:54-7411' for creating a case in Red Hat Customer Portal

I'm not sure what the correct behavior for abrt should be for centos, but this seems incorrect.
Steps To ReproduceAfter something crashes, run "abrt-cli list" . Look for references to "Red Hat Customer Portal"
TagsQA-7.0
abrt_hash
URL

Activities

davidlmansfield

davidlmansfield

2014-06-17 21:11

reporter  

0001-comment-out-a-RH-patch-from-spec-which-puts-a-RH-bra.patch (1,115 bytes)   
From d7377ac59156f029ae578ea82e77a190edc32429 Mon Sep 17 00:00:00 2001
From: David Mansfield <david@orthanc.cobite.com>
Date: Tue, 17 Jun 2014 17:10:59 -0400
Subject: [PATCH] comment out a RH patch from spec which puts a RH branding
 into command output

---
 SPECS/abrt.spec | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/SPECS/abrt.spec b/SPECS/abrt.spec
index d7be8b8..5914a28 100644
--- a/SPECS/abrt.spec
+++ b/SPECS/abrt.spec
@@ -54,7 +54,7 @@ Patch12: 0012-configui-show-Close-button-in-the-dialog.patch
 Patch13: 0013-applet-do-not-say-the-report-is-anonymous-when-urepo.patch
 #Patch14: 0014-spec-abrt-cli-requires-a-pkg-providing-workflows.patch
 #Patch15: 0015-testsuite-encourage-users-to-create-a-case-in-RHTS.patch
-Patch16: 0016-cli-list-show-a-hint-about-creating-a-case-in-RHTS.patch
+#Patch16: 0016-cli-list-show-a-hint-about-creating-a-case-in-RHTS.patch
 Patch17: 0017-harvest-vmcore-properly-handle-inaccessible-dir-erro.patch
 Patch18: 0018-don-t-break-the-event-run-by-failures-of-abrt-action.patch
 Patch19: 0019-Fix-handling-of-Machine-Check-Exceptions.patch
-- 
1.9.3

davidlmansfield

davidlmansfield

2014-06-17 21:15

reporter   ~0019909

The offending line is added via a RH patch ( 0016-cli-list-show-a-hint-about-creating-a-case-in-RHTS.patch). The attached spec patch simply comments out this line from the spec, which should remove the "offending" line from the command output.

Note issue#0007193 is related: the module which actually attempts to submit to RH Customer Support is still installed and active after this patch to abrt.
davidlmansfield

davidlmansfield

2014-06-18 13:42

reporter   ~0019921

This is probably a duplicate of issue#0007168 (which is about problems encountered during installation anaconda).
Evolution

Evolution

2014-06-18 15:58

reporter   ~0019923

Updated per this patch. commit dacf575

Should be resolved in the next build.
JohnnyHughes

JohnnyHughes

2014-06-23 20:15

administrator   ~0020008

modified package in the testing tree

Issue History

Date Modified Username Field Change
2014-06-17 14:33 davidlmansfield New Issue
2014-06-17 21:11 davidlmansfield File Added: 0001-comment-out-a-RH-patch-from-spec-which-puts-a-RH-bra.patch
2014-06-17 21:15 davidlmansfield Note Added: 0019909
2014-06-18 13:42 davidlmansfield Note Added: 0019921
2014-06-18 15:58 Evolution Note Added: 0019923
2014-06-20 00:50 toracat Tag Attached: QA-7.0
2014-06-23 20:15 JohnnyHughes Note Added: 0020008
2014-06-23 20:15 JohnnyHughes Status new => resolved
2014-06-23 20:15 JohnnyHughes Resolution open => fixed