View Issue Details

IDProjectCategoryView StatusLast Update
0007218CentOS-7efibootmgrpublic2014-10-07 17:50
Reportertoracat Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0007218: efibootmgr shows 'Red Hat Enterprise Linux'
DescriptionTested on a VBox guest.

# cat /etc/redhat-release
CentOS Linux release 7 (Broken)

# efibootmgr
BootCurrent: 0001
BootOrder: 0000,0001,0002,0003,0000,0001,0002
Boot0000* EFI DVD/CDROM
Boot0001* EFI Hard Drive
Boot0002* EFI Internal Shell
Boot0003* Red Hat Enterprise Linux
TagsQA-7.0
abrt_hash
URL

Activities

avij

avij

2014-06-26 22:34

updater   ~0020078

At this moment my server says:

# efibootmgr
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0009,0001,0000,0005,0006,0003,0004,0007,0008
Boot0000* HL-DT-ST DVD-ROM DU90N
Boot0001* Red Hat Enterprise Linux
Boot0002* CentOS
Boot0003* Windows Boot Manager
Boot0004* Virtual Floppy
Boot0005 EFI Network 1
Boot0006 EFI Network 2
Boot0007* Virtual CD
Boot0008* EFI Fixed Disk Boot Device 1
Boot0009* CentOS Linux

The list is pulled from firmware, and shows all the operating systems that have ever been installed on the system. The list can naturally be cleared somehow. My list shows that at least some CentOS version that I tested used the proper name. The first versions may indeed have used RHEL instead as the name.
JohnnyHughes

JohnnyHughes

2014-07-08 07:32

administrator   ~0020219

Is this issue now fixed?
avij

avij

2014-07-08 10:40

updater   ~0020221

I removed the RHEL entry from the boot menu with efibootmgr at some point, and after a few installations of various CentOS install methods I no longer see RHEL in that menu. Looks like it's fixed.
tigalch

tigalch

2014-10-07 17:50

manager   ~0021082

Thus marking as solved.

Issue History

Date Modified Username Field Change
2014-06-19 20:55 toracat New Issue
2014-06-20 00:39 toracat Tag Attached: QA-7.0
2014-06-26 22:34 avij Note Added: 0020078
2014-06-26 22:34 avij Status new => acknowledged
2014-07-08 07:32 JohnnyHughes Note Added: 0020219
2014-07-08 07:32 JohnnyHughes Status acknowledged => feedback
2014-07-08 10:40 avij Note Added: 0020221
2014-10-07 17:50 tigalch Note Added: 0021082
2014-10-07 17:50 tigalch Status feedback => resolved
2014-10-07 17:50 tigalch Resolution open => fixed
2014-10-20 12:14 shengvvvvv Issue cloned: 0007725