View Issue Details

IDProjectCategoryView StatusLast Update
0007242CentOS-7grub2public2014-07-03 12:46
Reporteravij Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Summary0007242: CentOS should store its UEFI files in a directory named centos
DescriptionCurrently CentOS stores its UEFI configuration files in /boot/efi/EFI/redhat. This should be changed to /boot/efi/EFI/centos to prevent conflicts with RHEL installations.
TagsNo tags attached.
abrt_hash
URL

Activities

tru

tru

2014-06-24 13:17

administrator   ~0020023

Caveat, that will break scripts running on both distributions.

SCL|devtools are using /opt/rh, not /opt/centos ;)
avij

avij

2014-06-24 14:59

updater   ~0020026

The difference is that the UEFI system partition mounted to /boot/efi can be shared between all the operating systems installed on the box. CentOS should play nice and not mess with files "owned" by other operating systems.

As a test, I installed RHEL7rc1 on one half of my hard disk, and then attempted to install CentOS 7 on the other half, reusing the EFI system partition that was created during the RHEL7rc1 installation. CentOS 7's installer crashed at the "Installing bootloader" stage:

File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1704, in remove_efi_boot_target
  raise BootLoaderError("failed to remove old efi boot entry")

I have reason to believe that this would have worked if CentOS used its own "centos" directory.
toracat

toracat

2014-06-24 17:05

manager   ~0020028

Just for the record, I encountered the same "failed to remove old efi boot entry" error at the "post-installation setup" step while installing RHEL 7 GA.

I now do not have a precise log of the event, but I believe the system had a previously installed RHEL (7RC). What I then did was as follows:

Did a Ctrl-Alt F2
At the shell prompt, chroot /mnt/sysimage
Ran 'grub2-config'

The system booted but I found some irregularities.
- For example, network setup was absent (despite the fact it was done during install).
- /etc/default/grub is missing

because of missing /etc/default/grub, symlink from /etc/sysconfig was broken.

In the end, I did a fresh (re)install and all was fine.

[/For the record]
toracat

toracat

2014-06-27 08:24

manager   ~0020082

"failed to remove old efi boot entry" is a known issue.

https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/7.0_Release_Notes/Known-Issues-Installation.html

[quote]
kernel component, BZ#1055814
    When installing Red Hat Enterprise Linux 7 on UEFI-based systems, the Anaconda installer terminates unexpectedly with the following error:

    BootLoaderError: failed to remove old efi boot entry

    To work around this problem, edit the Install Red Hat Enterprise Linux 7 option in the boot menu by pressing the e key and append the efi_no_storage_paranoia kernel parameter to the end of the line that begins with linuxefi. Then press the F10 key to boot the modified option and start installation.
[/quote]
arrfab

arrfab

2014-07-03 12:45

administrator   ~0020160

Fixed with BuildTag 20140702-1907

Issue History

Date Modified Username Field Change
2014-06-24 13:00 avij New Issue
2014-06-24 13:17 tru Note Added: 0020023
2014-06-24 14:59 avij Note Added: 0020026
2014-06-24 17:05 toracat Note Added: 0020028
2014-06-26 22:35 avij Status new => assigned
2014-06-27 08:24 toracat Note Added: 0020082
2014-07-03 12:45 arrfab Note Added: 0020160
2014-07-03 12:45 arrfab Status assigned => resolved
2014-07-03 12:45 arrfab Resolution open => fixed