View Issue Details

IDProjectCategoryView StatusLast Update
0007244CentOS-7anacondapublic2014-07-09 09:45
ReporterLorry Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status acknowledgedResolutionopen 
Summary0007244: 'No such file or directory' error after pressing 'Begin Installation' on Apple iMac
DescriptionJust after pressing 'Begin Installation' in CentOS 7, I get an 'No such file or directory' error and installations throws me into debugging mode.

Up to that point I don't have any problems setting up the network, access to install packages, see the drives in the disk formatting window etc.

I have tried to format the install drive with different formats before reaching the disk formatting window, e.g. ext4, but the install always quit at the same point: Just when 'Begin Installation' is pressed.

I also get the following error:
FormatCreateError: (OSError(2, 'No such file or directory'), '/dev/sda1')

BUT I could clearly see /dev/sda in the disk formatting window before pressing 'Begin Installation'.

I have attached the bug automatic bug report created by the installer.

Thanks for looking into this!
TagsNo tags attached.
abrt_hash
URL

Relationships

related to 0007327 acknowledgedavij Missing 'mactel-boot' package on DVD iso fails install on Macbook Pro 

Activities

Lorry

Lorry

2014-06-24 14:11

reporter  

Lorry

Lorry

2014-06-24 14:14

reporter   ~0020025

Just want to add that I am using the latest boot.iso image.
avij

avij

2014-06-24 19:24

updater   ~0020037

You seem to be trying to install on an "Apple Inc. iMac11,1/Mac". What kind of partitioning did you try to use? Usually wiping the entire disk and letting the installer do the partitioning automatically works quite nicely. If you are trying to set up dual booting between CentOS and MacOSX, I would suggest waiting for the next build of the boot.iso, as there are changes scheduled for UEFI booting.

Also note that the current version is only for testing and should not be used on production system. In particular, if you have anything important on your hard drive(s), please make good backups of your system prior to testing these builds. This QA build may eat kittens or other lovely animals, especially Apple kittens, which uses its odd implementation of UEFI.

There is this line in your anaconda.log:
10:57:30,485 INFO anaconda: Creating hfs+ on /dev/sda1
I don't know how you managed to convince anaconda to use hfs+ for that partition, as that isn't even a supported filesystem type.
Lorry

Lorry

2014-06-25 19:15

reporter   ~0020046

Seems like this has been reported earlier in the Red Hat forums, but from what I can tell it has not been solved. The comments mention a workaround that works [I have tested it] even though it's not ideal and should be fixed in the install code:
https://access.redhat.com/site/discussions/658253

Taken from the third comment shown on the page linked to above:
"
1. Boot to installation media.
2. Switch to vt2. (ctrl-alt-f2).
3. Run parted. Delete all partitions.
4. Edit /usr/lib/python2.7/site-packages/blivet/arch.py. Modify isMactel() function to always return False.
5. Run restart-anaconda.
"

This is for the use case where 'CentOS 7/RHEL 7' is the ONLY OS on the disk. There is also a workaround when OS X lives together with 'CentOS 7/RHEL 7' on the same disk, see the same link above.

In short: There is an error when installing CentOS 7 on Mac machines, and this should be fixed! :-)
avij

avij

2014-06-30 08:56

updater   ~0020116

Although I don't dispute your findings regarding this issue, I'm afraid this will need to get fixed in RHEL first. Any fixes done there will eventually propagate to CentOS as well. In practical terms, the first opportunity where this bug could be fixed is in CentOS 7.1 (or some other number; CentOS version numbering is being discussed at the moment).
avij

avij

2014-07-09 09:44

updater   ~0020280

Please see if adding the mactel-boot package from Fedora 19 or 20 as described in http://bugs.centos.org/view.php?id=7327#c20279 helps with your issue.

Now that CentOS 7 has been officially released, please remember to use the latest released .iso images for your testing. The GA version by itself is unlikely to help with your issue, but accompanied with the aforementioned F19 or F20 packages it just might work. Fingers crossed.

Issue History

Date Modified Username Field Change
2014-06-24 14:11 Lorry New Issue
2014-06-24 14:11 Lorry File Added: centos_7_24-06-2014.tar.gz
2014-06-24 14:14 Lorry Note Added: 0020025
2014-06-24 19:24 avij Note Added: 0020037
2014-06-25 19:15 Lorry Note Added: 0020046
2014-06-30 08:56 avij Note Added: 0020116
2014-06-30 08:56 avij Status new => acknowledged
2014-06-30 08:56 avij Summary CentOS 7 – 'No such file or directory' error after pressing 'Begin Installation' => 'No such file or directory' error after pressing 'Begin Installation' on Apple iMac
2014-07-09 09:44 avij Note Added: 0020280
2014-07-09 09:45 avij Relationship added related to 0007327