View Issue Details

IDProjectCategoryView StatusLast Update
0007282CentOS-7anacondapublic2014-07-03 12:30
Reporterguidow Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentOSOS Version7 RC 20140630
Summary0007282: Anaconda crashes when selecting "Closest Mirror" install source: 'YumPayload' object has no attribute 'getBaseRepo'
DescriptionWhen choosing "Closest Mirror" as the install source for CentOS 7, Anaconda will crash. The installation process cannot be continued when that happens.
Steps To Reproduce- Boot a computer or virtual machine from the ISO image found at http://buildlogs.centos.org/centos/7/os/x86_64-20140630/images/boot.iso
- Choose Install CentOS 7
- Configure the installation language
- In the "Installation Summary" screen, click on "Installation Source"
- The dropdown under "On the network" should default to "Closest mirror". Don't change anything, click "Done".

A window titled "An unknown error has occured" appears.
Additional InformationThe error reporter has generated a tar.gz file with crash information, which I am attaching here.
TagsNo tags attached.
abrt_hash
URL

Activities

guidow

guidow

2014-07-02 10:19

reporter  

problem-report.tar.gz (71,097 bytes)
guidow

guidow

2014-07-02 10:25

reporter   ~0020151

I just noticed that, while I was writing that, a new RC with version "20140702" was released.
The bug is still present in 20140702.
arrfab

arrfab

2014-07-02 12:44

administrator   ~0020152

yeah, we also discovered that. Devs are working on a fix and we hope to be able to release a newer tree today.
You can still install if you select "http" and points to the normal tree
arrfab

arrfab

2014-07-03 12:30

administrator   ~0020159

That option has been completely removed (needs more work on the server side) and it's now ok since tree x86_64-20140702-2

Issue History

Date Modified Username Field Change
2014-07-02 10:19 guidow New Issue
2014-07-02 10:19 guidow File Added: problem-report.tar.gz
2014-07-02 10:25 guidow Note Added: 0020151
2014-07-02 12:44 arrfab Note Added: 0020152
2014-07-02 12:44 arrfab Status new => acknowledged
2014-07-03 12:30 arrfab Note Added: 0020159
2014-07-03 12:30 arrfab Status acknowledged => resolved
2014-07-03 12:30 arrfab Resolution open => fixed