View Issue Details

IDProjectCategoryView StatusLast Update
0007293CentOS-7-OTHERpublic2015-12-14 06:59
Reporteravij 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version7.2.1511 
Summary0007293: Encrypted filesystem in UEFI mode on VirtualBox won't boot
DescriptionWhen installing CentOS 7 in UEFI mode on VirtualBox using an encrypted filesystem, the installed system stops prior to asking for the volume's passphrase.

The following combinations do work:
- CentOS 7 in BIOS mode on VirtualBox using an encrypted fs
- CentOS 7 in UEFI mode on VirtualBox not using an encrypted fs
- CentOS 7 in UEFI mode on real hardware using an encrypted fs

It is only the combination of all these three components that causes problems.
Steps To ReproduceCreate a new virtual machine in VirtualBox, check the "Enable EFI support" checkbox from the Settings > System > Motherboard page, install CentOS7 with the "Encrypt my data" option selected, reboot.
Additional InformationThis bug has also been confirmed with RHEL7rc1. It is unclear at this time if this is a bug in RHEL/CentOS or VirtualBox. This bug has been reproduced with VirtualBox 4.3.10 and 4.3.12
TagsNo tags attached.
abrt_hash
URL

Activities

avij

avij

2014-07-03 16:42

manager   ~0020169

A workaround is to remove the "rhgb quiet" options from the kernel command line.
avij

avij

2014-07-03 22:50

manager   ~0020174

Upstream bug entry: https://bugzilla.redhat.com/show_bug.cgi?id=1116159
sangala

sangala

2014-07-13 11:00

reporter   ~0020409

A i think the problem is not so specific.
I tried it in VMWare Worsktation 8 and in my case:
 Without 'rhbg' it is OK, with this options the system "stop" after detect disk.
 To see detail remove 'quiet' options too.

To reproduce:
           Create new VM with I/O controler: LSI Logic
                                            (BusLogic is not detected)
           Install with using "encrypted filesystem" checkbox.
           On reboot the system stops.
           Remove 'rhbg' and the ask for password is shown.
wolfy

wolfy

2014-07-14 10:03

developer   ~0020425

I confirm that the same issue appears with VMware Workstation 10 using an encrypted fs in BIOS mode
Removing "rhgb" from the grub2 options allows the dialogue to be displayed.
avij

avij

2014-07-14 10:04

manager   ~0020426

Sangala: Did you use BIOS mode or UEFI mode? I don't know about VMware, but I suppose it can be selected from the settings somewhere.
sangala

sangala

2014-07-14 14:37

reporter   ~0020427

Avij wrote:
>> Did you use BIOS mode or UEFI mode?...

I used VM Work. 8 with standard machine definition - it is without UEFI.
(I have never used UEFI in VM Work., but it is possible by manual configuration editing and add: 'firmware = "efi"' - I hope… )

I can test it in VM Work. with UEFI or I can test in KVM.
But I think this trouble doesn't depend on UEFI - it is common trouble "encrypt and rhgb combination" trouble.

The question: Does it work someone without modification GRUB menu when you install with encryption option?
sangala

sangala

2014-07-14 19:01

reporter   ~0020431

I've tested it on KVM (CentOS 6.5), and the result is:

»System doesn't start after reboot if installation with encrypted filesystem is used.«

I think the severity is minimal „major“ because everybody who install it with encrypted fs and without knowledge this issue doesn't start the system.

Mayby it is for new issue name:
"System doesn't start after reboot if installation with encrypted filesystem is used."

For better analyze I'll attach screenshot.
You can see the (bad) order of the services…
(I hope you understand my English…)
sangala

sangala

2014-07-14 19:01

reporter  

CentOS7-rhbg-systemd.png (25,382 bytes)
CentOS7-rhbg-systemd.png (25,382 bytes)
tigalch

tigalch

2015-12-14 06:59

manager   ~0025050

Reported to be fixed with 7 (1511).

Issue History

Date Modified Username Field Change
2014-07-03 16:37 avij New Issue
2014-07-03 16:42 avij Note Added: 0020169
2014-07-03 22:50 avij Note Added: 0020174
2014-07-03 22:50 avij Description Updated View Revisions
2014-07-13 11:00 sangala Note Added: 0020409
2014-07-14 10:03 wolfy Note Added: 0020425
2014-07-14 10:04 avij Note Added: 0020426
2014-07-14 14:37 sangala Note Added: 0020427
2014-07-14 19:01 sangala Note Added: 0020431
2014-07-14 19:01 sangala File Added: CentOS7-rhbg-systemd.png
2015-12-14 06:59 tigalch Note Added: 0025050
2015-12-14 06:59 tigalch Status new => resolved
2015-12-14 06:59 tigalch Fixed in Version => 7.2.1511
2015-12-14 06:59 tigalch Resolution open => fixed