View Issue Details

IDProjectCategoryView StatusLast Update
0007323CentOS-7grub2public2014-08-28 19:42
Reportertps800 Assigned To 
Status assignedResolutionopen 
Product Version7.0-1406 
Summary0007323: After new install from DVD-Everything CentOS wont boot -- missing
DescriptionAfter a fresh install of CentOS-7 on VMware Workstation/VMware ESXi the system won't boot from HD, since grub is missing/not installed in a useful manner.
Steps To ReproduceClean your HD ("dd if=/dev/zero of=/dev/sda bs=4096 count=1024" should do the trick).
Insert the "Everything DVD"; boot from DVD.
Install CentOS-7: minimal system, bootloader on HD
Configure system, then reboot after removing DVD

System hangs reading mbr.
Additional InformationIt doesn't matter selecting to install bootloader or not. The bootloader isn't installed. I could not find a gpt-partition with flag "boot-grub" set. Maybe this was the problem because grub wasn't installed?

I've tried again, this time partitioning manually. Same result. Grub wasn't installed at all. Regardless of setting install bootloader or not.

Fix: boot from systemrescue cd or else, then install grub. Make sure you keep the created config file. After this step the system will boot from HD.

Same for an upgrade from CentOS-6: grub isn't installed and the old install is broken (Grub goes into rescue mode). You have to do it manually. After this step CentOS-7 will boot using the new grub version.
TagsNo tags attached.




2014-07-09 00:24

updater   ~0020248

Was this in BIOS or UEFI mode?


2014-07-09 06:02

reporter   ~0020257

BIOS-Mode. UEFI I did not test, because the first try it failed to upgrade from 7beta to 7. And the system tried on is real hardware without UEFI.


2014-07-09 09:01

manager   ~0020276

I can't reproduce the issue. Created a fresh VM with Everything-ISO, left the disk as it was suggested, pressed Reboot after it was done, and the VM booted fine.


2014-07-10 09:22

reporter   ~0020343

Tested again. Did you use SCSI for the HD? Using an IDE/ATA/SATA works. If you take an SCSI-HD with VMware Workstation it does not.
I've tried the same with real hardware now: IDE/ATA/SATA works out of the box, while SCSI installs, but won't boot afterwards. You may indeed boot from CDROM (systemrescuecd) into the installed system on HD. I did not test to change the installed kernel in spite of not being equipped with necessary SCSI modules to access the HD.

I could not test UEFI on real hardware, because this system is a bit older and does not have UEFI.


2014-07-10 21:33

reporter   ~0020368

VMware allows to install two different virtual SCSI adapters: BusLogic- and lsilogic-Adapters (the second is recomended). Both of them are not build into the kernel neither as module nor directly. Resulting in an unbootable system if you install on VMware Workstation using the defaults for RedHat Linux or CentOS.


2014-07-10 23:00

manager   ~0020371

The BusLogic driver is enabled in the centos-plus kernel. I wonder if it is possible to pull in this kernel from the centosplus repository during (or after) install.


2014-07-15 08:36

reporter   ~0020433

Hmmm! It is enabled for the kernel booted if you boot from DVD/CDROM.
It is not enabled for the kernel installed from DVD:
 - config-3.10.0-123.4.2.el7.x86_64:# CONFIG_SCSI_BUSLOGIC is not set
 - config-3.10.0-123.el7.x86_64:# CONFIG_SCSI_BUSLOGIC is not set

 - config-3.10.0-123.4.2.el7.x86_64:CONFIG_SCSI_MPT2SAS=m
 - config-3.10.0-123.4.2.el7.x86_64:CONFIG_SCSI_MPT2SAS_MAX_SGE=128
 - config-3.10.0-123.4.2.el7.x86_64:CONFIG_SCSI_MPT2SAS_LOGGING=y
 - config-3.10.0-123.4.2.el7.x86_64:CONFIG_SCSI_MPT3SAS=m
 - config-3.10.0-123.4.2.el7.x86_64:CONFIG_SCSI_MPT3SAS_MAX_SGE=128
 - config-3.10.0-123.4.2.el7.x86_64:CONFIG_SCSI_MPT3SAS_LOGGING=y
 - config-3.10.0-123.el7.x86_64:CONFIG_SCSI_MPT2SAS=m
 - config-3.10.0-123.el7.x86_64:CONFIG_SCSI_MPT2SAS_MAX_SGE=128
 - config-3.10.0-123.el7.x86_64:CONFIG_SCSI_MPT2SAS_LOGGING=y
 - config-3.10.0-123.el7.x86_64:CONFIG_SCSI_MPT3SAS=m
 - config-3.10.0-123.el7.x86_64:CONFIG_SCSI_MPT3SAS_MAX_SGE=128
 - config-3.10.0-123.el7.x86_64:CONFIG_SCSI_MPT3SAS_LOGGING=y

They are loaded if booting from DVD/CDROM, but not if booting from HD.
They are indeed loaded if I start the system from systemrescuecd,
booting into the installed CentOS7.

I could manage to boot from kernels installed via internet repositories by reinstalling grub with:

grub2-install /dev/sda

by the default install grub was not copied automatically to /boot/grub2, nor was it installed into the boot sector. grub.cfg wasn't generated either.

so here is what I had to do, to make CentOS7 boot from HD:
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

Rebooting made grub come up, but without any menu. At the moment I am forced to type "configfile (hd0,msdos1)/grub2/grub.cfg" every time I'll reboot.


2014-08-28 19:42

reporter   ~0020769

I had almost the same problem.
I'm installing CentOS-7 under VM Workstation 10.0.x.
The first time I've choosed "Mini server config" followed the installation procedure and everything went Okay, includinf rebooting from the disk.
Second time I've choosed server-virt & GUI. One more time everything went well, until I reboot at the end of the installation. I have the similar problems described on the previous posts... So I've one working and the other not...
even don't know how to repair it.
any ideas?
Thanks in advance

Issue History

Date Modified Username Field Change
2014-07-08 20:46 tps800 New Issue
2014-07-09 00:24 avij Note Added: 0020248
2014-07-09 06:02 tps800 Note Added: 0020257
2014-07-09 09:01 tigalch Note Added: 0020276
2014-07-09 12:51 tigalch Status new => feedback
2014-07-10 09:22 tps800 Note Added: 0020343
2014-07-10 09:22 tps800 Status feedback => assigned
2014-07-10 21:33 tps800 Note Added: 0020368
2014-07-10 23:00 toracat Note Added: 0020371
2014-07-15 08:36 tps800 Note Added: 0020433
2014-08-28 19:42 erix Note Added: 0020769