View Issue Details

IDProjectCategoryView StatusLast Update
0007327CentOS-7anacondapublic2014-11-23 01:33
Reportertoml Assigned To 
Status acknowledgedResolutionopen 
PlatformMacbook Pro Retina 
Product Version7.0-1406 
Summary0007327: Missing 'mactel-boot' package on DVD iso fails install on Macbook Pro
DescriptionTrying a minimal install on a Macbook Pro Retina gives an 'An unknown error has occurred' after hitting the Begin Installation button.

The detailed info shows a NoSuchPackage error being raised for 'mactel-boot', which doesn't seem to be packages on the DVD ISO.

Sorry, I can't submit the bug report or provide full stacktrace because the Macbook's network device isn't detected in the installer.

Steps To ReproduceAttempt to install from "DVD" iso image onto Mactel with EFI (Macbook Pro Retina here).
Additional InformationLooks similar to/same as for F17 which was fixed by adding mactel-boot to the DVD package comps.
TagsNo tags attached.


related to 0007244 acknowledged 'No such file or directory' error after pressing 'Begin Installation' on Apple iMac 
related to 0007585 new Having an hfs+ partition on the disk crashes the install process (failed to find hfsplus-tools) 
related to 0007622 new Can not install on system with HFS partition 




2014-07-09 07:26

administrator   ~0020266

Problem is that such packages (mactel-boot/etc) aren't included at all, so referencing it/those in the comps would not help.
Some anaconda components are coming from Fedora, but weren't modified completely to support Mac hardware (as obviously RHEL doesn't target those machines at all).
worth reading :


2014-07-09 07:31

updater   ~0020267

A slight problem with this is that mactel-boot does not seem to be available in RHEL, and by extension, neither in CentOS..


2014-07-09 07:36

reporter   ~0020268

Hmm, I found the same thing after lodging the bug (that the mactel packages simply don't exist in RHEL). Seems like this may be a lost cause and this bug could be closed.


2014-07-09 09:35

updater   ~0020279

Looks like both Fedora 19 and Fedora 20 mactel-boot packages are installable in CentOS 7. I have no idea if they actually work.

If you want to give them a shot, try adding either of these repositories during install (via the Installation Source page, Additional repositories section). Remember to configure networking prior to attempting to add the additional repository. If networking is not configured and you attempt to add these repositories, the Software Selection page does not show any package groups, even if installing from DVD.

The Fedora 19 version is probably closer to CentOS 7's codebase, but the Fedora 20 version is slightly newer. You can try both, perhaps start with the 20 version first.

I give absolutely no warranties that this would work. If you have any important data on your laptop, back that up first. You have been warned. Here be dragons.


2014-07-09 10:25

updater   ~0020281

Sorry, I just realised you can't use these additional repositories if your network device isn't detected by the installer. Perhaps some USB network adapter might help in this situation.


2014-08-06 18:42

reporter   ~0020600


I can't thank you enough! You gave me the last piece of the puzzle, which is to install CentOS 7 / RHEL on Mactel hardware. By using the f19 repo from the link you provided, i have finally managed to do it sucessfully. As a side note, to whoever attempts this, you have to do it as follows:

* Choose not to install grub
* Add as an "Additional repository" during installation.
* After installation is completed, boot rescue mode
* chroot to your install
* Download / install latest rEFInd RPM from it's homepage (

After exiting rescue mode and rebooting, rEFInd will find your CentOS installation and boot it just fine

Also worth a read:


2014-09-07 10:48

reporter   ~0020851

Hi avij & msaraiva,

Thank you for you excellent problem solving as I have just been bitten by this as well; I added the additionally repository path and the installation finished with no errors although it did seem to take a while; does adding the extra repo make it go slower .. just wondering.

Anyway I'm still not at the finish line … please can you help?

I cannot get rEFInd to recognise the new install, it only sees apple. After installing RHEL 7 I installed rEFInd from a usb stick with a terminal window in OSX, thus:

  /Volumes/usb/refind-bin-o.8.3/ --esp --alldrivers

I renamed the instal directory from refind to BOOT and also the file refind_x64.efi to bootx64.efi to solve startup delay.

So now I have /Volumes/esp/EFI/BOOT/bootx64.efi

I also amended the refind.conf file to to scan the /EFI/BOOT/driver_x64 directory in the hope that the drivers should be able to directly see the boot loader in the /boot directory ….

So now it reboots and the rEFI boot manager screen come up fast but I do not see the new Linux install. I have clearly overlooked a few things please please can you elaborate on exactly what other steps you did after the linux install.

So I see you went into rescue mode whereas I installed rEFInd from OSX terminal window …. I wasn't sure how to get into rescue mode ..Anyway I'm a bit lost now and would appreciate some help.

Many many thanks,


2014-10-17 09:46

updater   ~0021170

Unfortunately I can't help with the rEFInd issues, but I'll just state here for the record and to help others that my repos mentioned above also contain hfsplus-tools, which may also be needed by the installer.


2014-10-17 12:12

reporter   ~0021172


Sorry for the late response. Anyway, you have to install rEFInd from Linux, so please boot into the rescue environment and chroot to your installed system. Also, sometimes you have to wait a bit for the other options to show up on the rEFInd boot menu.


2014-11-22 02:26

reporter   ~0021786

Been spending the better part of this evening trying to install on my Macbook Pro and finally I found this. Awesome. I'm trying to add the mactel-boot repository, but when I do I just get an error message that "Source changed - please verify selection" and where I normally only have the minimal install to choose from, I now don't even have that. Any ideas?


2014-11-22 15:28

updater   ~0021789

fred: That happens when you try to enable additional repositories, but don't have networking set up. Try setting up networking first, then add the repo. The user interface designer in me has rather violent thoughts about this oddity.


2014-11-22 19:28

reporter   ~0021790

avij: I assumed as much and tried adding ATrpms repo to test, which worked like it should, but the mactel-boot repo is disabled every time I exit the installation sources section. I find it it weird since I can browse the repo in a browser. But I'm a newbie here so there is probably something I haven't figured out yet, but I have ruled out lack of working network anyway. Thanks for taking your time.


2014-11-22 20:28

updater   ~0021791

fred: Oh, perhaps it has something to do with IPv6. is IPv6-enabled, is not. See if it works better with IPv6 entirely disabled in the network config.


2014-11-23 01:33

reporter   ~0021792

avij: Yeah, it worked when I disabled IPv6, but unfortunately the installer still crashed. I've given up for now and installed Fedora 20 until an official fix is issued and will run CentOS in the cloud and in VMWare on OS X on my other macbook in the meantime. Thanks so much for your help.

Issue History

Date Modified Username Field Change
2014-07-09 06:17 toml New Issue
2014-07-09 07:26 arrfab Note Added: 0020266
2014-07-09 07:31 avij Note Added: 0020267
2014-07-09 07:36 toml Note Added: 0020268
2014-07-09 09:35 avij Note Added: 0020279
2014-07-09 09:45 avij Relationship added related to 0007244
2014-07-09 09:48 avij Status new => acknowledged
2014-07-09 10:25 avij Note Added: 0020281
2014-08-06 18:42 msaraiva Note Added: 0020600
2014-09-07 10:48 JamesG Note Added: 0020851
2014-10-17 09:46 avij Note Added: 0021170
2014-10-17 09:52 avij Relationship added related to 0007585
2014-10-17 09:53 avij Relationship added related to 0007622
2014-10-17 12:12 msaraiva Note Added: 0021172
2014-11-22 02:26 fred Note Added: 0021786
2014-11-22 15:28 avij Note Added: 0021789
2014-11-22 19:28 fred Note Added: 0021790
2014-11-22 20:28 avij Note Added: 0021791
2014-11-23 01:33 fred Note Added: 0021792