2018-01-23 17:27 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0007341CentOS-7-OTHERpublic2017-12-22 02:14
Product Version7.0-1406 
Target VersionFixed in Version 
Summary0007341: images/pxeboot/vmlinuz unbootable
DescriptionThe images/pxeboot/vmlinuz shipped with CentOS-7.0-1406-x86_64-Everything.iso and CentOS-7.0-1406-x86_64-DVD.iso is unbootable.

If I keep everything from my CentOS-7.0-1406 and my PXE boot configuration except for images/pxeboot/vmlinuz and instead use the vmlinuz from rhel-server-7.0-x86_64-dvd.iso everything works.

The pxelinux.0 loader never gets past the "Loading kernels/centos70/vmlinuz.....", ie it never even tries to load initrd.img. After some time the boot loader gives up and writes "Boot failed".
Steps To ReproduceSetup PXE boot environment, point to the CentOS-7.0-1406 images/pxeboot/vmlinuz and try to PXE boot a machine with it.
TagsNo tags attached.
Attached Files




roeschu (reporter)

I use the vmlinuz and initrd.img from a official mirror (ex. rsync://mirror.netcologne.de/centos/7) for Kickstarting:

[root@kickstarter01 pxeboot]# ls -la
-rw-r--r--. 2 804 804 34935964 4. Jul 17:57 initrd.img
-rw-r--r--. 2 804 804 33127644 4. Jul 17:59 upgrade.img
-rwxr-xr-x. 2 804 804 4902656 30. Jun 14:17 vmlinuz

This works for Kickstarting.


TrevorH (developer)

What is your hardware? Specifically which processor, how much RAM and what disk controller?


tsondergaard (reporter)

It fails to work on both of these

* VMWare player 6.0.3 VM running on i7 860, VM has 4 GiB memory
* Core i7 -3770, 16 GiB memory

I don't know about the disk controller.


TrevorH (developer)

I think you have another problem somewhere. I checked with the GA files from the non-everything DVD, copied from images/pxeboot/[iuv]* to my /srv/tftp/images/centos/x86_64/7.0/ directory and it works fine for me.

md5sum /srv/tftp/images/centos/x86_64/7.0/*
b643733cacd1a8b6715f00ba669e69ed /srv/tftp/images/centos/x86_64/7.0/initrd.img
b76341074e5d68b4e315d00b29fb11fb /srv/tftp/images/centos/x86_64/7.0/upgrade.img
1f8a3bc847320572e531251fbf7e546b /srv/tftp/images/centos/x86_64/7.0/vmlinuz

Dates and time and filesizes match those in your first reply from roeschu.


tsondergaard (reporter)

Everything else being the same using one of these two kernels is the difference between not booting and booting. Is there any other information I can provide?

1f8a3bc847320572e531251fbf7e546b os/CentOS-7.0-x86_64/images/pxeboot/vmlinuz
8edbd2e995aa094b8fb850eb1b0a9399 os/RHEL7.0-x86_64/images/pxeboot/vmlinuz


isomer2004 (reporter)

this is my pxe label and its working fine:

        MENU LABEL CentOS 7
        KERNEL images/centos7/vmlinuz
        APPEND initrd=images/centos7/initrd.img ramdisk_size=9216 askmethod root=live: repo=

and i use ~/images/pxeboot/vmlinuz


tsondergaard (reporter)

I tried with isomer2004's configuration and it doesn't work. I'm using

I am using pxelinux.0 and menu.c32 from syslinux-4.05-7.fc20.x86_64.


isomer2004 (reporter)

selinux enabled?


tsondergaard (reporter)

selinux is enabled on the tftp/nfs server. It is running in Permissive mode. I can't imagine it makes a difference.


isomer2004 (reporter)

this is how i setup my pxeboot:

1. copy vmlinuz & initrd.img from ISO (CentOS-7.0-1406-x86_64-DVD.iso) /images/pxeboot/ to /var/lib/tftpboot/images
2. to avoid selinux issue, i have disabled it temporarily.
3. edit /etc/xinetd.d/tftp --> disable = no
4. restart xinetd
5. boot with pxe

my syslinux=syslinux-4.05-8.el7.x86_64


mbox1250 (reporter)

Has this been fixed yet? I tried ALL the suggestions in here and none worked for me. Trying to install centos7 using RIS and it just isn't working.


timbrigham (reporter)

I just wanted to voice the same issue. I'm running on a different version of pxelinux (older) and hosting the files on a Server 2008 box.

There does appear to be an issue within the vmlinuz file itself. Like the OP I tried multiple hardware platforms.

I tried the images from both images/pxeboot/" or "isolinux" on the ISO file and downloading the files straight from my local mirror.

The MD5 sum:
1f8a3bc847320572e531251fbf7e546b vmlinuz


morodin (reporter)

Unfortunately, I run into the same issue. Has there been any solution to the problem?
As with timbrigham, we are hosting the files on a Windows box. When looking at the TFTP-dump, i can see that the kernel vmlinuz is correctly transfered to the client system, however nothing happens afterwards.


davidhill (reporter)

Same problem here! Centos 7 wont pxeboot.


davidhill (reporter)

Can this be increased to Critical?

We can't automate deployment with PXEboots.


davidhill (reporter)

A workaround would be to boot with the ISO (DVD) and then type linux ks=http://something/something/somethingelse.cfg ip=dhcp and it would work but... this should be fixed ASAP.


claudiu@cccla.com (reporter)


I am having a similar issue:

The installation gets stuck after downloading vmlinuz file from tftp.

My setup Win2k8 server with pxelinux: <-- i don't remember pxelinux version

booting from Vmware 5.5 virtual machine.

LABEL CentOS 7 x64


KERNEL images/7/images/pxeboot/vmlinuz
append initrd=images/7/images/pxeboot/initrd.img ks=

All other distros work fine,except Centos 7... i tried the files from LiveCD, pxeboot, etc... folders, no dice.

Windows log file for WDS says:
The Following Client completed TFTP Download:

Filename: boot\x64\images/7/images/pxeboot/vmlinuz

That is the latest log after a pxe boot, it looks like it may be the kernel...


skelbley (reporter)

I'm also encountering an identical issue using the CentOS-7.0-1406-x86_64-Minimal ISO. I'm booting from pxelinux on a WDS server. Will try replacing with the vmlinuz from the rhel-server-7.0-x86_64-dvd ISO to see if that fixes the issue.


skelbley (reporter)

Chiming in to report that using the RHEL 7 vmlinuz file got it moving. It later hung with "/dev/root does not exist", but that's still further than the CentOS 7 file made it. Also, in case it matters, my PXE client is an ESXi 5.5u2 VM.


KennethP (reporter)

I'm having exactly the same problem. Have also been trying with RHEL 7 vmlinuz, which makes it continue with loading initrd.img from CentOS 7.

But it fails with the same error as skelbley, "/dev/root does not exist."
I have been trying a lot of combinations, but still no luck.

Any ideas what to try from here?

My PXE client is a Dell M600.


TrevorH (developer)

The common factor so far seems to be using a Windows tftp server...


skelbley (reporter)

For the most recent posters, at least. I have 2k8 w/ WDS, but it sounds like the original poster was using a Linux tftp server. Didn't explicitly specify but theh'd mentioned selinux in permissive mode on their tftp/nfs server.


KennethP (reporter)

Oh yes, forgot to mention that. Im also Using 2K8 with WDS.
My PXE setup is also providing CentOS 5 and 6, but without any problems.


tru (administrator)

works for me with the following md5sum:
b643733cacd1a8b6715f00ba669e69ed /tftpboot/PXEClient/centos/7.0.1406/x86_64/initrd.img
1f8a3bc847320572e531251fbf7e546b /tftpboot/PXEClient/centos/7.0.1406/x86_64/vmlinuz

Theses md5sums match the ones in the CentOS-7.0-1406-x86_64-NetInstall.iso
[tru@sillage x86_64]$ md5sum /mnt/loop/images/pxeboot/*
b643733cacd1a8b6715f00ba669e69ed /mnt/loop/images/pxeboot/initrd.img
064652e5c5e03bdc96f7b7b10d1c5c61 /mnt/loop/images/pxeboot/TRANS.TBL
b76341074e5d68b4e315d00b29fb11fb /mnt/loop/images/pxeboot/upgrade.img
1f8a3bc847320572e531251fbf7e546b /mnt/loop/images/pxeboot/vmlinuz


label centos7
        menu label centos7 C7.x86_64
        kernel centos/7.0.1406/x86_64/vmlinuz
        APPEND initrd=centos/7.0.1406/x86_64/initrd.img ksdevice=link lang=en ip=dhcp kssendmac noipv6 syslog=10.x.y.1 method=http://10.x.y.1/pub/centos/7.0.1406/os/x86_64/


tru (administrator)

https://bugs.centos.org/view.php?id=7341#c21656 was with https://www.kernel.org/pub/linux/utils/boot/syslinux/syslinux-4.03.tar.bz2

I have just tried with pxelinux.0 from syslinux-4.05-8.el7.x86_64: works fine for me on my testbed (VirtualBox 4.3.16 guest):
 VBoxManage showvminfo pxe-c7 --machinereadable
ostype="Red Hat (64 bit)"



claudiu@cccla.com (reporter)

Made some progress...

Used vmlinuz from rhel-server-7.0-x86_64-boot.iso pxeboot folder.
Used initrd.img from centos 7 minimal.iso pxeboot folder.

I get an error at dracut: FATAL: No or empty root = argument

See attached image.


tru (administrator)

- could you try with the pxelinux.0/menu.c32 from the CentOS-7 syslinux rpm?
- there might be an issue (bad interaction) with the vmware hypervisors (workstation or esxi) -> what network card is used on your VMs?


claudiu@cccla.com (reporter)

did not try pxelinux.0/menu.c32 from the CentOS-7 syslinux rpm.
E1000 network card.

I got a solution:

I upgraded to Win Server 2012 Std R2, use vmlinuz and initrd.img from Centos 7 minimal install cd and it worked, i am guessing there is incompatibility between TFTP sever on win2k8 r2 and Centos 7 kernel.


Seb042 (reporter)

Tried with the pxelinu.0/menu.c32 from CentOS-7 syslinux rpm, same issue.
Network Card is VMXNET3.

Looking for patches at the Microsoft kb at the moment.


Seb042 (reporter)

Found a solution for windows 2008 R2.

Since 2008 R2 SP1 you have this key :

I put 512 (tftp packets will have a size of 512 bytes) and it works well now.


KennethP (reporter)

Interesting - how does your APPEND line look Seb042?


CommonCentOS (reporter)

Running PXE server on CentOS 7, cannot PXE boot CentOS 7.

kernel minimal/vmlinuz
#append file=minimal/initrd.img method=
#append initrd=minimal/initrd.img inst.stage2=hd:LABEL=CentOS\x207\x20x86_64
append initrd=minimal/initrd.img inst.stage2=hd:LABEL=CentOS\x207\x20x86_64 nomodeset

dracut-initqueue[584]: Warning: Could not boot.
dracut-initqueue[584]: Warning: /dev/root does not exist


Seb042 (reporter)

@KennethP: didn't have to change my line. It looks like this:
APPEND initrd=images/centos/7/amd64/initrd.img ramdisk_size=10000 ksdevice=[mac address] ks=http://[web server]/ks/centos7kickstart repo=http://[web server]/depot/centos/7/amd64


vmeshche (reporter)

Issue still present in CentOS 7.4 (by the way and RedHat 7.4).
I download vmlinuz and initrd.img for pxeboot from official CentOS 7.4 ISO.
Then I puts it into flash drive with syslinux and tried to boot. I have attached screenshot.
After repeating of "dracut-initqueue ... starting timeout scripts" strings I have "Warning: /dev/root does not exists" and dracut console.


jbowen7 (reporter)

I was also experiencing this problem... Here's the solution:
Add inst.repo to your append line.

KERNEL centos7/vmlinuz
APPEND ks= initrd=centos7/initrd.img inst.repo= pointed to the extracted contents of the DVD.

Host: CentOS Linux release 7.4.1708
VM: CentOS Linux release 7.4.1708
TFTP: tftp-server-5.2-13.el7.x86_64
KERNEL: 43a395b89485ec908e6c0622273299c4 vmlinuz
INITRD: e46db99b8ccf289fa5f5541fcaeb78b2 initrd.img

Thanks: https://tobyheywood.com/warning-devroot-does-not-exist/
Sources: https://rhinstaller.github.io/anaconda/boot-options.html

-Issue History
Date Modified Username Field Change
2014-07-10 07:57 tsondergaard New Issue
2014-07-10 13:57 roeschu Note Added: 0020349
2014-07-10 18:34 TrevorH Note Added: 0020364
2014-07-11 11:21 tsondergaard Note Added: 0020387
2014-07-11 11:39 TrevorH Note Added: 0020390
2014-07-12 08:00 tsondergaard Note Added: 0020400
2014-07-12 08:51 isomer2004 Note Added: 0020401
2014-07-13 11:07 tsondergaard Note Added: 0020410
2014-07-13 15:49 isomer2004 Note Added: 0020411
2014-07-13 15:52 tsondergaard Note Added: 0020412
2014-07-13 15:56 isomer2004 Note Added: 0020414
2014-09-09 15:24 mbox1250 Note Added: 0020870
2014-09-15 17:00 timbrigham Note Added: 0020917
2014-11-04 13:46 morodin Note Added: 0021538
2014-11-10 19:49 davidhill Note Added: 0021627
2014-11-10 19:52 davidhill Note Added: 0021628
2014-11-10 19:59 davidhill Note Added: 0021629
2014-11-11 19:34 claudiu@cccla.com Note Added: 0021637
2014-11-11 21:03 skelbley Note Added: 0021638
2014-11-12 13:52 skelbley Note Added: 0021646
2014-11-12 15:11 KennethP Note Added: 0021650
2014-11-12 15:13 TrevorH Note Added: 0021652
2014-11-12 15:27 skelbley Note Added: 0021653
2014-11-12 15:31 KennethP Note Added: 0021654
2014-11-12 15:53 tru Note Added: 0021656
2014-11-12 16:23 tru Note Added: 0021657
2014-11-14 18:55 claudiu@cccla.com File Added: Dracut failure.jpg
2014-11-14 18:58 claudiu@cccla.com Note Added: 0021696
2014-11-14 22:36 tru Note Added: 0021704
2014-11-14 22:51 claudiu@cccla.com Note Added: 0021705
2015-01-22 11:53 Seb042 Note Added: 0022199
2015-01-27 13:43 Seb042 Note Added: 0022227
2015-01-27 14:45 KennethP Note Added: 0022229
2015-05-13 00:10 CommonCentOS Note Added: 0023038
2015-05-13 09:31 Seb042 Note Added: 0023043
2017-12-15 08:05 vmeshche File Added: CentOS7.4-Heypr-V-WS2008R2-boot-issue.png
2017-12-15 08:05 vmeshche Note Added: 0030751
2017-12-22 02:14 jbowen7 Note Added: 0030813
+Issue History