View Issue Details

IDProjectCategoryView StatusLast Update
0007355CentOS-7kernelpublic2014-08-11 15:24
Reporterkris+bugzilla@knigga.com Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0007355: Kernel update to 3.10.0-123.4.2.el7.x86_64 sets wrong default kernel in grub2
DescriptionWhen the update to kernel 3.10.0-123.4.2.el7.x86_64 is installed, grub2's default kernel is set to a bogus entry:

[root@localhost ~]# grub2-editenv list
saved_entry=CentOS Linux (3.10.0-123.4.2.el7.x86_64) 7 (Core)

The entry should be something like: 'gnulinux-3.10.0-123.el7.x86_64-advanced-30249ce6-ce2f-408b-bfc2-be572f9ab03f'

This can be found in /boot/grub2/grub.cfg:

[root@localhost ~]# egrep '^menuentry' /boot/grub2/grub.cfg
menuentry 'CentOS Linux (3.10.0-123.4.2.el7.x86_64) 7 (Core)' --class centos --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-3.10.0-123.el7.x86_64-advanced-30249ce6-ce2f-408b-bfc2-be572f9ab03f' {
menuentry 'CentOS Linux, with Linux 3.10.0-123.el7.x86_64' --class centos --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-3.10.0-123.el7.x86_64-advanced-30249ce6-ce2f-408b-bfc2-be572f9ab03f' {
menuentry 'CentOS Linux, with Linux 0-rescue-699a39a746084be2a66f490ed0dfdc9a' --class centos --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-0-rescue-699a39a746084be2a66f490ed0dfdc9a-advanced-30249ce6-ce2f-408b-bfc2-be572f9ab03f' {

The impact of this bug is that grub2 selects whichever legitimate menu entry it finds, which may or may not be the new kernel. Some of my machines are booting into the correct kernel, so are still booting in to the old one. To fix I run:

[root@localhost ~]# grub2-set-default 'gnulinux-3.10.0-123.el7.x86_64-advanced-30249ce6-ce2f-408b-bfc2-be572f9ab03f'
[root@localhost ~]# grub2-mkconfig -o /boot/grub2/grub.cfg
Steps To ReproduceInstall kernel-3.10.0-123.4.2.el7.x86_64
TagsNo tags attached.
abrt_hash
URL

Activities

toracat

toracat

2014-08-08 21:24

manager   ~0020630

There have been two kernel updates since this report. Are you still seeing the issue?
kris+bugzilla@knigga.com

kris+bugzilla@knigga.com

2014-08-08 21:30

reporter   ~0020631

3.10.0-123.4.4 looks ok. I haven't updated to 3.10.0-123.6.3 yet. I'll do that tonight and report back Monday.
kris+bugzilla@knigga.com

kris+bugzilla@knigga.com

2014-08-11 14:52

reporter   ~0020658

I think it's resolved.
tigalch

tigalch

2014-08-11 15:24

manager   ~0020659

Marking as RESOLVED per reporters feedback

Issue History

Date Modified Username Field Change
2014-07-10 20:16 kris+bugzilla@knigga.com New Issue
2014-08-08 21:24 toracat Note Added: 0020630
2014-08-08 21:24 toracat Status new => feedback
2014-08-08 21:30 kris+bugzilla@knigga.com Note Added: 0020631
2014-08-08 21:30 kris+bugzilla@knigga.com Status feedback => new
2014-08-11 14:52 kris+bugzilla@knigga.com Note Added: 0020658
2014-08-11 15:24 tigalch Note Added: 0020659
2014-08-11 15:24 tigalch Status new => resolved
2014-08-11 15:24 tigalch Resolution open => no change required
2014-10-20 12:14 shengvvvvv Issue cloned: 0007749