View Issue Details

IDProjectCategoryView StatusLast Update
0007359CentOS-7CentOS-7-Pluspublic2015-07-24 20:49
ReporterDanielJohnson 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version7.0-1406 
Target VersionFixed in Version 
Summary0007359: nVidia forcedeth driver not in CentOS 7 normal or Plus kernels
DescriptionThe nVidia "forcedeth" Ethernet NIC driver is absent in the CentOS 7 and CentOS 7 Plus kernels. Unless it would lead to known issues, I ask that it be enabled.
Additional InformationOpening bug with upstream vendor, hopefully they will add it to a future RHEL 7 release also.
TagsNo tags attached.
abrt_hash
URL

Relationships

has duplicate 0009131 resolvedtoracat I installed Centos 7 and the network card did not work. 

Activities

DanielJohnson

DanielJohnson

2014-07-11 15:34

reporter   ~0020391

Also opened in upstream: https://bugzilla.redhat.com/show_bug.cgi?id=1118821
toracat

toracat

2014-07-11 16:08

manager   ~0020392

Last edited: 2014-07-13 17:13

View 2 revisions

Will try in the next kernel update.

(Network driver support -> Ethernet driver support -> NVIDIA devices -> nForce ethernet support)

TrevorH

TrevorH

2014-07-11 22:36

manager   ~0020398

ELRepo already provide a kmod-forcedeth that can be used with el7. That should work on all EL7 versions: RHEL, CentOS, SL etc.
toracat

toracat

2014-07-31 11:57

manager   ~0020558

The latest kernel-plus (3.10.0-123.4.4.el7.centos.plus) has the forcedeth driver enabled.
mauro.mozzarelli

mauro.mozzarelli

2014-08-30 17:56

reporter   ~0020789

Thank you for adding the driver to kernel-plus, however the driver should be added to the CentOS CD/DVD distribution too since it becomes impossible to install CentOS 7 on popular workstations using NVDIA chipsets (like hp xw9400) without having to fit temporarily an extra Ethernet card!
toracat

toracat

2014-08-30 18:11

manager   ~0020790

Last edited: 2014-08-31 06:48

View 2 revisions

@DanielJohnson

What is the status of the BZ you filed?

General note: forcedeth is one of the many drivers that have been removed when going from EL6 to EL7.

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Migration_Planning_Guide/sect-Red_Hat_Enterprise_Linux-Migration_Planning_Guide-Removed_Packages.html#sect-Red_Hat_Enterprise_Linux-Migration_Planning_Guide-Removed_Packages-Removed_Drivers

We'll see if RH agrees to add any of them back upon request from users.

DanielJohnson

DanielJohnson

2014-08-31 04:23

reporter   ~0020795

Terribly sorry, I thought the RedHat link was accessible by the general public. This was their only response:
=================
 Neil Horman 2014-07-11 16:33:46 EDT

Actually, the CONFIG_NET_VENDOR_NVIDIA option is unset, and that is done intentionally as we decided to phase out support for some older drivers that don't have much hardware in circulation anymore. If you feel this is in error, please open a support ticket with Red Hat Support to build a case for re-enablement.

Status: NEW ? CLOSED
Resolution: --- ? NOTABUG
Last Closed: 2014-07-11 16:33:46
=================

So it looks like, unless we get someone [with an RH support contract?] to make a good case for re-enabling these we'll just be out of luck.
toracat

toracat

2014-08-31 07:09

manager   ~0020796

That response was more or less expected. Because your original request for the plus kernel was fulfilled, I'm going to close this ticket as 'resolved'.

Issue History

Date Modified Username Field Change
2014-07-11 15:24 DanielJohnson New Issue
2014-07-11 15:34 DanielJohnson Note Added: 0020391
2014-07-11 16:08 toracat Note Added: 0020392
2014-07-11 16:08 toracat Status new => assigned
2014-07-11 22:36 TrevorH Note Added: 0020398
2014-07-13 17:13 toracat Note Edited: 0020392 View Revisions
2014-07-31 11:57 toracat Note Added: 0020558
2014-08-30 17:56 mauro.mozzarelli Note Added: 0020789
2014-08-30 18:11 toracat Note Added: 0020790
2014-08-31 04:23 DanielJohnson Note Added: 0020795
2014-08-31 06:48 toracat Note Edited: 0020790 View Revisions
2014-08-31 07:09 toracat Note Added: 0020796
2014-08-31 07:10 toracat Status assigned => resolved
2014-08-31 07:10 toracat Resolution open => fixed
2014-10-20 12:14 shengvvvvv Issue cloned: 0007740
2015-07-24 20:49 toracat Relationship added has duplicate 0009131