View Issue Details

IDProjectCategoryView StatusLast Update
0007363CentOS-7kernelpublic2014-08-05 10:42
Reporterisomer2004 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version7.0-1406 
Summary0007363: centos 7 wont boot into single user mode
Descriptionqemu-img-1.5.3-60.el7_0_0.2.x86_64
qemu-kvm-1.5.3-60.el7_0_0.2.x86_64
ipxe-roms-qemu-20130517-5.gitc4bce43.el7.noarch
libvirt-daemon-driver-qemu-1.1.1-29.el7.x86_64
qemu-kvm-common-1.5.3-60.el7_0_0.2.x86_64

linux16 /vmlinuz-3.10.0-123.4.2.el7.x86_64 root=/dev/mapper/root-root ro rd.lvm.lv=root/root rd.lvm.lv=root/usr crashkernel=auto vconsole.keymap=us vconsole.font=latarcyrheb-sun16 rd.lvm.lv=swap01/swap rhgb quiet LANG=en_US.UTF-8 single
        initrd16 /initramfs-3.10.0-123.4.2.el7.x86_64.img


above boot parameters wont boot into single user mode. we need to edit fstab, since we have problem with fstab, one of cifs is dead and console thrown:
[ 249.762250] systemd[1]: Found dependency on NetworkManager-wait-online.service/start
[ 309.765091] systemd[1]: Found dependency on basic.target/start
[ 369.767088] systemd[1]: Breaking ordering cycle by deleting job paths.target/start
[ 429.769091] systemd[1]: Job paths.target/start deleted to break ordering cycle starting with basic.target/start
[ 489.773088] systemd[1]: Found ordering cycle on basic.target/start
[ 549.775098] systemd[1]: Found dependency on sockets.target/start


However we are still unable to boot into single user mode.
Steps To Reproduceappend linux grub with single .
TagsNo tags attached.
abrt_hash
URL

Activities

toracat

toracat

2014-07-12 12:40

manager   ~0020402

It says "Rescue Mode" instead of 'single user mode' when booted with "single" appended on the 'linux16' line. And it asks for root password.

Or, if you can boot the system at all, try running 'systemctl rescue' and reboot.
isomer2004

isomer2004

2014-07-12 13:30

reporter   ~0020403

hi toracat,

the system wont boot at all its stucked at below dependencies error even with singe appended to the linux16.

[ 249.762250] systemd[1]: Found dependency on NetworkManager-wait-online.service/start
[ 309.765091] systemd[1]: Found dependency on basic.target/start
[ 369.767088] systemd[1]: Breaking ordering cycle by deleting job paths.target/start
[ 429.769091] systemd[1]: Job paths.target/start deleted to break ordering cycle starting with basic.target/start
[ 489.773088] systemd[1]: Found ordering cycle on basic.target/start
[ 549.775098] systemd[1]: Found dependency on sockets.target/start.


Does single means it will bypass all network and its dependent?
isomer2004

isomer2004

2014-07-12 13:40

reporter   ~0020404

this is solved. eventually after one hour it will boot into maintenance. I guess when single is append, it will bypass all network dependencies and boot into non-networking environment but that is not the case here,

Feel free to close this as resolved if it is by design, that it will trying to mount network storage even single mode appended.


Thanks for prompt reply.
Maska

Maska

2014-08-05 10:34

reporter   ~0020588

this is not error, please close.
root passw reset in RHEL/Centos 7 is just done in different way than we are used to:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/sec-Terminal_Menu_Editing_During_Boot.html#sec-Recovering_Root_Password

user1999

2014-08-05 10:42

  ~0020589

For what it's worth, init=/bin/bash was always an option, in all previous releases of RH & RHEL ( and CentOS)

Issue History

Date Modified Username Field Change
2014-07-12 08:46 isomer2004 New Issue
2014-07-12 12:40 toracat Note Added: 0020402
2014-07-12 13:30 isomer2004 Note Added: 0020403
2014-07-12 13:40 isomer2004 Note Added: 0020404
2014-08-05 10:34 Maska Note Added: 0020588
2014-08-05 10:42 user1999 Note Added: 0020589
2014-08-05 10:42 user1999 Status new => closed
2014-08-05 10:42 user1999 Resolution open => no change required