View Issue Details

IDProjectCategoryView StatusLast Update
0007374CentOS-7firefoxpublic2014-07-15 23:17
Reporterad5mq Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status feedbackResolutionreopened 
PlatformDell Vostro 1510OSCentosOS Version7
Product Version7.0-1406 
Summary0007374: Changing default search providerin Firefox causes instant fatal crash/hang
DescriptionDropping selector in Firefox and attempting to select anything except default (??!!) Amazon search provider causes display to disappear; massive disk activity, massive CPU activity (presumed from fan running at full speed for more than a minute followed by no activity of any kind. The only method I have found to recover form this state is to remove the battery. It's pretty unaceptable for a browser setting to make the entire O/S unusable
Steps To ReproduceInstall default centos 7 - software development workstation profile, start Firefox attempt to change default search provider.
TagsNo tags attached.
abrt_hash
URL

Activities

ad5mq

ad5mq

2014-07-14 19:28

reporter  

dmesg.old (57,575 bytes)
tigalch

tigalch

2014-07-15 17:27

manager   ~0020434

I've jumped through 6 or 7 of the provided search engines, and nothing of those things happened. Can you maybe try on another HW or a VM?
ad5mq

ad5mq

2014-07-15 19:03

reporter   ~0020435

This appears to be an unexpected interaction between the browser and a Broadcom network driver. When I reported the bug I had the default Broadcom wifi adapater installed (no driver could load for it Broadcom BCM94312MCG) and was connected via wired ethernet. I have now replaced the non-functioning Broadcom module with a supported Realtek module and the problem has disappeared. Not sure why this would break search engine provider.
Might be nearly impossible to reproduce without the hardware so I have no problem with closing this as "can't reproduce"; incidentally I tried it again in a VirtualBox VM and couldn't reproduce it either.
tigalch

tigalch

2014-07-15 20:04

manager   ~0020436

Thanks for your feedback. I will mark this bug as closed.

user1999

2014-07-15 23:17

  ~0020440

If the problem can be reproduced at will when the BRCM card is present, we still have a bug which should get fixed by upstream. The kernel should not go nuts no matter what happens in the browser

Issue History

Date Modified Username Field Change
2014-07-14 19:28 ad5mq New Issue
2014-07-14 19:28 ad5mq File Added: dmesg.old
2014-07-15 17:27 tigalch Note Added: 0020434
2014-07-15 19:03 ad5mq Note Added: 0020435
2014-07-15 20:04 tigalch Note Added: 0020436
2014-07-15 20:04 tigalch Status new => closed
2014-07-15 20:04 tigalch Resolution open => unable to reproduce
2014-07-15 23:17 user1999 Note Added: 0020440
2014-07-15 23:17 user1999 Status closed => feedback
2014-07-15 23:17 user1999 Resolution unable to reproduce => reopened