View Issue Details

IDProjectCategoryView StatusLast Update
0007377CentOS-7screenpublic2014-07-16 09:58
ReporterNightlydev Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version7.0-1406 
Summary0007377: "screen is terminating" for non-root users.
DescriptionScreen is not working for non-root users.

[nightlydev@mainframe ~]$ screen
[screen is terminating]

I have the good permissions (I think) for the screen folder :

[nightlydev@mainframe ~]$ ls -la /var/run/screen/S-nightlydev
total 0
drwx------ 2 nightlydev nightlydev 40 Jul 15 22:06 .
drwxrwxr-x 4 root screen 80 Jul 9 19:39 ..

[root@mainframe ~]# ls -alh /usr/bin/screen
-rwxr-sr-x 1 root screen 465K Jun 10 02:30 /usr/bin/screen

Steps To ReproduceJust launch screen as a non-privilegied user.
Additional InformationUsing CentOS Linux release 7.0.1406 (Core), kernel 3.10.23-xxxx-std-ipv6-64 #1 SMP - SELinux disabled.
TagsNo tags attached.
abrt_hash
URL

Activities

avij

avij

2014-07-15 21:51

updater   ~0020437

Last edited: 2014-07-15 21:52

Is this reproducible with a CentOS kernel as well?

Nightlydev

Nightlydev

2014-07-16 09:20

reporter   ~0020444

Not reproducible with CentOS default kernel. What can be the cause ?

user1999

2014-07-16 09:58

  ~0020445

Your modified kernel does not include some needed capabilities. Please report the problem to those who provided that kernel or use the stock centos kernel instead of that one.

Issue History

Date Modified Username Field Change
2014-07-15 20:11 Nightlydev New Issue
2014-07-15 21:51 avij Note Added: 0020437
2014-07-15 21:52 avij Note Edited: 0020437
2014-07-16 09:20 Nightlydev Note Added: 0020444
2014-07-16 09:58 user1999 Note Added: 0020445
2014-07-16 09:58 user1999 Status new => closed
2014-07-16 09:58 user1999 Resolution open => no change required