View Issue Details

IDProjectCategoryView StatusLast Update
0007392CentOS-7[All Projects] generalpublic2014-08-03 07:26
ReporterDon 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86_64OSCentOSOS Version7
Product Version7.0-1406 
Target VersionFixed in Version 
Summary0007392: "Server with GUI" environment loads libreoffice
DescriptionI loaded a system from the CentOS-7.0-1406-x86_64-Everything.iso DVD selecting to load only the "Server with GUI" enviroment group. The libreoffice group (office-suite) gets loaded. I can't even deslect the office-suite explicitly by using the following in my kickstart file:

%packages
@^graphical-server-environment
-@office-suite
-libreoffice*
%end

I have been studying the repodata/*-c7-x86_64-comps.xml file. For all the groups of which office-suite is a member, office-suite is in the optionlist not the grouplist. So this should mean office-suite is an option right? Not mandatory or default. So why is it loaded? I could be mistaken, but this seems like a bug to
me.
Steps To ReproduceUse the kickstart packages code section provided above.
TagsNo tags attached.
abrt_hash
URL

Activities

Don

Don

2014-07-22 02:29

reporter   ~0020495

On deeper investigation I found that the "graphical-server-environment" loads the group "gnome-desktop" which in turn loads the package "unoconv". "unoconv" has a dependency of much of libreoffice-*.

I tried loading a graphical-server-environment from the upstream server DVD, rhel-server-7.0-x86_64-dvd.iso . This resulted in libreoffice not being loaded. On digging into this, it appears the unoconv package is not on the DVD.

So there is a difference in the behaviour between CentOS-7.0-1406-x86_64-Everything.iso and rhel-server-7.0-x86_64-dvd.iso when loading the "Server with GUI" environment. But I don't think the bug is on CentOS' side.
Don

Don

2014-08-03 02:36

reporter   ~0020574

This ticket can be closed. Sorry to report something that turns out not to be a bug.

Issue History

Date Modified Username Field Change
2014-07-18 07:55 Don New Issue
2014-07-22 02:29 Don Note Added: 0020495
2014-08-03 02:36 Don Note Added: 0020574
2014-08-03 07:25 wolfy Status new => closed
2014-08-03 07:26 wolfy Resolution open => no change required