View Issue Details

IDProjectCategoryView StatusLast Update
0007400CentOS-7kernelpublic2014-10-27 18:42
Reporterdougmc Assigned To 
Status newResolutionopen 
PlatformDell PowerEdge 2850OSCentos 7.0OS VersionCentOS 7.0
Product Version7.0-1406 
Summary0007400: CentOS 7.0 installer does not see PERC 4e/Di RAID card, but CentOS 5.x and 6.x installed and worked fine on it
DescriptionTrying to install CentOS 7.0 on a Dell PowerEdge 2850 with a PERC 4e/Di RAID card with all drives installed as one logical drive (raid 5, if it matters.)

The CentOS 7.0 installer does not see the device at all. Alas, I did not save the dmesg output for y'all, but I can go back and get it if needed.

CentOS 6.5 works fine on this hardware. CentOS 6.5 reports this for it in the dmesg output --

DMI: Dell Computer Corporation PowerEdge 2850/xxx, BIOS A05 01/09/2006
megaraid cmm: (Release Date: Sun Jul 16 00:01:03 EST 2006)
megaraid: (Release Date: Thu Nov 16 15:32:35 EST 2006)
megaraid: probe new device 0x1028:0x0013:0x1028:0x016d: bus 2:slot 14:func 0
  alloc irq_desc for 46 on node -1
  alloc kstat_irqs on node -1
megaraid 0000:02:0e.0: PCI INT A -> GSI 46 (level, low) -> IRQ 46
megaraid: fw version:[521X] bios version:[H430]
scsi2 : LSI Logic MegaRAID driver
scsi[2]: scanning scsi channel 0 [Phy 0] for non-raid devices
scsi 2:0:6:0: Processor PE/PV 1x6 SCSI BP 1.0 PQ: 0 ANSI: 2
scsi[2]: scanning scsi channel 1 [Phy 1] for non-raid devices
scsi[2]: scanning scsi channel 2 [virtual] for logical drives

lspci says this about it --
02:0e.0 RAID bus controller: Dell PowerEdge Expandable RAID controller 4 (rev 06)

lshal says this about it --
udi = '/org/freedesktop/Hal/devices/pci_1028_13'
  info.linux.driver = 'megaraid' (string)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_330' (string)
  info.product = 'PowerEdge Expandable RAID controller 4' (string)
  info.subsystem = 'pci' (string)
  info.udi = '/org/freedesktop/Hal/devices/pci_1028_13' (string)
  info.vendor = 'Dell' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'pci' (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:02:0e.0' (string)
  pci.device_class = 1 (0x1) (int)
  pci.device_protocol = 0 (0x0) (int)
  pci.device_subclass = 4 (0x4) (int)
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:02:0e.0' (string)
  pci.product = 'PowerEdge Expandable RAID controller 4' (string)
  pci.product_id = 19 (0x13) (int)
  pci.subsys_product = 'PowerEdge Expandable RAID Controller 4e/Di' (string)
  pci.subsys_product_id = 365 (0x16d) (int)
  pci.subsys_vendor = 'Dell' (string)
  pci.subsys_vendor_id = 4136 (0x1028) (int)
  pci.vendor = 'Dell' (string)
  pci.vendor_id = 4136 (0x1028) (int)

Again, all of this data was collected under CentOS 6.5, not CentOS 7.0.

Since the install DVD kernel doesn't see the raid controller, anaconda cannot install to it. I don't know if the kernel that is installed has support for this device or not -- I just know that the install DVD doesn't seem to.

Sorry if "kernel" wasn't the ideal project to put this under. I'm not sure if I should have done that or "anaconda", but "kernel" seemed more correct.
TagsNo tags attached.




2014-07-25 14:19

reporter   ~0020533

I just tried to install CentOS 7 on a Dell 2850 with the same result.


2014-07-25 19:01

reporter   ~0020534

This is the expected result. The megaraid driver used here was deprecated/removed in 7. This was documented in the beta and rc release notes, but seems to be missing in the upstream production documentation. You could ask that the elrepo folks provide this driver, and then use the hardware via a driver update disk. It will not be fixable in the core distribution.


2014-07-25 19:45

reporter   ~0020535

Where exactly is it documented? I went looking for it and couldn't find it anywhere.

The RHEL 7 release notes mention the megaraid driver, but it just says that "The described restriction does not apply to LSI adapters that use the megaraid driver. Those adapters implement the RAID functions in the adapter firmware" -- i.e. for something that was removed, that's an odd thing to say.

That said, I don't have a copy of RHEL 7 to try, though I wouldn't expect any differences between it and CentOS 7.

And I've been unable to find the beta and rc release notes, though the CentOS 7.0 GA release notes don't seem to say anything about it.

This from the GA release notes is odd --

   6. Deprecated Features
   None, as this is the first release of CentOS-7.

... as I'd think they ought to also mention any features deprecated from 6.5.

In any event, I realize that this change almost certainly came from RedHat themselves and so it's not something y'all are likely to change, but I ran into the problem here so I documented it here.

But even so ... removing this driver makes little sense, as there are many machines out there using the associated hardware, machines that are (otherwise) more than capable of running the most modern operating systems.

The driver is certainly still there in the most recent Linux kernels, so why would it be disabled?

In any event, it probably should be mentioned in the CentOS 7 GA (and RHEL 7) release notes, and as far as I can tell it is not.


2014-07-26 04:45

reporter   ~0020537

This is the only place I can find the rc documentation currently mirrored. It lists the discontinued drivers. 4.4 has what you want I think.


2014-07-26 05:25

reporter   ~0020539

Thanks -- that's what I was looking for. Odd that they don't seem to include this information in the GA release notes.

Looks like my Poweredge 2850 uses megaraid_mbox, which is listed as removed.

The 6.x release notes listed it was deprecated --

So it's obviously not an accident, and it's been planned for a while. I do have to wonder why they did it -- it's an old card, yes, but it was well supported until now.

I see they've also removed aic7xxx and sym53c8xx -- I've used those cards a lot in the past, and in fact still use them to control tape drives. I guess what this means is that any machine I have that uses SCSI, I'll want to leave it at CentOS 6 or earlier.

Thanks for looking into this! Looks like this machine (and some others) will be sticking with CentOS 6.


2014-10-27 18:42

manager   ~0021418

CentOS 6 is supported until 2020, so you still have 6 years to go.

But if you wish to go for CentOS 7 at some point, as Evolution hinted, you could ask ELRepo if the driver can be built for el7.

Issue History

Date Modified Username Field Change
2014-07-19 01:23 dougmc New Issue
2014-07-25 14:19 mochouinard Note Added: 0020533
2014-07-25 19:01 Evolution Note Added: 0020534
2014-07-25 19:45 dougmc Note Added: 0020535
2014-07-26 04:45 Evolution Note Added: 0020537
2014-07-26 05:25 dougmc Note Added: 0020539
2014-10-27 18:42 toracat Note Added: 0021418