View Issue Details

IDProjectCategoryView StatusLast Update
0007405CentOS-7anacondapublic2014-12-12 22:35
Reporterjweage Assigned To 
Status newResolutionopen 
Product Version7.0-1406 
Summary0007405: Random anaconda kernel crashes on Intel J1900
DescriptionWhen attempting to install the CentoOS 7 netboot image from USB stick, I get random anaconda kernel crashes. This happens for all installation modes available from the boot menu. The crashes can be immediate up until just after getting the graphical installer screen. Sometimes there are kernel messages on the terminals, sometimes there aren't. I tried using two different USB sticks and both USB 2.0 and 3.0 ports with the same behavior.

The CentOS 6.5 netboot image installed without any issues.

This system uses an ASRock Q1900B-ITX motherboard with Intel J1900 CPU.
Steps To ReproduceWrite netboot iso to USB flash drive using dd. Boot from USB and attempt to install.
Additional InformationOutput from lspci:

00:00.0 Host bridge: Intel Corporation ValleyView SSA-CUnit (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation ValleyView Gen7 (rev 0c)
00:13.0 SATA controller: Intel Corporation ValleyView 6-Port SATA AHCI Controller (rev 0c)
00:14.0 USB controller: Intel Corporation ValleyView USB xHCI Host Controller (rev 0c)
00:1a.0 Encryption controller: Intel Corporation ValleyView SEC (rev 0c)
00:1b.0 Audio device: Intel Corporation ValleyView High Definition Audio Controller (rev 0c)
00:1c.0 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0c)
00:1c.1 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0c)
00:1c.2 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0c)
00:1c.3 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0c)
00:1d.0 USB controller: Intel Corporation ValleyView USB Enhanced Host Controller (rev 0c)
00:1f.0 ISA bridge: Intel Corporation ValleyView Power Control Unit (rev 0c)
00:1f.3 SMBus: Intel Corporation ValleyView SMBus Controller (rev 0c)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
TagsNo tags attached.



2014-07-20 00:15


Last edited: 2014-07-20 00:16

Did you verify the checksum of the iso prior to writing it to the USB stick?
Did you try the "Test this media and install" option (I assume you did, but I have to verify) ? If you did, did the media check pass ?



2014-07-20 01:56

reporter   ~0020481

Yes, I did both and both passed. The install progressed further when I selected the "Test this media and install" option. When I just did the normal install, the installer would crash almost immediately.

I also let memtest86 run for a while and no issues were reported.

I have the full install iso downloaded, so I may try that and see what happens.


2014-07-20 02:02


Last edited: 2014-07-20 02:04

That would be a good test, please do it. We might find out if it's an issue restricted to the netinstall or maybe your motherboard is not supported. To be honest random crashes usually rhyme with defective hardware, an error in the program usually manifest always in the same place so I am tempted to not blame anaconda yet.

Mind that for conclusive results, memtest needs to be run for more than "a while". And even then, running a PC in dual-channel mode might mask memory problems. Happened to me once, a system passed all memtest tests with flying honors until I left a single DIMM inside. As soon as I did that, memtest detected it as being defective.



2014-07-20 09:19

reporter   ~0020483

I have the same problem with ASRock AD2550B-ITX (Intel D2550 CPU with Intel GMA 500). This system is very similar to yours.

I think is a problem with X driver.
Installing with Anaconda GUI produce a Kernel Panic on shutdown and at bootloader install, but using Anaconda CLI installation works fine

You are using EFI Boot, right?


2014-07-20 17:00

reporter   ~0020484

I tried the full install ISO with the same result. I also tried using a serial port console to log the kernel messages and didn't get anything useful, both for normal and text mode installation. Crashes seemed completely random and switching to text mode didn't fix the issue. Sometimes I would see a kernel panic other times there would be a python error.

I also thought hardware problems initially, but I'm not convinced now. I let memtest86 run overnight (4 passes) with no errors reported. Single channel memory setup. CentOS 6.5 and Ubunto both run fine.

I'm using EFI boot.


2014-09-08 09:09

reporter   ~0020859

the same happened with us on j1900 and it's randomly crash after the first few minutes of use (usuably just after we login into X)


2014-09-08 18:13

manager   ~0020861

I would not completely eliminate the possibility of bad memory. In at least one incident in my case, running memtest overnight did not find any error. But it eventually found some errors after I extended the running time to > 24 hours.


2014-09-08 22:54

reporter   ~0020864

it's not a hardware problem. and since this kernel line option:
solve the problem for us i'm sure it's a kernel or intel's kernel module bug.


2014-09-08 23:42

manager   ~0020865

Perhaps, the OP and others reporting the issue may want to try and see if the intel_pstate=disable kernel option that worked for lfarkas also fixes the problem for them.
Tolbkni Kao

Tolbkni Kao

2014-09-23 15:13

reporter   ~0020984

Congratulations! Worked on ASRock Q1900M motherboard with Intel J1900 CPU after adding intel_pstate=disable kernel option.

Thank you very much!
Tolbkni Kao

Tolbkni Kao

2014-09-23 15:59

reporter   ~0020986

Ooops! Random kernel crashes again after installed whether intel_pstate=disable or not.
Tolbkni Kao

Tolbkni Kao

2014-09-27 06:13

reporter   ~0021013

Confirmed, that's another bug for Logitech Unify receiver.
intel_pstate=disable works fine!


2014-12-12 22:32

reporter   ~0021929

Same problem. intel_pstate=disable allows the install to continue, but after the install, rebooting hangs at "tsc : Fast TSC calibration failed". Turning off precision timer in bios has no effect. Machine requires a hard reset at this point.

I filed bug report on 11-29-14 about this.

Hardware is:

Gigabyte GA-J1800N-D2H Motherboard
Intel Dual-Core Celeron J1800 SoC (2.41Ghz) processor.
480GB Crucial SSD Drive

Issue History

Date Modified Username Field Change
2014-07-19 22:07 jweage New Issue
2014-07-20 00:15 user1999 Note Added: 0020480
2014-07-20 00:16 user1999 Note Edited: 0020480
2014-07-20 01:56 jweage Note Added: 0020481
2014-07-20 02:02 user1999 Note Added: 0020482
2014-07-20 02:04 user1999 Note Edited: 0020482
2014-07-20 09:19 pma61 Note Added: 0020483
2014-07-20 17:00 jweage Note Added: 0020484
2014-09-08 09:09 lfarkas Note Added: 0020859
2014-09-08 18:13 toracat Note Added: 0020861
2014-09-08 22:54 lfarkas Note Added: 0020864
2014-09-08 23:42 toracat Note Added: 0020865
2014-09-23 15:13 Tolbkni Kao Note Added: 0020984
2014-09-23 15:59 Tolbkni Kao Note Added: 0020986
2014-09-27 06:13 Tolbkni Kao Note Added: 0021013
2014-12-12 22:32 stariontech Note Added: 0021929