View Issue Details

IDProjectCategoryView StatusLast Update
0007446CentOS-7redhat-upgrade-toolpublic2014-09-10 11:04
Reportermaweos Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version7.0-1406 
Summary0007446: redhat-upgrade-tool fails when using md RAID1 partitions
DescriptionOn a system installed from scratch with Centos6, the disks were setup with md raid1 as such:
# cat /proc/mdstat
Personalities : [raid1]
md2 : active raid1 sda5[0] sdb5[1]
      387454784 blocks super 1.1 [2/2] [UU]
      bitmap: 2/3 pages [8KB], 65536KB chunk

md1 : active raid1 sdb2[1] sda2[0]
      67075968 blocks super 1.1 [2/2] [UU]
      bitmap: 1/1 pages [4KB], 65536KB chunk

md0 : active raid1 sdb1[1] sda1[0]
      102336 blocks super 1.0 [2/2] [UU]

redhat-upgrade-tool prepares the system for upgrade to Centos7.
When rebooting into the upgrade kernel, it cannot mount the paritions. From the error message it seems, the upgrade kernel can only handle version-0 superblocks. However Centos6 installer creates version-1 superblocks.
There is no way to convert the superblocks. Upgrade fails.
I could not save the actual logs, because USB also didnt work.
Steps To ReproduceInstall Centos6 with md-raid1 disks.

redhat-upgrade-tool --network 7.0 --instrepo ...somerepo...os/x86_64/ --force

reboot into upgrade kernel

Upgrade kernel cannot mount existing partitions.
Additional InformationUSB in the upgrade kernel also didnt work. So i could not save logs.
This was reproduced on two HP DL380pGen8 servers.
redhat-upgrade-tool is version 0.7.22-1
TagsNo tags attached.
abrt_hash
URL

Activities

maweos

maweos

2014-09-10 11:04

reporter   ~0020879

On a system with md version 0.9 partitions, the upgrade worked partially.
This system was installed with Centos5 installer, creating md-Raid1 version 0.9 partitions. Later it was upgraded to Centos6 via upgradeany method.

Upgrading this system to Centos7 with redhat-upgrade-tool worked partially.
The upgrade started, but the upgrade-kernel did not detect the md partitions.
In the F2 dracut console i did a "mdadm --assemble --scan", followed by "exit".
Then the upgrade process continued until finished.
However grub2 was not activated.

At reboot into the upgraded system, it hang for several minutes until giving a dracut shell. There "mdadm --assemble --scan", followed by "exit" continued the boot.

Then i manually activated grub2:
"grub2-mkconfig -o /boot/grub2/grub.cfg"
"dracut --force --mdadmconf"
"grub2-install /dev/sda"
"grub2-install /dev/sdb"

Hope this helps someone.

Issue History

Date Modified Username Field Change
2014-07-30 10:31 maweos New Issue
2014-09-10 11:04 maweos Note Added: 0020879