View Issue Details

IDProjectCategoryView StatusLast Update
0007455CentOS-6autofspublic2015-03-07 02:02
Reporterekacnet Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version6.5 
Summary0007455: Autofs not working correctly in LXC containers
DescriptionI have a Centos 6.5 64bits host with 32 bits LXC containers.

Inside the containers autofs blocks on lstat(...) calls.
Issue is also reported here:
http://comments.gmane.org/gmane.linux.kernel.containers.lxc.general/894

The proposed patch (once slightly adapted for 2.6.32-431) almost works but there is still something not ok.

Steps To ReproduceSetup autofs with NIS/NIS+
Configure autofs in the container
Try to list the volume ie. ls /mnt/<autofs_mountpoint>
TagsNo tags attached.

Activities

ekacnet

ekacnet

2014-08-28 05:13

reporter   ~0020761

mainline kernel works, git commit 6eaba35b437438988078efc92f1ef445a00cd7bc and fbff08706d12fcdb160604c4ba790df6707c32cb seems to fix the issue.

I applied them on 3.10 kernel and it works.

Works is needed in order to backport it to 2.6.32 it seems
toracat

toracat

2014-08-28 21:03

manager   ~0020770

Have you tried backporting the patches to the distro kernel (2.6.32-431.el6)?

We can patch the centosplus kernel. However, to get the fix into the distro kernel, the upstream (RHEL) kernel needs to be fixed first.
ekacnet

ekacnet

2015-03-07 02:02

reporter   ~0022483

I tried but I failed to backport the files, file have changed somehow between 2.6.32 and 3.10 ...

Issue History

Date Modified Username Field Change
2014-08-01 19:07 ekacnet New Issue
2014-08-28 05:13 ekacnet Note Added: 0020761
2014-08-28 21:03 toracat Note Added: 0020770
2015-03-07 02:02 ekacnet Note Added: 0022483