View Issue Details

IDProjectCategoryView StatusLast Update
0007497CentOS-7systemtappublic2014-08-25 12:23
ReporterKennyQiao Assigned To 
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
OSCentOS OS Version7 
Summary0007497: No debuginfo-* packages to support Systemtap on CentOS7
DescriptionI hit problems to use systemtap on CentOS 7 with failure to install required kernel-debuginfo-* packages.
# uname -r
3.10.0-123.4.4.el7.x86_64
# stap-prep
Need to install the following packages:
kernel-debuginfo-3.10.0-123.4.4.el7.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.clearvoiceone.com
* centosplus: mirror.cogentco.com
* extras: mirrordenver.fdcservers.net
* updates: mirror.steadfast.net
No package kernel-debuginfo-3.10.0-123.4.4.el7.x86_64 available.
Error: Nothing to do
package kernel-debuginfo-3.10.0-123.4.4.el7.x86_64 is not installed
problem installing rpm(s) kernel-debuginfo-3.10.0-123.4.4.el7.x86_64

Also failed to install kernel-debuginfo via yum:
# yum install kernel-debuginfo
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.clearvoiceone.com
* centosplus: mirror.hmc.edu
* extras: mirrordenver.fdcservers.net
* updates: mirror.steadfast.net
No package kernel-debuginfo available.
Error: Nothing to do
I tried to find those required debuginfo packages but only find one on http://debuginfo.centos.org/7/x86_64/
kernel-plus-debuginfo-3.10.0-123.el7.centos.plus.x86_64.rpm.

When I manually install this rpm and failed to find its dependency:
# rpm -ihv kernel-plus-debuginfo-3.10.0-123.el7.centos.plus.x86_64.rpm
warning: kernel-plus-debuginfo-3.10.0-123.el7.centos.plus.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID b6792c39: NOKEY
error: Failed dependencies:
kernel-plus-debuginfo-common-x86_64 = 3.10.0-123.el7.centos.plus is needed by kernel-plus-debuginfo-3.10.0-123.el7.centos.plus.x86_64

It seems no kernel-debufinfo-* packages available for CentOS7 now.
TagsNo tags attached.
abrt_hash
URL

Relationships

related to 0007451 resolvedkbsingh@karan.org Missing kernel-debuginfo package 
related to 0007516 resolvedkbsingh@karan.org RPM-GPG-KEY-CentOS-Debug-7 import fails 

Activities

toracat

toracat

2014-08-13 15:42

manager   ~0020677

kernel-debufinfo-* packages for C7 are there now. Can you check and confirm?
terrywang

terrywang

2014-08-20 00:49

reporter   ~0020716

Last edited: 2014-08-20 00:55

The debuginfo packages are now available after enabling debug repo by "yum-config-manager --enable debug".

However, when running "debuginfo-install kernel", it'll fail due to missing public key.But the key is actually there /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-7. Manually import the key "rpmkeys --import" didn't help.

Current workaround is to manually install the kernel-debuginfo-* packages for the running kernel.

======
# debuginfo-install kernel
Loaded plugins: fastestmirror, langpacks
enabling epel-debuginfo
Loading mirror speeds from cached hostfile
 * base: mirror.optus.net
 * centosplus: mirror.optus.net
 * epel: mirror.optus.net
 * epel-debuginfo: mirror.optus.net
 * extras: mirror.optus.net
 * updates: centos.mirror.serversaustralia.com.au
--> Running transaction check
---> Package kernel-debuginfo.x86_64 0:3.10.0-123.6.3.el7 will be installed
--> Processing Dependency: kernel-debuginfo-common-x86_64 = 3.10.0-123.6.3.el7 for package: kernel-debuginfo-3.10.0-123.6.3.el7.x86_64
---> Package yum-plugin-auto-update-debug-info.noarch 0:1.1.31-25.el7_0 will be installed
--> Running transaction check
---> Package kernel-debuginfo-common-x86_64.x86_64 0:3.10.0-123.6.3.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================
 Package Arch Version Repository Size
==============================================================================================================
Installing:
 kernel-debuginfo x86_64 3.10.0-123.6.3.el7 debug 247 M
 yum-plugin-auto-update-debug-info noarch 1.1.31-25.el7_0 updates 22 k
Installing for dependencies:
 kernel-debuginfo-common-x86_64 x86_64 3.10.0-123.6.3.el7 debug 39 M

Transaction Summary
==============================================================================================================
Install 2 Packages (+1 Dependent package)

Total size: 286 M
Installed size: 1.3 G
Is this ok [y/d/N]: y
Downloading packages:
warning: /var/cache/yum/x86_64/7/debug/packages/kernel-debuginfo-common-x86_64-3.10.0-123.6.3.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID b6792c39: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-7
GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-7 (0xF4A80EB5) is already installed
Importing GPG key 0xB6792C39:
 Userid : "CentOS-7 Debug (CentOS-7 Debuginfo RPMS) <security@centos.org>"
 Fingerprint: 759d 690f 6099 2d52 6a35 8cbd d0f2 5a3c b679 2c39
 Package : centos-release-7-0.1406.el7.centos.2.4.x86_64 (@updates)
 From : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-7
Is this ok [y/N]: y
Key imported successfully
Import of key(s) didn't help, wrong key(s)?


Public key for kernel-debuginfo-common-x86_64-3.10.0-123.6.3.el7.x86_64.rpm is not installed


 Failing package is: kernel-debuginfo-common-x86_64-3.10.0-123.6.3.el7.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-7

======

JohnnyHughes

JohnnyHughes

2014-08-25 12:23

administrator   ~0020741

You can not use kernel, you have to specify a specific kernel since there are usually more than ONE on the system at any one time.

So the correct command would be:

debug-install kernel-3.10.0-123.6.3.el7
JohnnyHughes

JohnnyHughes

2014-08-25 12:23

administrator   ~0020742

fixed in centos-release-7-0.1406.el7.centos.2.5.x86_64.rpm, now syncing to mirrors

Issue History

Date Modified Username Field Change
2014-08-13 01:43 KennyQiao New Issue
2014-08-13 15:40 toracat Description Updated
2014-08-13 15:42 toracat Note Added: 0020677
2014-08-13 15:45 toracat Relationship added related to 0007451
2014-08-13 15:46 toracat Status new => feedback
2014-08-20 00:49 terrywang Note Added: 0020716
2014-08-20 00:55 toracat Note Edited: 0020716
2014-08-20 00:59 toracat Relationship added related to 0007516
2014-08-25 12:23 JohnnyHughes Note Added: 0020741
2014-08-25 12:23 JohnnyHughes Note Added: 0020742
2014-08-25 12:23 JohnnyHughes Status feedback => resolved
2014-08-25 12:23 JohnnyHughes Resolution open => fixed
2014-10-20 12:14 shengvvvvv Issue cloned: 0007746